Can't change the default program to handle *.txt files on my phoneSupport

Last Updated:

  1. soumyasg

    soumyasg New Member This Topic's Starter

    Sep 8, 2010
    Likes Received:
    Hi all,

    Here's my problem: (Samsung Epic 4G; Android 2.1)

    When opening a text file (*.txt) it used to give me a list of apps and ask which one I wanted
    to use to open the file. For example I had 'Bluetooth', 'PrinterShare', 'DropBox', 'EverNote' etc which I could use to open that txt file. And this is standard for many other file types. Now the very first entry was called "File Editor" I think this is a native application for the Epic 4G.

    So last evening, I checked the 'Use by default' option and selected 'File Editor' as my handler. From this point on of course it does not ask me to choose the app to open txt files anymore. And this is expected.

    But I now want to remove 'File Editor' as my default for opening text files and want that list of options to show up. But I can't find a way to do that.

    I have tried Settings>Applications>Manage Applications but do not see 'File Editor" on that list.

    Any help will be greatly appreciated.



  2. mikeprovencher

    mikeprovencher New Member

    Jan 19, 2012
    Likes Received:
    I too have this problem, when using File Editor to edit notepad files, when I save in dropbox, the formatting is ignored ie; on android it looks like this:

    list item 1
    list item 2
    list item 3
    list item 4

    When I open from dropbox in notepad on my computer, formatting looks like this:

    list item 1list item 2list item 3list item 4

    which kind of makes my todo list unreadable.

    I'm thinking that if I could change my default text editor the formatting issue might go away. From Manage Applications File Editor does not show as a running application, but when I hold the HOME key, File Editor is one of the applications that is loaded, which is how I found out it's my default editor.

    Any help is much appreciated.

  3. Coucher

    Coucher New Member

    Sep 6, 2010
    Likes Received:
    Had this exact same problem and after a bit of digging found that "File Editor" is a part of Astro File Manager. So, clear the defaults for Astro File Manager and you'll have control of your *.txt file opening default back.

Share This Page