1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

Can't connect samsung fascinate to my pc to transfer filesSupport


  1. corazonflores

    corazonflores New Member

    first time I tried to connect my phone to my pc with usb cord. First it said unknown device and some how I got my pc to recognize it as my samsung. I go to my computer and it shows removable disk every time I plug the device in. when I click it tells me to insert disc. I have my.debugging on. usb settings are set for mass storage. When I connect the cord it tells me to mount and I click mount. when I connect it to my laptop it connects fine and I can transfer my files fine lap top is windows vista. The pc I am having trouble connecting to is xp. Can't figure out whats wrong

    Advertisement
    :
  2. PSkeptic

    PSkeptic Well-Known Member

    Download the Samsung drivers from here: Samsung

    Make sure your phone is NOT connected. Install the drivers. Then try to plug the phone in.

    If that doesn't work, unmount the SD card (Settings --> SD Card --> Unmount). Take the card out. Turn off phone. Turn phone back on. Once it's booted up all the way, put the card back in. Now try it on the computer.
    corazonflores likes this.
  3. speedfreak

    speedfreak Well-Known Member

    Do a search there is a long thread on this topic... Some phones just won't work after the DL09 update. Mine is one... I have done it all and had to root to get it connected
  4. AlissaLL3

    AlissaLL3 Well-Known Member


    I had to root my Fascinate to get my usb to work again after the OTA update to 09. Not really a big deal for me since I was planning to anyways, but not really fair or right, to force users to do so. BUT rooting is super simple and fun! =)
  5. corazonflores

    corazonflores New Member

    Thank you after being so frustrated your advise fixed my problem. I dont know which one but I did both before I tried again. Thanks again
  6. PSkeptic

    PSkeptic Well-Known Member

    Be forewarned, this seems like a temporary fix... I periodically have to step through it all again :(
  7. momoe65

    momoe65 New Member


    how did you root without usb connection???
Loading...

Share This Page