Can't connect to my pc via USB. Help!!Support


  1. alltexan2010

    alltexan2010 Member

    I have a Samsung Galaxy Indulge from Metro PCS. I am trying to connect it to my Dell laptop with Windows 7 Ultimate on it. I have downloaded every possible Samsung driver that I can find. Absolutely nothing lets me connect to my phone via USB. I have even tried different cables. I can however connect to my mom's XP pc, an hour away. That helps me little as I need to connect to my own. Can anyone give me any ideas? Has anyone else been able to connect to a Windows 7 machine? Thanks.

    Advertisement
    :
  2. astmd1655

    astmd1655 Well-Known Member

    I have an XP and an Xubuntu setup. On the XP box the only way I can get the Indulge to be seen is to remove the SDCard, turn the phone off, plug the cable into the computer and phone, and then power the phone on. Connects every time. The Xubuntu box it is seen every time with no issue.
    nomed1331 likes this.
  3. tiede

    tiede Well-Known Member

    Make sure the device is not setup to USB only.
    Under the settings screen, choose "ask every time".

    That's Settings >USB settings >Ask on connection
    that should help you with the SD removal + reboot problem.

    For the OP, try that suggestion as well, but do check your firewall settings. Firewalls, such as Comodo,have been getting increasingly restrictive lately, and might block such access if set on paranoid mode, or some equivalent setting.
  4. yogeneyo

    yogeneyo Active Member

    I had the same problem-metro claims that if you go to an authorized store,they will give you a cd with updated drivers-I chose to install ubuntu on my pc and have no problems anymore.
  5. I have Win 7/64 and had some issues too.
    Make sure you check settings/usb settings/ask on connection
    Try uninstalling the drivers with control panel/device manager, then restart the pc, then connect the phone again.
    What are you trying to do?
    There might be an easier way, like just connecting the sdcard by itself.
  6. Reaper man

    Reaper man Well-Known Member

    Sometimes using another port works best.
  7. glen1944

    glen1944 New Member


    I know, I have 2 ports that the phone just doesn't like and others it works well on
  8. deuce947

    deuce947 Active Member

    I have the SCHR910 and am running win7x64. Mine also won't connect. Originally when I plugged the phone into pc, software and driver installed w/o a problem. Shortly after I installed pdanet, my pc stopped recognizing my phone. I tried installing many different samsung drivers, formatting sd card, resetting phone to factory default, resetting pc to restore point, toggling between development on and off, ask on connection, kies, mass storage, and nothing has worked. After reading this thread, I uninstalled all samsung drivers, restarted my pc, plugged phone in and it said driver not found. Is there any update I can download to my phone to make it install driver to pc like it did the first time?
  9. OnyxJay

    OnyxJay Active Member

    For the record, these phones don't like USB 3.0 ports much. I use a Asus Sabertooth 990FX motherboard and I tried to use the one-click root on my phone and it would hang every time. Also it didn't like charging (maybe because I was trying to use quick charge which pumps about 3 times more electricity into the device. Not sure) but as soon as I went back to USB 2.0 ports and turned off quick charge, no issues.

    Granted, this could just be specific to my board, but I would think its safe to say it's best to stick to 2.0 for now. (most computers just have 2.0, unless your PC is less than a year and a half old. easy way to tell, the ports are blue.)

    Just wanted to share that.
  10. confed

    confed Well-Known Member

    good catch, i know it doesnt like my 3.0 ports either too
  11. jjcox315

    jjcox315 Member

    i toggled usb debugging off, connected, turned it back on, then connected and again and i worked just fine after that. was having the same issue like 2 days ago while trying to set up thetherin on the new laptop
  12. TurnerJ

    TurnerJ Member

    I was having that problem while trying to root the phone using windows 7 64 bit. I had to reinstall the drivers for the phone, I also found that if you are using a different usb cord and not a samsung manufactured usb cord makes a difference. I work for metro and I was using a usb cord from an Optimus M to try and root the phone. It would register as plugged in on the phone, but the computer wouldn't read the phone unless I used a cord from another galaxy indulge i had in the shop. Also make sure you have the phone set to mass storage and not samsung kies.
  13. nomed1331

    nomed1331 New Member

    turning off phone connecting it then turning it on worked for me
    ACraigL likes this.
  14. ACraigL

    ACraigL New Member

    Brilliant... spent hours removing/reinstalling drivers, rebooting my pc and device. This did the trick. Thank you!
  15. Pidasso

    Pidasso Well-Known Member

    I have had problems since day1 connecting my indulge to a PC.... winXP and windows7.

    two things helped, a .99c cable from eBay worked much better than the factory one and my PC's are 5-8 years old, using a USB port on the back of the tower that is connected directly to the motherboard rather than one on the front of the tower that is connected to the mb by wires made all the difference in the world. On a new desktop and laptop it didn't seem to matter where I connected it but on the older desktop PC it did.

    don't even know if anyone uses the indulge but maybe this will help someone
  16. Joy Stick

    Joy Stick New Member

    I had exactly the same issues, it was really frustrating. Doubly so because it has worked fine before. The solution now is to open Settings > Wireless and Network > USB utilities and then click "connect storage to PC".

    I'm sure there are other people out there who didn't know we needed to do that.
  17. bripriuk

    bripriuk New Member

    Yes - thank you for the tip.
    My Galaxy S connected perfectly with my Vista computer, but refused to with my new Windows 7 one.
    The routine on the (ancient) Galaxy S is Settings>Wireless And Network>USB Settings>Mass Storage

    Thanks again

    Brian
Loading...

Share This Page