Can't connect to pc (mass storage)


  1. grpweld

    grpweld Member

    I had no problems with either of My lap tops (PCs windows 7) recognizing My epic, that was before I took the phone in to L.S.S. they did a hard reset & now I can't get MY photos on to My pc. When I plug in the usb the phone goes through all the connecton sequences OK & the computer says that it loaded the drive ok but.... nothing happens.

    PLEASE HELP

    Advertisement
  2. duratime

    duratime Well-Known Member

    Make sure the USB cable is good. The one that comes with the phone sucks, and shouldn't be used. Also, for whatever reason my phone will not connect to the USBs on the front of the computer, but works fine on the back. Give that a try.
    grpweld likes this.
  3. grpweld

    grpweld Member

    I've tried 3 different usb cables that all used to work! & all the available usb slots

    Thanks, George
  4. icecold

    icecold Well-Known Member

    I've had to uninstall and reinstall the drivers a couple of times to get the USB Mass Transfer fuction to work. At least that is what I think got it to work. That, rebooting both the computer and phone, turning on and off the USB debugging...are also some other things to try...

    When you plug in the phone to the computer, is it giving you the three options: Mass Storage, Charging, Sync? When my computer was not working, those options were not showing up...

    Edit: Also, I see you have this in the All Thing Root section...you could also try reflashing a ROM...
  5. rounsy222

    rounsy222 Well-Known Member

    Also try toggling usb debugging on or off. Just opposite of what it is on now.
  6. Gavisann

    Gavisann Well-Known Member

    I had a similar problem when trying to root my phone. I was able to get mass storage, but i couldn't get adb to work. I uninstalled all the galaxy s drivers then plugged the phone in, went to device manager, and upgraded each driver manually. My computer now connects to my phone without a problem.

    On a side note, try turning dubugging off if it is on. You are selecting the turn on mass storage button right?
  7. jmsnyc

    jmsnyc Active Member

    This is what fixed it for me:

    Use dialer code ##8778# to enter secret menu and make sure under usb pda is checked
    ikeywatson, smpcorp and Tibbetsni like this.
  8. Tibbetsni

    Tibbetsni New Member

    That worked for me as well. Thank you very much
  9. TheDetroiter

    TheDetroiter New Member


    OH MY FREAKING WORD!!! That totally worked. For the past 5 months i've had my Epic 4g (had it flash to work Boost Mobile) I have had to constantly take the sd card out and put it into my old phone so that I could load my music. Now my phone is recognized by my two laptops.

    Thanks so much jmsnyc!
  10. smpcorp

    smpcorp Member


    That was huge. Fixed my problem CAUSED by Sprint. They had to fix my no 3G problem and left the phone with PDA disabled. Thanks!!
  11. mnix9796

    mnix9796 New Member

    Tried the pda thing, but mine is already checked but still won't connect to my computer
  12. mcacke

    mcacke New Member

    I've tried everything, all the same issues above - anything else?
  13. mcacke

    mcacke New Member

    #7284# or #8778# does not work either, states unable to process request.
    I have SG S2 on Gingerbread 2.3.6. I have tried different cables, plugging into back of laptops, cleaned ports, installed kies (which does not recognize any device, although its plugged in and charging) checked android sdk drivers, tried usb debugging, tried manually going into phone utility, I am at wits end - what is wrong with my S2?

Share This Page