Can't connect to wifiSupport

Last Updated:

  1. bha19

    bha19 Member

    Sorry for the long post.

    I have had the HP Touchpad for about a month now and love it. My problem is that I can't connect to wifi and need help. I have the latest webos that seems to connect fine. I loaded cm7 which sometimes got the internet, it seems only if webos wifi was turned off. I upgraded to cm9 alpha 2 by using ACMEInstaller2 without deleting anything and was able to connect to the internet only 1 time. I have tried to forget, start new connection etc. on my home network but get no bars even though it says signal strength is excellent. I also tried these steps with my results in ():

    1. Boot into WebOS and make sure your wifi connects. Use your browser for a sec and then boot back to CM.
    (Wifi works on webos not android)

    2. Delete your wifi profile:

    start the terminal app

    type su and tap enter
    the pound sign # turns to a dollar sign $
    type rm -rf data/misc/wifi && reboot and tap enter

    For clarity that's rm(space)-rf(space)/data/misc/wifi(space)&&(space)

    Reboot your TouchPad.

    After your TP reboots, you will have to reestablish the SSID and password for every AP you use.

    (when I go to terminal app and do rm etc.. it said read only and will not execute)

    3. Go to Settings -->WiFi --> Menu --> Advanced --> Keep wifi on during sleep --> Always

    4. Download Clock Sync, configure it for your timezone and set it to sync on boot.(An incorrect date or time can screw up
    wifi and several other things in Android)

    The last thing is I can't side load any fix apps since I can't seem to get android recognized by my computer. I read somewhere on the net about adb and got all the java requirement for android onto my computer but when I try to do an adb from touchpad it says device not found so I may be doing something wrong there as well.

    Anyway any help would be appreciated.

  2. colchiro

    colchiro Well-Known Member

    Hi bha, sorry you're having so much trouble.

    First, is the problem your TP or your router? Can you connect to ANY router? If you can't connect to ANY wireless (public, coffee, restaurant, library) then concentrate on your touchpad.

    For starts, it's been recommended in many places not to upgrade CM7 to CM9 for the touchpad. Many of us have had a lot less trouble once we booted into recovery and formatted data. (Make a backup in Titanium Backup and recovery first.)

    You might want to flash this wifi fix:

    wifi settings: some say that a lower channel on your router, like 1-6 is best, but I don't buy that. Setting your router to use "G" (not "N" exclusively) helps. (Mine says "up to 54 mps.) Also change security using WPA or WPA2 with TKIP.

    How old is your router? If it's more than 3 years old or doesn't do "N", replace it. You can get a Netgear N150 for $45 at Walmart. I've had lots of routers and that's the best.

    This is good if you're in a apartment/condo or congested area:
  3. bha19

    bha19 Member

    I think it is anywhere but wil try the library today, although webos even has trouble at the library sometimes. I did try the router thing. My router is dual band 2.4 and 5 and under security the options were:

    Security mode:
    64 bit wep
    128 bit web


    I did not see tpik so I did not mess with it.

    I guess I will try a clean install of cm9
  4. colchiro

    colchiro Well-Known Member

    Try the patch first.
    bha19 likes this.
  5. bha19

    bha19 Member

    tried the patch and it worked. The 1st thing I downloaded was FXR WIFI FIX.
    Thanks for your help. I will let you know if it goes out again.
  6. colchiro

    colchiro Well-Known Member

    I don't know much about the patch, (like is it included with nightlies or compatible with them)?
  7. bha19

    bha19 Member

    So here is what happened. I have been in android all day so I don't if problems may arise when I go back to webos. Wifi has been strong all day so it is looking good.
  8. colchiro

    colchiro Well-Known Member

    In the past, I found that going into webOS often fixed my wifi issues. I suspect my date might have been off, webOS fixed it and everything was good when I booted back into CM7.
  9. alexkrat

    alexkrat New Member

    rm /data/misc/wifi/wpa_supplicant.conf
  10. bioforce

    bioforce Well-Known Member

    What worked for me was changing my router to channel 1 any g only instead of mixed b/g.
  11. ricklynchcore

    ricklynchcore Member

    Must agree. Tried every fix I could find on the forums, but could not keep wifi consistent. I always avoided channel 1 because analysis showed neighbor congestion. However, when I finally tried channel 1 in desperation, wah la, worked like a charm. Sometome simple is best.
    Ed. likes this.
  12. colchiro

    colchiro Well-Known Member

    I'm on channel 4 only b/c I'm in a congested building and that's the best open spot. Turning off wireless-n (5 mhz) also helps.
    layka likes this.
  13. devrit

    devrit New Member

    This worked for me, thanks.

Share This Page