can't connect to wifi

Last Updated:

  1. sross512004

    sross512004 Member

    Here's the problem:

    1. factory refurbished nc wouldn't ever connect to my home wifi since 1st day,said mine out of range, but would connect to others around me
    2. got new router, same problem, but could still connect to others around me
    3. added android 2.2 w/n2a sdcard - same problem
    4. called b&n 2 days ago, they had me upgrade to newest update for nc.
    5. can't connect to any wifi at all, can't factory reset since no wifi access,
    5b. mistakenly told costumer svc about n2a sdcard, was informed this voided my warranty, no other help availble from b&n
    6. can this device be saved or should I read it it's last rights? :confused:

    PS-nc will scan for network, then show "connecting" then shows "disconnected" in continuous loop

  2. colchiro

    colchiro Well-Known Member

    If your NC connects to other networks, why are you ready to trash it? :D

    Sounds to me like you misconfigured or misconnected your router.

    What kind of router?
    How is it connected?
    What else connects to it and how (plugged in, wireless)?
    sross512004 likes this.
  3. sross512004

    sross512004 Member

    Thanks for the quick reply. The problem was that the nc had stopped connecting to any network at all. Somehow it "magically" started connecting tonight. I had wanted to connect to my own network so l'd know I always would have an open network. Anyway, it's connecting now, so I'm happy. I have a Belkin router (don't know the model offhand) 801.11 b/n/g and it's connected to a cable modem. There's nothing connected to it wired. I have a Gateway laptop (running windows Vista) and a Dell Duo netbook (running W7). I've rebooted it many times, tried inputting all the techy info from the nc to add it specifically to the router/network.

    I did run FXR Wi-Fi Fixer yesterday but it didn't start connecting after I ran it. It just connected today out of the blue. If you know of something I haven't tried, I'd be happy for your suggestions.

    And thanks again for your quick reply.
  4. colchiro

    colchiro Well-Known Member

    Are you saying these devices use wireless with no problems?

    Try this to make sure you have a clear channel: Wifi channel optimizing

    I'm not aware of anything specific for the NC.
  5. sross512004

    sross512004 Member

    I just checked out the link and that's really great info which I'll be using tomorrow since I know my mental limitations at night. And I'll be back soon with more questions. What a great site!
  6. colchiro

    colchiro Well-Known Member

    The only other recommendation would be to try turning off wireless-n, which I don't know if that's an issue or not for the NC.

    You need to be able to reproduce the not-connecting problem tho.

    BTW, next time get a Netgear 150... Belarc is crap. :D
  7. sross512004

    sross512004 Member

    The funny thing is, I switched from Netgear to Belkin last year when I was having problems and thought it must be the router. I may go back to my old netgear and try to see if it works.
  8. sross512004

    sross512004 Member

    well, I have reproduced the not-connecting thing but have no idea how it happened
  9. sross512004

    sross512004 Member

    OK, Colchiro, it has stopped connecting again and now it's doing something weirder: it scans for available wifi networks, gets a list, can't connect, then scans again and about half the networks that were just there are gone, then scans again in another 30 seconds and they're back. This process just continues over and over.
  10. colchiro

    colchiro Well-Known Member

    You didn't answer my question. I want to know that the router works for everything except you NC.

    Did you optimize the channel you use? (What was it before and what did you change it to?) Did you do anything else?

    I need to know a lot more info. What have you changed from when it was working to when it wasn't?

    Can other devices still connect to your router?

    Is the date and time correct on your NC?
  11. sross512004

    sross512004 Member

    Sorry, I'll try to answer them all this time,

    Yes, the router works for everything except the nc
    I haven't changed anything on the router or the nc from when it was working to when it wasn't - if you mean this last time.
    Yes, all my other devices still connect to the router, oh, and I forgot to mention I have a D-Link "what's-it" box hooked up to my tv for netflix, youtube, vudu and pandora, that still connects fine also.
    Yes, the date and time are correct on my nc.

    And the last wifi network I connected to on my nc is now showing up as out of range.
  12. sross512004

    sross512004 Member

    I posted this on another thread, but thought if anyone might still be following this thread they would appreciate the answer:

    Ok, I've had this problem for many months, and could never find any way to connect. I even took my mook to B&N yesterday, where everything worked just fine. I even checked my router's MAC address settings and the router could see the nook just fine, the nook's MAC address was already listed, but still the nook would not even "see" the router when it scanned. Finally, after reading the above posts, I decided to take the security on my router down to WEP (temporarily) to see what that would do. Well, I couldn't connect to the internet with any of my devices following that move. So I pushed the red reset button on my router, which reset the security back to WPA/PSK. And what do you know, after months of no connection, my nookcolor has finally got online at my house. Hurray. Hopefully, people with this problem will see this post and be able to connect.

Share This Page