Can't delete files or apps and other problems


  1. fonnae

    fonnae Member

    Having weird problems here. I can't remove files from my phone. I've tried using astro and by hooking up to pc. in both cases it says the file is deleted with no errors but then when I go back to the phone the file is still there. Same thing with trying to uninstall apps. I think the problem may have started when I tried to install HTCSync but I'm not sure.

    Advertisement
  2. sdrawkcab25

    sdrawkcab25 Guides Guide

    Are you talking about media files? Or system files?

    Usually not being able to delete files is a sign of file corruptions. Have you tried pulling the battery on the phone for a while? You may end up needing to do a factory reset and reformatting the sd card.
  3. fonnae

    fonnae Member

    I have not tried pulling the battery out for a while, but i've pulled it out for a second numerous times.

    I can't delete mp3 files from certain folders and when I install an app, I can use it once, and then it disappears. similarly if i uninstall an app it disappears at first and then reappears.

    i tried doing a factory reset from the settings menu, but that resulted in a screen with a red exclamation point. from there i can go to the hboot menu using vol up + pwr and if i do a factory reset from there it seems to do something but when the phone reboots all my apps are still there and i'm signed into google.

    i also tried loading a stock image from the sd card but that gives me an error that says: "Main version is older! Update Fail!". I tried both of the images here plus a couple others: Stock Images | PvilleComp's

    Here are the specs for my phone:

    Incrediblec xc ship s-on
    hboot-1.02.0000
    microp-0417
    touch panel-atmel224_16ab
    radio-2.15.10.12.20
    dec 21, 2011,23:37:16

    Android Version 2.3.4
    Baseband version 2.15.10.12.20
    Build Number 4.08.605.15

    PLEASE HELP!!! I'm hours into this. I can't give up now!
  4. sdrawkcab25

    sdrawkcab25 Guides Guide

    You aren't going to be able to run a factory image unless you unlock your boot loader and go s-off. Sadly, it sounds like you ran the wrong factory image from that site first which is preventing you running the correct one.

    It also sounds like your file system has been corrupted and rooting may be your only chance at fixing it. But even that may not be able to help with bringing your phone back to a fully functional state.

    http://androidforums.com/incredible...ow-unlock-downgrade-achieve-s-off-htcdev.html
  5. fonnae

    fonnae Member

    (sigh) I made it to step 4 with no errors. After flashing the PB31IMG file and rebooting I now find myself in a reboot loop. It makes it the red eye part of the startup sequence and then freezes there. After a minute or so it restarts and does it again.

    Tried to doing factory reset from hboot menu but nothing different.

    Am I screwed?
  6. sdrawkcab25

    sdrawkcab25 Guides Guide

    Try flashing it again... seems to be a common problem.
  7. fonnae

    fonnae Member

    I just tried flashing it two more times but I still got the same result. Gets stuck in exactly the same place.

    One thing I did notice is that fastboot getvar mainver does not say 1.22.605.2 it says 3.26.605.1 instead. but since I can't access adb I can't rewrite the misc image.

    What should I try next?
  8. sdrawkcab25

    sdrawkcab25 Guides Guide

    Why can't you access adb? Completing the process is your best hope.


    You could just try flashing a custom rom however, as long as your bootloader successfully unlocked and flash the custom recovery.
  9. fonnae

    fonnae Member

    I can't access adb because my phone never fully boots. I thought I could only access adb when the phone was booted. When I try to do adb devices it says offline.

    I can't use adb from the hboot menu and hboot is about the only thing I can access.

    Can you help me to use adb or to flash a custom rom?
  10. sdrawkcab25

    sdrawkcab25 Guides Guide

    Were you able to unlock the bootloader?
  11. fonnae

    fonnae Member

    yes, when I run the command fastboot flash unlocktoken Unlock_code.bin it takes me to the screen where I can unlock the bootloader and then afterwards the hboot menu says unlocked at the top.
  12. sdrawkcab25

    sdrawkcab25 Guides Guide

  13. fonnae

    fonnae Member

    I tried loading the recovery clockwork PB31IMG.zip file on the the sd card.

    It produced the same error I've gotten EVERY time when trying to load a PB31IMG file from the sdcard. First it says checking sd card, then it says loading PB31DIAG.zip, then something about no image file, then it says loading PB31DIAG.nbh, then no image file, finally it says loading PB31IMG.zip and this (sooner or later) results in the Main Version is older error.

    Strangely, PB31DIAG.zip is not even on the sdcard so I don't know what it's doing.

    Note that at the top of the hboot menu it says *** UNLOCKED ***

    I'm beginning to think my sdcard is either bad or corrupted. Despite having reformatted it a couple times I still don't trust it. Could that be causing the problems?
  14. fonnae

    fonnae Member

    One last thing: I've also found that it goes through that sequence of trying to load PB31DIAG.zip, etc. every time the phone goes to the hboot menu with the sdcard in....EVEN when there is no PB31IMG file there at all. I only have the superuser zip file there now and it just went through the whole sequence (minus the main version is older error).
  15. fonnae

    fonnae Member

    OK, so I got the CM7 rom installed using clockwork recovery. (I used fastboot instead of sdcard to put clockwork on the phone b/c I couldn't get past the Main version is older error).

    The problem is that now I am stuck in a bootloop with CM7 :(
  16. sdrawkcab25

    sdrawkcab25 Guides Guide

    You can't use cm without having s-off ( well you can but there is a couple extra steps)

    Use a stock ROM for now

    The green text you see in the hboot screen is normal. You are supposed to see that every time, unless you have that type of file on your SD card, which you shouldn't. (unless you are trying to install a recovery or an OS image).

    I don't see any reason you can't get downgrade to achieve s-off though. ADB sounds like it's working fine if you were able to get an unlock token. All you have left to do is rewrite the misc.img, downgrade, then get s-off. I'd recommend just rereading through the steps again. Just take it slow and step by step. I know it seems wordy, but the basic process is pretty simple.
  17. fonnae

    fonnae Member

    2 things:

    - I only have access to the hboot and fastboot menus and I can't use adb from there (the device is not listed when I do 'adb devices'). This is why I can't rewrite the misc.img. Do you know how to use adb without having to boot up the phone into the operating system?

    - When adb used to work for me, before the bootloops, I tried downgrading with the zip file listed in the tutorial and that is what started the bootloops. I've tried downgrading it a couple times but always get bootloops. I can't get s-off without downgrading. What can I try differently?
  18. sdrawkcab25

    sdrawkcab25 Guides Guide

    You are able to get into recovery though? You should be able to do everything through recovery.
  19. fonnae

    fonnae Member

    You're right! I can access adb through clockworkmod recovery.

    Which PB31IMG file should I use to downgrade? The one that is recommended in the tutorial is the one that caused the bootloop initially.
  20. fonnae

    fonnae Member

    Making progress....

    I made it through all the steps this time and my phone is s-off but I'm still stuck in the same bootloop.
  21. fonnae

    fonnae Member

    Just tried flashing the froyo stock recovery image from this website: Stock Images | PvilleComp's.

    The good news is that I didn't get the main version is older error. the bad news is that I still get stuck in the bootloop.

    Is there anything else I can try?
  22. sdrawkcab25

    sdrawkcab25 Guides Guide


    Try flashing the froyo image again... verify md5.

    Other that.. use the one link I gave you to regain root (be sure to remove any other pb31img.zip files first ) This way you will have recovery back and can try different ROMs till you find one that boots. Also make sure you are doing a factory reset before installing any ROMs.
  23. fonnae

    fonnae Member

    it's not looking good for me. I tried froyo, gingerbread, cm7, and abduction and they all get stuck in a boot loop.

    question: the PB31IMG files I have to install from hboot, right? The stock images I downloaded from pvillecomp I wasn't able to install through clockwork mod recovery. cm7 and abduction I was.

    Is there any way to scan the disk for errors?
  24. sdrawkcab25

    sdrawkcab25 Guides Guide


    Correct, the only way to install the files is from hboot.

    All ROMs should be installed from clockwork using the instructions I linked you to above. It might be worthwhile to format the SD card again to fat32(don't use quick format).

    Do you get any errors when you do a factory reset in clockwork?
  25. fonnae

    fonnae Member

    No errors on factory reset except something about no sd extension partition.

    I just bought a new SD card and reformatted it.

    I'm not sure what else to try. Why could it be that I get stuck in the bootloop every time?

    Any other custom ROMs you can suggest?

Share This Page