Can't do anything!Support


Last Updated:

  1. m21mccracken

    m21mccracken New Member

    I've been having charging issues for awhile...phone is temperamental. It always has to be off to charge, otherwise it goes into annoying loop of "detection" "no-detection" of the charger, and beeps repeatedly and flashes as if I'm plugging and un-plugging the charger continuously. After a round of that yesterday, I finally had to pull the battery. When I put it back in, I have nothing. The phone won't turn on, and the charger isn't being detected. I've tried many outlets and everything. For a split second last night, I got the battery icon to come on the screen like it was going to charge, and then it just went black again. the phone is 16 months old and I'm not eligible for an upgrade for another 8 months :( I never buy the phone insurance b/c typically I don't need it (in 12 years of owning cell phones, this is my first issue). Could it be the battery, the charging port, the USB charger, or the actual phone?
    Thanks!

    Advertisement
  2. AlkiDweller

    AlkiDweller Well-Known Member

    Yes.

    The only way to find out is to replace the battery and/or charger.

    Borrow someone's charger. Any USB charger that fits will work. If that doesn't work, get another battery. They're cheap. If that doesn't work, it's probably not worth going any further.
  3. Nevis

    Nevis Well-Known Member

    I'm confused. How can your phone be 16 months old? The Epic 4G Touch only came out 8 months ago. Are you sure you're on the right forum? Do you mean to be asking about the original Epic 4G?
  4. JAJameson2010

    JAJameson2010 Well-Known Member

    This happens to me when I have a bad charger. I usually buy them super cheap on ebay and have multiples all around the office/house/car/trailer/etc. Since they are cheap they tend to have a solid rate of going bad!
  5. fofjjsr

    fofjjsr Well-Known Member

    I was thinking the same exact thing....
  6. Nevis

    Nevis Well-Known Member

    I think there was an issue with the charging port on the OG Epic 4G...or was that the EVO 4G? Might have been the EVO, I forget. I had the EVO and my wife has the Epic. I upgraded to the E4GT in October right after it came out.

    Searching the forums is probably in order here...

Share This Page