cant dowload anything over mobile data on galaxy S4 AT&T.General

Last Updated:

  1. TheZacktus

    TheZacktus New Member

    I was trying to download an app that was about 3 mbs and it wouldnt download. It would show the spinny bar but it wasnt actually downloading. It finally downloaded while I was in wifi. This was the same case with downloading pdf files and really anything that involves downloading. I am currently using the galaxy s4 on the AT&T network. The thing that is weird about this problem is that I can surf the web and do anything else that requires internet on mobile data its just I cant download anything over mobile data. Any help would be greatly appreciated.

  2. SAL8116

    SAL8116 Well-Known Member

    Weird. Did you try restarting your phone? Data outage in your area maybe?
  3. TheZacktus

    TheZacktus New Member

    Yeah I tried everything. Its been going on for about 2 weeks now. It used to work perfectly and now it wont work at all. But my friend has the gs4 and his still downloads things off of cellular data perfectly fine.
  4. SAL8116

    SAL8116 Well-Known Member

    I would call AT&T and if they can't help, Samsung to troubleshoot.

    Sorry I can't be of further help.
  5. Nabeeeh

    Nabeeeh New Member

    Click on settings =>Data usage => click on Media => untick "Restrict background data"
  6. BlurrFrost

    BlurrFrost New Member

    I am using my s5 for many months now but just 3 days ago when i was downloading something i dont know what happened but the downloads from my mobile network stop downloading.. a bar comes saying untitles or unknow.m but it just keep loading .. it doesnt download. The weird thing is that i can browse but cannot download.. even youtube videos and internet videos doesnt work
    HELP!!!!! All this downloads and stuff work perfectly in wifi and i have not ticked the "restrict background download" function either soo pleaseee HELP!!!!!!
  7. Ashok Kudamaloor

    Ashok Kudamaloor New Member

    May be the DRM Content is off for mobile.Try this . Go to SETTINGS -DATA USAGE - Enable
    DRM Content for mobiledata.

Share This Page