Cant download app from google play via wifiSupport

Last Updated:

  1. eskal

    eskal Member

    I have Xperia S with ICS 4.0.4. Two days ago when i returned home from a trip, my phone connected as usual to my home wifi network. I was using it for messenger, facebok etc, but when I wanted to install updates of apps via google play, i click update...and the download didnt start, it s just stuck on thet blue bar moving from left to right... When i turn off wifi download starts immediately over 3G. I did reset my router, my phone to factory settings, several times, i cleared the cache on google play, download manager. I dont know what to do i can browse web, watch videos on youtube, can browse google play, but cant download any app over wifi... Help me please :(

  2. Del1701

    Del1701 Well-Known Member

    Have you tried to download from a different WiFi network?
  3. eskal

    eskal Member

    yes i tried different network yesterday, and i could download apps from google play over wifi...
  4. Del1701

    Del1701 Well-Known Member

    Ah, so it's probably your router or isp then.
  5. eskal

    eskal Member

    Problem solved! I repair time and date, also set dns of my isp, restarted the router and now it works
  6. Del1701

    Del1701 Well-Known Member

    Glad you solved it.
  7. ap_arpan

    ap_arpan New Member

    I am facing same problem, but for me it is not working as described.
    Please help
  8. Anas javaid

    Anas javaid Member

    I faced the same problem on my jellybean upgrade, Idk what caused it I tried everything I could understand nothing fixed it, n then next day when I woke up it was working just like before. :p this happened a couple times n now it's fine.

Share This Page