can't download attachments from email accountSupport

Last Updated:

  1. mgpolanco

    mgpolanco New Member

    [FONT=&quot]I have a Samsung Galaxy S2 upgraded with Ice Cream Sandwich. Now I have problems with opening up attachments from email. I have a few different email accounts set up on my droid. When I access an email and click on the the open (attachment) button, I get an error message saying fetching attachment..attachment can't be displayed. I have tried different file types and sizes (xls,pdf, doc) none will open. Can anyone help me with this?[/FONT]

  2. Russell Ng

    Russell Ng Well-Known Member

    Have you downloaded any apps that can restrict internet use. Apps like antivirus or data manager than can allow downloads only on wifi modes. Tried using "Dr Web Light" once. If you select active protection, it won't let you download attachments. Uninstalled already. Went back to Avast.
  3. ufxss

    ufxss New Member

    I had a problem to open attachments right after the upgrade. Not exactly the same, but I could not open them. I deleted the email account and set it up again and it worked. just my 2 cents
  4. littlefilly

    littlefilly Member

    I am also having issues with ice cream sandwich and email pics...tried deleting account and reinstalling change!:confused:
    any more ideas??? thanks!
  5. upd103

    upd103 Active Member

    I found with ICS that many times, if not always, attachments do not even show up in the regular email app. I will just see a blank email. If I use the gmail app however, everything works just fine. Not a big deal really as I like the gmail app better anyways, but still an interesting issue. Not sure if 4.1.2 will fix this or not.
  6. jaliy

    jaliy Well-Known Member

    since ics update long emails are missing body text
    attachments not working
  7. sky2ken

    sky2ken New Member

    Dear all Android users, if you're experiencing this problem unable to download the attachment in yr email, which happened to my phone, there's no respond when u click on preview or save button and the percentage figure not moving at all with 0%.

    For god sake DO NOT GO to any phone service centre or shops and asking them to troubleshoot the phone. For the next 10 secs after reading this, Volla ! There you go, yr email will be working just fine. Those phone service retailers will tell you 101 things bout yr phone problem. More interestingly they told me that the software already crash and need to do some update installation, or either that the email host service provider having some problem. If they tell you this, show them yr 3rd finger and tell them go F@#K themselves.

    Like what user UFXSS had shared, it is very true. All you need to do is to remove yr email account and create back the settings. That's it!
  8. RositaCrus

    RositaCrus New Member

    Ok I have a Verizon Samsung Galaxy S3 running on Verizon towers through a prepaid service called Straighttalk. After a year of frustration I think I figured it out myself. Try this. In the to portion of your emial make it 8005551212 or whatever Verizon phone you want to sent the photo to the add "" without the quotes ofcourse and hit send. Then go to your phone and you will hopefully see it appear as an "MMS" and then click on that "MMS" then it opens and then hit the bottom left on my phone for options for that message such as reply, delete etc and select "Save attachment" This saves it to your phone or SD card on the phone and you can re-send it via text to others. Good luck. Let me know if it worked.

Share This Page