Can't eject Droid from computer!


  1. Chuck1906

    Chuck1906 Well-Known Member

    I have been having issues the last few times when I have my Droid hooked up to my computer. I can drag my music and pics over to the Droid with no problems. I tried to drag 7 photos over to my desktop and iPhoto locked up on me.

    Now I am trying to unmount and unplug the USB cable and it won't let me. It keeps saying Disk is in use, try quitting applications and try again!

    Nothing is open that would cause the disk to be in use. I have a Mac computer. When I first got my Droid, it mounted and unmounted with no problems until recently. It mounts with no problems but unmounting is another story!

    Advertisement
  2. messenger13

    messenger13 Well-Known Member

    What happens if you UNmount from the DROID's interface?
  3. Chuck1906

    Chuck1906 Well-Known Member

    I ended up just yanking the USB cable out of the Droid! I know I shouldn't do that but what else is there to do! It wouldn't unmount and and kept telling me to quit applications first! I checked and made sure my pics, videos and whatever else didn't get messed up and they were all there on the card and played back fine.
  4. messenger13

    messenger13 Well-Known Member

    But did you try pulling the notification bar down and unmounting from the DROID itself? That is how I unmount every time, (albeit not what the directions tell you to do.)
  5. Chuck1906

    Chuck1906 Well-Known Member

    yup I tried that first however it said to unmount before I turned the USB storage off. It just kept saying my Droid was in use and could not be ejected and I couldn't figure out what was causing it to be in use!!!
  6. try another computer. if it still happens ... it's your phone. if it doesn't ... it's your computer. go from there.

    also try another cable. and don't use any lazy mount apps. go meat-n-taters built in droid mount.
  7. timlitw

    timlitw Well-Known Member

    The "proper" or safest thing to do in that situation is to shutdown the computer, when it is shutdown then you can unplug the usb, and then turn the computer on again.
  8. raremage

    raremage Well-Known Member

    Are you running any third party sync software? For example, I know Salling Sync seems to "prefer" that you unmount via it's UI, or it doesn't always recognize the Droid when I try to remount it without a reboot.
Loading...

Share This Page