Can't enable USB debugging, is permanently greyGeneral


Last Updated:

  1. harris5800

    harris5800 Member

    Sorry for my bad english, first of all. I just bought a LG Optimus L3 and, of course, I want to root it..:).But, I can't enable USB debugging, is permanently grey......Is this a required step for root?.....please help.Thank you.

    Advertisement
  2. AndyOpie150

    AndyOpie150 <strong> <a href="http://androidforums.com/optimus Contributor

    Can you post a screen shot of the settings/applications/development screen?
    Use a screen capture app from Google Play, then use photo bucket App from the Google play. once you have the screen shot uploaded to Photo Bucket select it and hit the menu button. Select to copy the img URL. Go to this site with a browser from the market that will enable Desktop view (Dolphin HD is the one I use). Paste the screen shot img URL into the reply box making sure you have [​IMG]
  3. harris5800

    harris5800 Member

    All screen capture apps from Google play needs activate USB debugging. I can't do that, so I can't use Android SDK (DDMS).......other solution pls?

    Anyway...there are three options.....USB debugging(permanently grey, inactivated), Stay awake and Allow mock locations.
  4. c4ou3

    c4ou3 Member

    hi harris, try this

    1. connect phone to pc
    2. see usb icon on shortcut drop down, you see message : charge only , usb storage , go to pc-software and press ok.
    3. go to settings menu- press applications - press development now you can press usb debugging press ok

    USB debugging options should be able to tick.
    If u want to root, you can use this link
    Root LG Spectrum Smartphone Method By Dan Rosenberg

    beforehand, you need to install L3 USB driver, find it from LG E400 Support: Find Manuals & Warranty Info | LG UK click the software update & drivers

    hopefully help :) nubie First-timer superuser
  5. c4ou3

    c4ou3 Member

    After rooting, i manage to find useful application that can so called "map" internal sd folder but put the large big file in external SD
    This app requires superuser access. here is the link [TOOL] DirectoryBind - move data to external_sd (GameLoft, Shadowgun etc.) ROOT req. - xda-developers

    so far i am quite happy because i can move my huge offline map to external SD

    For force moving application that belongs to phone memory only such as Adobe Flash Player, i use Link2SD. This also requires superuser permission and farthest only to Internal Storage, not External SD.
    renofizaldy and harris5800 like this.
  6. harris5800

    harris5800 Member

    Thank's my friend.....working good...:p
  7. harris5800

    harris5800 Member

    it takes only 30 sec for rooting....great job.
  8. renofizaldy

    renofizaldy New Member

  9. jlove1974

    jlove1974 Active Member

    If the USB is connected to the PC in a mode other than charge only, it will be greyed out until you unplug the cable ;)
    jakman likes this.
  10. rucksak

    rucksak Active Member

    I can only select usb debugging when connected to the pc ,I've downloaded link2sd and when I select an app to move it says phone needs to be in debugging mode which is greyed out unless connected to pc,any ideas mate.
  11. rucksak

    rucksak Active Member

    Ignore that last post I sussed it out.
  12. sharkeater

    sharkeater New Member

    hello i need help why i cant root after running that &#8220;run.bat&#8221;. the result is

    &#8216;adb&#8217; is not recognized as an external or internal command, operable program or batch file

    and so on&#8230;
    that one,. i think im missing someone., i really need help badly sir., i would appreciate your reply as soon as possible. thanks in advance

    pls ive been trying to root my l3 for many days but unfortunately, dont know the exact process,. ive been downloaded what have been told and run files but still, it doesnt work for me, or maybe ill just missing something,. pls pls
  13. rucksak

    rucksak Active Member

  14. sharkeater

    sharkeater New Member

    yup ive installed the drivers that i got from LG site(windows usb driver=l3 usb drive?) if that would the case i installed it already. but why is it that after i run that file nothing changes to my phone.

    well if i run my that "run.bat" on my pc there is a black box(seems commandt promt) and says press enter or any key to root your phone., and still i have the same result >.< ive tried it many times but i dont know what is really wrong., i getting headaches and starting to pissed off about this situation.. haha do you know other reasons why?. or is it the driver?. i dont anything else more about this situation. i really need help :)
  15. rucksak

    rucksak Active Member

    I would check if the usb drivers are installed properly or just reinstall them and turn off anti virus software it may conflict, or try a different usb port ones on the back of the pc seem to work best, when I rooted mine I used linux on my netbook no drivers needed and it took two times for it to work so dont give up.
  16. rucksak

    rucksak Active Member

  17. sharkeater

    sharkeater New Member

    well thanks for the help ruksak,. and im glad someone helping me through this already,. ^_^
  18. rucksak

    rucksak Active Member

    Sharkeater were you successful :p
  19. hilly1877

    hilly1877 New Member

    im getting same probs as Sharkeater , someone heeeelllllp , tried everything , adb drivers antivirus off etc the lot , this has to be something n nothing . my phone is on latest firmware could this be the issue ? i also trie on different pc running xp not 7 to see if this was an issue but still get same outcome ....its winding me up !!!
  20. rucksak

    rucksak Active Member

    Hilly windows not working do you know anyone with a mac execute the &#8220;run.sh&#8221; instead of the "run.bat" or try a live linux
  21. hilly1877

    hilly1877 New Member

    just installed linux , shall post soon thanks
  22. merb

    merb Member

    Thank you! I couldn't figure out why I couldn't enable USB debugging on a particular device, but could on others. Mystery solved!
  23. JnznRys

    JnznRys New Member

    Can someone help me? my lg e400 is already rooted but i want to hard reset it now, but it wont. i tried the lock button+volume down+home button but it wont do any too.
  24. Brutal

    Brutal New Member

    How fix this problem ??? I have same tipe :( (Sorry for my eanglish)
  25. Skyshark

    Skyshark New Member

    Sorry for delayed answer. This is not a problem - you really need a PC connection to enable it - but once you did it, it will stay enabled even if you are disconnected from PC.

Share This Page