Can't enable USB debugging to do a recovery because phone is stuck in a bootloop

Last Updated:

  1. eniac1

    eniac1 Member

    Hello all,

    I'm new to android and this forum.

    My dad's HTC Desire seems to be stuck in a bootloop. Every recovery method i have found seems to require that I enable USB debugging in order to do the recovery.
    Is there a way that I can enable USB debugging without booting into the phone.
    If not, can you please outline a procedure that i can follow to do a recovery from this state.

    PS: I have already installed ADB and Android SDK

    Thank you!!:)

  2. CdTDroiD

    CdTDroiD Well-Known Member

    Does it not work if you take the battery out then put it back, hold the volume down + power to get to recovery?
  3. eniac1

    eniac1 Member

    Yes it works. It takes me to the bootloader menu, then when i choose recovery it will reboot and get stuck again. Pls Help!!!
  4. CdTDroiD

    CdTDroiD Well-Known Member

    Instead of selecting recovery select fastboot and flash the original RUU.

    (it will erase everything including root access)
  5. eniac1

    eniac1 Member

    Ok. Trying that now. Hope it works.
  6. eniac1

    eniac1 Member

    Can you please outline the procedure to do this. Would really appreciate it. Thanls.
  7. CdTDroiD

    CdTDroiD Well-Known Member

    Find the right RUU off the XDA site, chuck the phone in fastboot mode and run the .exe file to flash, the flashing is very simple and self explanatory, otherwise look for SUroot's guide... I think he made one.

    Heres the XDA link for RUU's

    UN-ROOT guide
  8. eniac1

    eniac1 Member

    Thank you. Will do just that.:)
  9. porter_james

    porter_james Well-Known Member

    Make sure that u don't grab an amoled ruu for an slcd screen tho'!
  10. SUroot

    SUroot Well-Known Member Developer

    All 2.2 support slcd.
    porter_james likes this.
  11. eniac1

    eniac1 Member

    I download the RUU from the XDA site and put the phone in fastboot mode. I then run the .exe file i downloaded.
    It rebooted the phone and started the update. It has been stuck at 39% for past 30 min. I think there is something wrong. I have attached screenshots of the progress indicator and the RUU file I downloaded. Please advice.

    Attached Files:

  12. SUroot

    SUroot Well-Known Member Developer

    Thats a 2.1 RUU!!!! Thats never going to work as you can't go backwards.

    That whole thread contains only 2.1 RUU's. Garrgghhh!

    You should use the one from the useful downloads thread linked in my signature.

    You're going to have to wait it out and see what happens. Disconnecting whilst flashing radio can be very risky.
  13. eniac1

    eniac1 Member

    Okay. Download it now. Will let you know what happens. Thanks.:)
  14. SUroot

    SUroot Well-Known Member Developer

    Is it still sat at "updating Radio" btw?
  15. eniac1

    eniac1 Member

    Downloaded the RUU from your dropbox. I started the update process again and after verifying signatures, it say " Model Mismatch".
    The Current version on my phone is 1.21.405.5.
    Can you please advice.
  16. SUroot

    SUroot Well-Known Member Developer

    Model mismatch? It definitely works. Its an HTC desire RUU. Its 2.29.405.5. The latest version of WWE unbranded.
  17. togger161

    togger161 Well-Known Member

    How did it get into a bootloop? Are you rooted? did the phone just pack up? How long have you had it? Did you try and flash something to it initially?
  18. eniac1

    eniac1 Member

    I retried the recovery again with the RUU i downloaded from your dropbox.
    This time, it started the recovery process and it is stuck at 22%. Screenshot below.
    I hope I am not asking for too much, but really need some more ideas.

    Is there an alternative way to flash the ROM?????

    Attached Files:

    • RUU.JPG
      File size:
      32.4 KB
  19. eniac1

    eniac1 Member

    I don't know how it got into bootloop and I'm pretty sure it wasn't rooted (because it belongs to my dad who is just a regular user).

    He has had it for a couple of months now. It was actually a gift his manger got him from Norway.

    Ideas Please!!!!!
  20. SUroot

    SUroot Well-Known Member Developer

    You could try the ( must be called this, capital letters too), put it on sd and boot into hboot. It should find it. Also on download thread in Sig
  21. togger161

    togger161 Well-Known Member

    Hardware fault? Would seem strange that an unrooted machine with stock rom would fail to boot.
  22. Rastaman-FB

    Rastaman-FB Well-Known Member

    If it was never rooted then accessing recovery using root.methods will never work. This should have been a warranty return. Its quite likely to be a hardware issue
  23. gwaimui

    gwaimui Member


    I am a new member of this forum and I am having the same problem of the post as my HTC Desire keeps on rebooting itself. I've searched and most of the method I have found seems to require that I enable USB debugging in order to do the recovery. Is there a way that I can enable USB debugging without booting into the phone? because I cannot boot into the phone. I would really appreciate the instructions on how to fix the phone.

    Thank you so much for the help
  24. Hadron

    Hadron Well-Known Member Contributor

    Hi gwaimui, and welcome to AF :)

    Firstly, we need to know a bit more about your phone and what started this.

    Is the phone rooted? The answer to that question will tell us what options we have.

    Have you recently changed anything: made any software mods, accepted any updates, installed any apps or themese shortly before the problem started? Did the phone show any problems beforehands, such as occasionally crashing or rebooting when used heavily (games, 3G browsing, maps - things that might make it hot)? The answers to these questions will help guess the cause.

    As general advice I'd suggest pulling the battery out, leaving the phone for a while with the battery out (several minutes at least), then putting the batter back in and seeing whether it helps.

    If it's a software problem on an unrooted phone we might need to reflash the software. In this case we'll need to know more about the phone to select the right software: what model it is (GSM or CDMA - does it have a SM card or not?), was it network branded or not, and if so which network? It might also be a hardware problem though - at this moment all we know is that it's in a bootloop, but there are many possible causes for that.
  25. gwaimui

    gwaimui Member

    Hi Hadron,

    Thanks for the welcome!

    The phone is not rooted and I have not done anything to it, it was how it was from the shop. The phone did not show any symptoms and just died on me. I tried reading most of the tutorials or guides around but non has the similar problem until this thread. Most of the guides needed the phone to be in good condition or at least bootable so the USB debugging could be enabled. I've also tried recovery and it will come to the black screen with a red triangle exclamation mark in the middle.

    I could get into the bootloader screen and the details shown:

    Bravo PVT4 SHIP S-ON

    There are terms I might not understand please guide me to find out if you need to know more information.

    I really appreciate help on this.

    Thank you very much.

Share This Page