Can't establish a reliable data connection to the server | Tried Factory reset + File delete


Last Updated:

  1. disparate

    disparate New Member This Topic's Starter

    Joined:
    Sep 9, 2010
    Messages:
    3
    Likes Received:
    0
    Hi,

    I have a Samsung i7500 (Galaxy).

    Originally, it had Android 1.5 installed, but I could not enter the Google Market with my google account and got this message: "Can't establish a reliable data connection to the server".

    I read here and across the web I should Factory-reset my phone, but it did not work.

    So I upgraded the firmware to Android 2.1 using this guide:
    http://androidforums.com/i7500-all-things-root/40806-how-mustymod.html

    It worked, and now the phone had Android 2.1 installed, but I still cannot access the Google Market with my Google account.
    This time I did a factory-reset (Settings -> Privacy -> Factory reset) and also followed this guide to delete the provider-settings (eventually I removed the whole /data/data/com.android.providers.settings/ directory and not only that file):
    http://androidforums.com/droid-x-al...stablish-reliable-data-connection-server.html

    BUT NOTHING HELPED!

    Any suggestions? I'm beginning to lose hope :(
     

    Advertisement
  2. Lelouch

    Lelouch Well-Known Member

    Joined:
    Aug 6, 2010
    Messages:
    655
    Likes Received:
    70
    Just a question. Why would you want to have Android 2.1 installed on your Galaxy, when you can have Android 2.2 instead?
     
  3. weasel

    weasel Well-Known Member

    Joined:
    Mar 5, 2010
    Messages:
    401
    Likes Received:
    23
    I am not sure off the top of my head how, but you might trying to clear the market cache.
     
  4. sgx100

    sgx100 Well-Known Member

    Joined:
    Mar 18, 2010
    Messages:
    262
    Likes Received:
    14
    Dude I had that irritating thing once. Really freaks you out. If I remember correctly I had that problem when I was trying out Froyo 2.2.

    Basically you can try to clear cache of all google related settings.
    Find that in Setings---> Applications---> Manage Applications

    That should help but it would require you to relogin to use gapps.

    If this does not help try installing gapps from the recovery again

    You my also try restoring to default factory settings

    Lastly you may have to start from scratch and try using Galaxo 1.6.3.4.
    Its the most stable platform now for daily use.
     
    disparate likes this.
  5. disparate

    disparate New Member This Topic's Starter

    Joined:
    Sep 9, 2010
    Messages:
    3
    Likes Received:
    0
    Well, I could not reinstall the gapps from recovery as the mustymod does not contain that option :(
    But you were right, when I downgraded to Android 1.6 - I managed to login with my Google account!
    :D

    To tell the truth, I didn't find the proper firmware to install on my samsung galaxy :-/ only Eclair (2.1)
     
  6. Lelouch

    Lelouch Well-Known Member

    Joined:
    Aug 6, 2010
    Messages:
    655
    Likes Received:
    70
    Just one sentence.
    Drakaz has it all. :cool:

    And that's it.
     

Share This Page

Loading...