Can't figure out how to work titanium backup. Please Help!


Last Updated:

  1. Ryanater

    Ryanater New Member

    So I rooted my Eris using the gscript.zip method. But before I go ahead and install a new rom I want to backup my contacts etc. I downloaded titanium backup but it says it can't get root rights. When I start titanium backup up says it's asking for root rights but nothing ever comes up asking for them.

    Any ideas? This is my first time ever rooting a phone so is there any additional steps that I need to take?

    Advertisement
  2. Xyro

    Xyro 4 8 15 16 23 42 Moderator

    Do you have the superuser permissions app installed? That's the app that should be popping up to let you allow/deny TB's root request. And if you do have it installed, make sure you have USB debugging enabled in Settings >> Applications >> Development, otherwise the superuser app seems to have trouble popping up.
  3. scotty85

    scotty85 Guides Guide

    also,you might push the "problems" button in TiBu,and then "get busybox". alot of issues with TiBu result from the lack of busybox. :)
  4. Bob Cat

    Bob Cat Careful, They're sharp!! Moderator

    :D
    Now I know which one of my bosses watches over our little forum.
  5. scary alien

    scary alien not really so scary Moderator

    Scotty or Xryo? :D :D
    :) ;) :p
  6. Bob Cat

    Bob Cat Careful, They're sharp!! Moderator

  7. doogald

    doogald Guides Guide

    Hmm, that's a great point.

    The 1-click root app in the market will put a file called "rootme.zip" on your SD card, which you can then flash to get all of the bits that you need for apps that need root ti run (mostly the SU, or superuser, app.) However, the rootme.zip file itself is not downloadable, as I understand it.

    The Universal Root for Dummies method, if I read right, assumes that you will then be installing a custom ROM that includes all that you need for root apps to run rather than flashing something like rootme.zip. (Though that procedure mentions PlainJane as a good choice, I prefer xtrSENSE myself.)

    xtrSENSE can be downloaded here: [ROM][GPL][3/15/2011] xtrSENSE5.0.1 [cache2cache,apps2sd,oc,jit]-HTC Sense - xda-developers

    The good news is that you can almost always flash xtrSENSE over stock and keep your data, apps, etc. Here would be the procedure:

    - download xtrSENSE5.0.1.zip and copy to your SD card
    - shut down your phone
    - restart in Recovery (hold down VolUP while starting the phone until you see the Recovery menu)
    - go to the Backup/Restore menu
    - Nandroid backup (you can go back to where you are easily with this step, in case this goes badly)
    - Press VolDn to go back up to the main menu
    - Wipe menu
    - Wipe Dalvik cache
    - press VolDn to go back up to the main menu
    - Flash a zip from SD card menu
    - choose xtrSENSE5.0.1.zip from the list
    - when it finishes, restart your phone

    This should leave you with a phone with all of your apps and data intact, your home screens as they were with stock, the ability to run root-based apps like Titanium Backup, and a phone overclocked to run at 710 MHz to boot.

    Good luck and, if you try this, let us know how it works.

    (By the way, the Universal Root for Dummies method shows illustrations of all of these steps in the fourth post. However, rather than "Wipe data/factory reset", do the "Wipe Dalvik cache" instead. Wipe data/factory reset will delete all of your apps and data from the phone, meaning that you'll have to reinstall everything from scratch.)
  8. scotty85

    scotty85 Guides Guide

    whaaa :eek:

    :D

    good call,dooglad. IIRC,i ran the once click app and was on the rooted stock rom afterward. following the dummies directions to flash roms starting in post 4, i flashed something and noticed rootme.zip was on the sd card.

    if the OP does not have the su app in his drawer,thats prolly exactly what happened.err,didnt happen :)

    flashing xtrsense is an excellent idea,or simply flashing the rootme.zip in recovery.
  9. doogald

    doogald Guides Guide

    Alas, the rootme.zip file comes with the 1-click app. I *meant* to point that out in my post above, but forgot to highlight that little fact. I suppose one of us could send to the OP, but I would want to check with JCase first. It's his app, and does have license terms. (Easy license terms, but...)
  10. Ryanater

    Ryanater New Member

    That might be my problem. I did install the superuser app but I never installed a superuser permissions app. I looked for it in the market ad couldn't find it, where can I get it?
  11. Bob Cat

    Bob Cat Careful, They're sharp!! Moderator


    You should have a superuser app already included with whatever rom you flashed. Are you rooted?
  12. Xyro

    Xyro 4 8 15 16 23 42 Moderator


    They're the same thing. The superuser app (which exists to grant other apps superuser permissions) is the only one you need, so that's not the problem then.

    If you open up superuser, do you see a listing for titanium backup? It should have a green dot next to it.

    You also need to ensure you really have root access and that busybox is installed, as others have said.
  13. scary alien

    scary alien not really so scary Moderator

    Guys,

    The rootme.zip file is, I believe, essentially the same as the widely-known and previously used (before 1-click root), engtools3.zip (also put together by jcase):

    Multiupload.com - upload your files to multiple file hosting sites!

    I usually grab it from this post by thenestor: http://androidforums.com/eris-all-things-root/121660-root-without-rom-yet.html#post1136379

    I'll unpack 'em both and compare 'em just to make sure they are indeed, identical. I'll post back here in a sec...

    But the OP could flash the engtools3.zip in lieu of the rootme.zip to gain actual root.

    Cheers!

    edit: yep! rootme.zip is identical to engtools3.zip :) enjoy!
  14. Ryanater

    Ryanater New Member

    I did install busybox. I followed the steps from rooting for dummies. I even installed a new rom but obviously all my contacts and apps were gone so I restored the phone back to it's original state and reran the GSpcript root_part1.sh, restarted then ran root_part2.sh. Then I installed titanium backup, superuser, and busybox. I never got anything asking for permissions.
  15. doogald

    doogald Guides Guide

    Again, if you read my post from above you'll see a way to install xtrSENSE without losing all of your contacts, apps, etc.

    [edit: or, better: flash engtools.zip. Restart to make sure that you have root. Go back to Recovery and run a Nandroid backup. Then you can try flashing xtrSENSE with a Dalvik wipe and see if that works better for you. If not, Nandroid restore and you're all set.]

    Or, from Scary's post above, flash engtools. You won't get an overclockable kernel, and no cache2cache feature to get you more space for apps and data, but that's probably just fine, if that's all that you want.

    But, at the risk of sounding like a broken record, you can flash xtrSENSE over stock without wiping data and get all of the goodness of root, all of the full-compatibility of stock, and some extra speed and battery life.
  16. Ryanater

    Ryanater New Member

    Ok here is where my inexperience shines through. Is xtrSENSE a rom? I was hoping to experiment with a few different roms.
  17. metlcat

    metlcat Well-Known Member

    xtrSense is a ROM. Dooglad linked to the thread where you can download it in post 7 of this thread. Follow his instructions there.
  18. doogald

    doogald Guides Guide

    xtrSENSE is a great ROM to start with. For one thing, it looks and feels almost exactly like stock. It is a one-step flash (no separate Google apps flash.) Last, unlike most custom ROMs, for this one it's possible to flash over stock without wiping data, so you skip all of that rebuilding of everything (which Titanium Backup will help you with immensely once you get root rights.)

    Best of luck and let us know how things work out.
  19. DrDooGood

    DrDooGood Member

    fyi, i tried this with xtrROM and it has a few minor issues. a couple shortcuts and widgets didnt work. also, the Accounts & Sync option under Settings always gives a Force Close error.

    i know you said xtrSense, not xtrRom, but i just thought i'd share since they are so similar. oh, and i had Sense turned off in the OTA stock ROM before i tried it.
  20. doogald

    doogald Guides Guide

    Yep, this is definitely correct. xtrROM is not something that should be flashed over stock without a data wipe first.

    You may have had the Sense launcher turned off, but you still had Sense on stock. There is no Sense launcher on xtrROM, of course.

Share This Page