1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

Can't Flash 4.2


  1. CYNICALifornia

    CYNICALifornia Well-Known Member

    I'm rooted running a stock 4.1.2, rooted, with franco kernel. I've only removed a few of the Google play apps, language packs, and asus keyboard.

    I've downloaded the 4.2 zip from google, checked the MD5, then tried to flash it from TWRP. Install was failed.

    Am I missing something?

    Advertisement
    :
  2. colchiro

    colchiro Well-Known Member

    Maybe it's Franco kernel? :D

    The OTA is usually a patch, and if items it counts on being there are gone, it fails.

    I think you need to find a stock 4.1.2 rom, preferable rooted and flash it over what you have, then try the update. Or wait for a full stock 4.2.0 rom.
    CYNICALifornia likes this.
  3. Rxpert83

    Rxpert83 Dr. Feelgood Moderator

    CYNICALifornia likes this.
  4. CYNICALifornia

    CYNICALifornia Well-Known Member

    I believe that is the file I tried. For fun though, I'll download from your link and try again.

    No dice.

    Any ideas?
  5. CYNICALifornia

    CYNICALifornia Well-Known Member

    Tried to install via OTA and it took me to TWRP, then nothing happened.

    I bet this will turn out to be something simple that I'm missing.
  6. LoBatt

    LoBatt Well-Known Member

    I just got the OTA update. I'm rooted (or was), running stock with TWRP. Looks like it applied properly. I'm assuming WUGS Toolkit will get me rooted again?
  7. colchiro

    colchiro Well-Known Member

    You could have installed Root Saver, but yes, you can reroot with Wugs. I used the "any build" version.
  8. CYNICALifornia

    CYNICALifornia Well-Known Member

    Something went terribly wrong. I tried restoring from a previous nandroid I ended up with the dead android red triangle screen.

    Starting from scratch, thanks to the Wug.

    This is the fun part, right?
  9. CYNICALifornia

    CYNICALifornia Well-Known Member

    Things went bad again. Boat browser keeps force closing, the home screen keeps redrawing, and I can't install Franco kernel.

    Unless you have a better idea I'm going to do a full unroot and wipe and star over... Again.
  10. Rxpert83

    Rxpert83 Dr. Feelgood Moderator

    I would download the 4.2 factory image, backup your SD card, return to stock with wug, flash the factory image with dug, and then root
    CYNICALifornia likes this.
  11. CYNICALifornia

    CYNICALifornia Well-Known Member

    That is my plan. Thanks for confirming it.
  12. Teknologic

    Teknologic Well-Known Member

    The ota I got in this morning checked system apps for sure, it failed on Books. Maybe it's a different implementation of system checks but it seemed like the same error as before. I'm downloading the update from google now but it should be the exact same result as taking the ota...
  13. colchiro

    colchiro Well-Known Member

    Don't flash Franco until you find out if it's compatible with 4.2. Then make a recovery backup before flashing.

    I'm on my second restore back to stock. My sdcard got mounted wrong twice so all my files are in sdcard\0\. Just restoring files now after restoring back to stock 4.1.2. I'll wait for a 4.2 rom before updating again.
  14. CYNICALifornia

    CYNICALifornia Well-Known Member

    Damn thing still isn't working. One more time . . .
  15. colchiro

    colchiro Well-Known Member

    Sounds like my experience... :D

    I came to the conclusion that rooting 4.2 with Wugs might be broken.
    CYNICALifornia likes this.
  16. CYNICALifornia

    CYNICALifornia Well-Known Member

    I agree. after trying a number of times the root files keep appearing in the sdcard/0/ file. My guess is that the new profiles feature is what's messing things up.

    Back to 4.1.2 I go...
    colchiro likes this.
  17. Rxpert83

    Rxpert83 Dr. Feelgood Moderator

    I used it i know It works. Honestly download the factory image, backup with titanium backup, backup SD card, flash the image and you're golden.
  18. CYNICALifornia

    CYNICALifornia Well-Known Member

    I tried again and seemed to have been successful. Had to reroot, but what ev, right?

    Boat still isn't working, lets hope that fix it soon.

    Haven't tried flashing franco yet...
  19. colchiro

    colchiro Well-Known Member

    I had no problem until I rooted 4.2.0. I'm back on CodeName Android. :D
  20. wtherrell

    wtherrell Well-Known Member

    Same here.
    Well, not quite. I flashed a 4.2 Rom Scotts Stock rooted 4.2. Everything was fine. Then I made mistake of flashing a Kernel. Everything looked ok but all my settings and data are gone. Tried to restore a nandroid but recovery can't find the files. I can find them with file manager but 4.2 has crapped up all the partitions so that recovery restore function can't find them. If I knew where recovery restore was looking for them I would move them there and try again. Right now I seem to be screwed. :confused:
  21. colchiro

    colchiro Well-Known Member

    See if there's a zero folder (number zero) in the sdcard. That's where all my stuff went.

    I moved a couple nandroids over to where TWRP could see them, but every time I restored one, the problem was worse. It started out being a TWRP problem (couldn't find backups, but the rom was ok), then it became a rom problem (everything moved to 0 folder).

    I was able to backup my media and data with Wugs, moved the contents of the 0 folder to where it belonged on my computer, then back-to-stock with 4.1.2, rooted it and restored my media and data.

    I went back to stock twice, first with 4.2.0, and later with 4.1.2 and restored data 3 times. My laptop was working when I went to bed, went to work and most of last night, moving all that stuff over usb.

    I've had enough of an adventure with 4.2.0. I'll wait for the custom rom now. :D
  22. CYNICALifornia

    CYNICALifornia Well-Known Member

    Yeah.

    After Rxpert's encouraging remarks I wiped to stock 4.1.2, rooted, flashed 4.2, re rooted (skipping the last step of flashing apps via TWRP, as I already had them installed) and most everything is golden.

    Now I wait patiently for boat and franco to become 4.2 compatible.

    Also, any idea where my TWRP backup is... I can't seem to find it...
  23. wtherrell

    wtherrell Well-Known Member

    That was my problem exactly. I, too was up most of the night. I had lost everything after flashing a kernel folks thought was compatible with 4.2--sorta but not completely. Tried to restore nandroid but recovery restore could not find the files. PANIC BUTTON!
    Here Is what I had to do after I finally found the files with the advanced file manager in TWRP. (BTW Astro File Manager-paid version can't see them nor do they show up in Windows.These partitions are a labyrinth!)
    Now in looking back through my files, I finally found the backup files and moved them from the "0" partition to the main SD card partition recovery system directory. However, it still didn't work because the files themselves apparently have to be inside a folder named "Backups" inside TWRP folder before the restore function can see them. So I made a folder named "Backups" in there and moved the files into it. It Worked! Kinda wish I had waited to jump on the 4.2 bandwagon. Other apps and stuff have a ways to go to catch up to this new multi-user partition scheme. I hope there's a way to turn that off. Finally Got my homescreens and stuff back tho and am now on 4.2 with stock kernel. If you go with 4.2, For God's sake, guys, don't flash any Kernels until it is absolutely certain they work with 4.2. I flashed Trinity a12 and it seemed to work but lost all my set-up, homescreens, data, etc.
    CYNICALifornia likes this.
  24. CYNICALifornia

    CYNICALifornia Well-Known Member

    I can't find the file but TWRP restored it fine.

    Also, Franco kernel just boot loops at this time.
  25. Rxpert83

    Rxpert83 Dr. Feelgood Moderator

    Kernels are very specific for the version of android you are on. I'm not surprised it didn't work.

    Just have to wait for the update
Loading...

Share This Page