1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

Cant flash clockword recovery


  1. sublimnl

    sublimnl Well-Known Member

    Hi guys, I just got a replacement droid in the mail today and am trying to get back to where I was on my old one. I have a nandroid on my sdcard and am trying to flash clockwork recovery so that I can restore my nandroid, but everytime I try to flash recovery I get an error message that says "an error occurred while flashing your recovery". I was able to flash SPrecovery from ROM Manager, but that won't allow me to restore the nandroid that I made in clockwork.

    The phone came with 2.1-update1, so I used RSDLite to flash back to 2.0 stock and then rooted that using the original update.zip technique. I then got DroidRootPro, installed busybox, etc, installed rom manager, but thats where I started getting the flash error to begin with. I managed to get back up and running with a pre-clockwork nandroid, but I really want to get my nandroid from earlier today restored from clockwork!

    Any ideas?

    Advertisement
    :
  2. bp328i

    bp328i Well-Known Member

    I was getting the same thing tonight when I flashed a new ROM and did not like it. I found my issue was I needed to go into my market downloads and install both the free and paid ROM Manager. I had not one issue after. I hope this helps
  3. sublimnl

    sublimnl Well-Known Member

    thanks. i had them both installed but still no luck at all. I ended up doing the following to fix it...

    1. Downloaded the appropriate Clockwork recovery img file from Index of /droid/koush/recoveries

    2. Renamed downloaded img to recovery.img and copied to /system/recovery.img on my phone

    3. Followed the steps (in the first code box only) here... Replace Recovery Partition - Android Wiki


    I had to do all of that from an ADB shell with my phone booted into SPRecovery for it to work. I now have clockwork recovery 1.8.1.2 installed and am restoring my nandroid from this afternoon. Fingers crossed!
  4. sublimnl

    sublimnl Well-Known Member

    Success!
  5. thasfreak

    thasfreak Member

    I'm confused. Why would you have to do this if you did all of your earlier work from a stock 2.0.1? How does it make sense that you went back to a different stock rom, then root it and for Rom Manager not work? I'm currently having the same problem and I would like to understand what else may not be working right.
  6. sublimnl

    sublimnl Well-Known Member

    Wish I could say why it washappening. Maybe someone else will know why. I still can't flash the latest version of clockwork but whatever, I am back up and running for now. Everything else works so far.
  7. thasfreak

    thasfreak Member

    I'm sorry to hear about your lack of success.

    I followed the same steps you did. Had 2.1, dropped to 2.0.1, rooted, installed Rom Manager and it won't let me flash to clockworkmod recovery either. I just went ahead and used SPRecovery to instal the rom I wanted.
  8. thasfreak

    thasfreak Member

    Oh wow, thanks!! I didn't want to trouble him in case I missed something. Thanks for your help!!!! :D

    Just tried it and it works now!
  9. Archon810

    Archon810 Well-Known Member

    Hehe, and then there is that "Give Thanks" button ;-)
  10. thecarpenter

    thecarpenter Member

    Everything installed fine, made a backup, but there is nothing stored under the ; Manage and Restore Backups screen. In file explorer, only have in the /sdcard/clockworkmod directory , /download and a recovery-update.zip file.
    Thanks for any help
    Greg
  11. scotty85

    scotty85 Guides Guide

    i would highly recomend booting into recovery to make backups,wipe,and flash roms. i see rom manager cause strange prollems on occasion,and personally avoid using it.

    download roms to your pc,transfer them to your phone via usb,and then use recovery to change roms and backups. this is the least risky way to do it,in my humble opinion. :)
Loading...

Share This Page