Can't flash ROMs/nandroids due to lack cache space


  1. erickrocks1126

    erickrocks1126 Active Member

    Hey everyone, I can't seem to flash ROMs or create additional nandroid backups or even wipe my cache as one of the preps to install a ROM. Here's what I get:

    E: error in /cache/recovery/log (bad file number)
    E: error in /cache/recovery/last_log
    (no space left on device)

    Here's the background on how I got there, hoping someone can help so I can load ROMs or at least be able to make nandroid backups occassionally.

    1 - I installed CWM 2.5.1.8 recovery on my MetroPCS Ascend (running stock 2.2.2) without issue then immediately did a nandroid backup. Took a long time to do the nandroid (longer than any other phone I've done nandroids on) but it worked
    2 - In preparation to flash PlayfulModz ROM, I did the obligatory wipe data/factory reset -- no issue. Next did wipe cache -- phone froze for nearly an hour. After quite a while, pulled battery, restored original nandroid, all is OK.
    3 - Installed CWM 3.0.2.4 at the recommendation of another member. Did the obligatory data and cahce wipes, this time wipe cache worked. Next wiped dalvik cache and that worked fine.
    4 - Now tried to do another nandroid and phone froze for a while and eventually gave me the lines above.
    5 - Tried to then just flash PlayfulModz ROM, ended up with an installation aborted error.

    Anyone know what's up and how to fix it? :confused: I'm searching the web furiously and finding lots of similar things, but mostly related to command line and for other phones. Hoping someone in this community might know what's up.

    Advertisement
    :
  2. erickrocks1126

    erickrocks1126 Active Member

    **UPDATE**

    Found a fix buried in a forum for the HTC Desire. In CWM, data wipe/factory reset. Then wipe cache. Then wipe Dalvik Cache. Then reboot to recovery.

    The missing step was reboot to recovery...previously after wiping I just tried flashing a nandroid or the ROM and it gave the errors. Rebooting to recovery (an option in CWM) after wiping everything seemed to fix it. Was then able to flash a nandroid backup then flash PlayfulModz ROM without problem.

    Hopes this helps others.
    lriv likes this.
  3. lriv

    lriv Well-Known Member

    Thanks for sharing your "fix" :):)
  4. lacalacaloca

    lacalacaloca New Member


    It helped me!
Loading...

Share This Page