Can't format sd card.Support


Last Updated: 2011-04-19 03:49:50
  1. Zenofsong

    Zenofsong Well-Known Member

    Tried formatting sd from within cm6, won't let me. TRied it from cwm says:
    E:failed to mount /sdcard invalid argument
    error mounting /sdcard!
    skipping format...
    done.

    Could really use some help I have no idea what happened to cause the sd to fail.

    Advertisement
  2. Zenofsong

    Zenofsong Well-Known Member

    Alright, tried restarting and removing sd a few time it let me format and mount to the device but still not connecting to my mac. I'm backing up cm6 to the sdcard currently.

    During backup it says "No sd-ext found. skipping back-up of sd-ext"

    Would formatting sd-ext via cwm fix this issue?
  3. PlayfulGod

    PlayfulGod Well-Known Member Developer

    just means that partition isnt there to format like its instructed to do. No harm. Mine did that until I formatted my sd card. Since you just formatted yours I would go a head n partition it.
  4. Zenofsong

    Zenofsong Well-Known Member

    My real problem is it's not mounting to pc.
  5. PlayfulGod

    PlayfulGod Well-Known Member Developer

    thats prolly a driver issue. As I dont use a Mac daily my suggestion is to google it ;)
  6. Zenofsong

    Zenofsong Well-Known Member

    The windows pc is free, im on that now. where the phone file system should be is a zero kb "dummy" file with no space free. When i mount i see android secure and lost.dir (both directories)

    It says the card is write protected. Not sure how that would happen.
  7. PlayfulGod

    PlayfulGod Well-Known Member Developer

    umm, try running fix permissions from CWM.
  8. Zenofsong

    Zenofsong Well-Known Member

    Nope, same thing
  9. Zenofsong

    Zenofsong Well-Known Member

    Lame. Is it possible the cm6mod is preventing me from mounting to. PC?
  10. nuttmeg

    nuttmeg Well-Known Member

    it will say that, but theres no harm to your backup or moving apps...
  11. Sinner67

    Sinner67 Well-Known Member

    I did notice the same thing on my phone when I went to CM6. Stock and Icarus both popped up a window on my computer that allowed me to move files to my sd card. CM6 doesn't. You have to drag your status bar on the phone down (after connecting to your computer) and there will be an option for storage or something like that (I am typing this from memory, so it might say something different). Tap on that option and it will then make your sd card available so you can copy files from the computer to the sd card.
  12. Zenofsong

    Zenofsong Well-Known Member

    The weird thing is it was working fine and then poof! Not fine. getting unreadability even when i choose to connect through the phone. The sd card works fine in the phone. Been saving apps and moving them on and off all day.

    This is a complete mystery to me. I want to apply the mms fix it seems ill have to bluetooth it to the card via the handset...

    EDIT: Well, bluetoothing it to the card didn't work at all. This worries me, because now I'm pretty much stuck with cm6.

Share This Page