can't get a com port recognised in Odin


Last Updated: 2011-10-10 16:07:41
  1. Grazuncle

    Grazuncle Well-Known Member

    Hi all

    Im trying desperately to upgrade to 2.1 and have everything in place (courtesy of Beekan) but try as i might I cannot get a com port recognised in Odin

    I have installed NPS and Kies on two different computers now and they see the phone/USB/Memory card mounted but I do not see a com port in Odin.. (top left?)

    an ideas?




    many thanks

    Advertisement
  2. Beerkan

    Beerkan Well-Known Member

    Disconnect phone, and remove battery. Re-insert and power on to Upload screen.

    Try changing USB ports.
    Try re-booting PC screen.

    Also do not connect phone until Odin is running, and ensure NPS and KIES are NOT running.

    It's a pain, but I've seen odin fail to recognise phone, and then suddenly recognise it after trying a few of the above.
    Grazuncle likes this.
  3. Grazuncle

    Grazuncle Well-Known Member

    I will persevere

    thanks for your tip
  4. Grazuncle

    Grazuncle Well-Known Member

    thanks Beerkan

    I eventually got the Galaxy recognised as COM 3


    all the files recognised as per your list :) I clicked on Start.. the com port timer started climbing up... after 20 mins and still nothing happening?/

    I eventually pulled the battery and fortunately it re-booted as previously.. I'm doing somethnig wrong...

    As www.Androidforums.com site has been down for the day I looked at Youtube for other;s using Odin to install 2.1. It seems the person on the video checked the 'one package' tick box. It wasn't on my tryout as it was not suggested. .should it be ticked, perhaps?

    Reboot, protect ops, and reset time boxes, are ticked


    still keen to get it going :D



    any help appreciated
  5. Beerkan

    Beerkan Well-Known Member

    NOOO!!!! Be VERY VERY CAREFUL. Ticking the wrong boxes can seriously FUBAR your phone.

    SERIOUSLY FUBAR IT!!

    The firmware you have is NOT a "One Package" update.

    Start again from scratch. Reboot PC, remove battery from Phone, reinsert and begin again.

    [ ] One Package (not ticked)
    [x] Reboot (ticked)
    [x] Protect OPS (ticked)
    [x] Reset Time (ticked) 300
    [ ] Debug (not ticked)
  6. Grazuncle

    Grazuncle Well-Known Member

    Thanks for the confirmation, Beerkan.

    I saw the time counting up on COM 3 but that was all.. is there another indication that it is actually uploading to the phone.. Perhaps i didn't give it enough time?.. (I only pulled the plug as the whole event should have been done in under 7 mins..:eek:

    If I pull the battery 'ext' time through not working is it safe to do so. or have I just been VERY LUCKY!


    I await your sage advice :D





  7. Beerkan

    Beerkan Well-Known Member

    OK.. All this assumes you have PC USB drivers installed.

    Power off phone. Remove SIM and SD and USB cable from Phone. (leave it connected to PC)

    Start Odin.
    Fill in Odin file details,

    On the right hand side windows Select these files.

    OPS = spica_jc3.ops
    BOOT = I570EXXJA1_Bootloader.tar
    PHONE = I570EXXJD1_Phone.tar
    PDA = I570EXXJD4_PDA.tar
    CSC = I570EOXEJD2-CSC.tar

    Left hand side window
    [ ] One Package (not ticked)
    [x] Reboot (ticked)
    [x] Protect OPS (ticked)
    [x] Reset Time (ticked) 300
    [ ] Debug (not ticked)


    Now Press and hold down in order
    "Volume Down + Camera Key + Power On"

    Might take a couple of tries.
    Wait till you see Downloading Screen, come up.
    [​IMG]

    Now connect Phone to USB. If Odin does not detect phone, unplug phone USB and try again. If Odin STILL does not detect phone, remove USB from phone, remove battery, reinstert and put phone back into download mode. If Odin is still not seeing Phone, try another USB port on PC. . And if Odin is STILL being a b*stard, reboot PC and start again.

    Plug in phone USB.

    You're looking for an image like this.


    [​IMG]

    Check the boxes are ticked correctly, and hit Start Button.

    Takes about 3 mins, and you will see a green progress bar rising above COM Port mapping in Odin.

    Wait for your phone to reboot, about (2 mins) with No Sim message.
    Odin should say PASS!
    Disconnect phone from PC
    Close Odin.

    Wait for phone to boot to home screen, then power off phone and insert SIM & SD.

    When you power on again, (might take a while to boot)
    First go to Wireless settings, enable them and connect to your home Wifi.

    Set your launguage & location to UK English etc.
    Set up Market Place first with your Gmail account.

    Then let phone sync to google, you'll have your contacts/calander back etc.

    Load any apps you want back from Market place.

    Go to home screen and add Power Control Widget and switch off Screen, GPS and Bluetooth.
    You can switch em back on when you need them.


    If your phone will not connect to internet without wifi you need to set your APN settings Manually.

    Menu
    Settings
    Wireless & Networks
    Mobile Networks
    Access Point Names
    Your Provider

    Enter your settings here.
  8. Grazuncle

    Grazuncle Well-Known Member

    Thanks for the detailed rundown Beerkan :)



    I have got to the point in your screen shot above in you thread.. then clicked Start button.

    Then I get this but no downloading is happening. I have tried it twice now (without bricking the phone.. don't want to try another time without your advice :confused:

    [​IMG]



    just out of shot is the last message

    <1> setup connection...

    It's still at this point after 20 mins and I am going to pull the battery again.

    The messages may mean something to you?

    Again thanks for all yuor help.. whether it gets to work or not [​IMG]
  9. Grazuncle

    Grazuncle Well-Known Member

    Pulled battery and phone is working as before

    last 'protest lines' from Odin:

    <1> e - dll cannot setup connection with the target.
    <0> Destroy instant..
    <0> Killed timer


    It is still the connection problem tthen?


  10. XplosiV

    XplosiV Master X is Watching You VIP Member

    Check that no samsung software is running on the pc/laptop. If it is, unload it. (like samsung stuido or keis)

    Also once you have your phone in download mode, and you plug it into your pc, wait 2-3 mins for the phone to be detected by your pc/laptop propperly. After this wait, load odin, check your settings and .tar file paths are correct, then hit start.

    Hope this helps
    Grazuncle likes this.
  11. Grazuncle

    Grazuncle Well-Known Member

    Interesting

    connect phone 'before' loading Odin.

    I am pretty sure the files are where they are stated in Odin.. I purposely browsed to them from Odin to make sure..

    They are close to the root directory.. just one subdrectory of C:


    I'm just wondering how many times I can pull the battery before I have an accident with it.. If it were a cat.. half its lives would be up by now :eek:


  12. XplosiV

    XplosiV Master X is Watching You VIP Member

    Well, thats what works for me, did you make any progress?
    Grazuncle likes this.
  13. Grazuncle

    Grazuncle Well-Known Member

    trying to pluck up the courage
  14. XplosiV

    XplosiV Master X is Watching You VIP Member

    Its not as bad as it sounds, I'm sure it will go smoothly, I was worried before I did mine, but I'm so glad I have, although I'm still debating if I should root or not.

    The jd1 firmware had all the tmobile settings, I tried jd4 also but that came up as DISCONNECTED to tmobile, so I'm assuming it was missing some apn settings or something. just fyi.
  15. Grazuncle

    Grazuncle Well-Known Member

    Hi

    Tried your suggestion...

    It did show as connected in Odin com port 3.. but it still failed to upload to phone


    Wil try some other NPS versions.. at least the phone works following all this:D
  16. XplosiV

    XplosiV Master X is Watching You VIP Member

    Glad you made some progress, did you make sure NPS was completely unloaded (tray icon as well)
  17. Grazuncle

    Grazuncle Well-Known Member

    good tip! just noticed NPS is still monitoring...


    Will try again later

    many thanks for your help
  18. Mad_Sunday

    Mad_Sunday Well-Known Member

    I was having the same problem, not continuing with the upload (if it's working it ONLY takes a few minutes) and the ONLY way I could do it was with KIES installed (but not running) and It still took a couple of attempts (with 2 different phones). If the download doesn't start (no movement of the upload bar above the com port) close Odin, take the battery out of the phone and reboot it in download mode again, re-start Odin and re-connect the phone and try again. It did work for me eventually.

    Pete

    p.s. Froyo anyone? ;-)
  19. gamet

    gamet New Member

    I have had the same problem in the past caused by other programs attempting to access the port. Quickest way to solve it is to run msconfig and disable all startup programs on your pc. Do the upgrade as described by Beerkan then run msconfig again and re-enable all those startup programs
  20. kalyan@s5570

    kalyan@s5570 Member

    cyanogenmod7 installation takin long to reboot..any guess
  21. kalyan@s5570

    kalyan@s5570 Member

    hello after applyimg th overclock to 864 mhz...my phone does not boot

Share This Page