can't get adb working


  1. welbinator

    welbinator Well-Known Member

    does anybody have any idea why the following instructions dont seem to be working?

    Getting ADB Standalone

    Windows


    1. Download this file and extract to C:\Program Files\adb.
    2. Press WinKey + Break, or Open your Start Menu and right click on (My) Computer, then click Properties.
    3. Go to Advanced System Settings (or Advanced Tab in XP)
    4. Click on Environment Variables, then double click on PATH (or Edit)
    5. At the very end of Variable value (should have a really long string), put in C:\Program Files\adb;
      • Make sure there is a semicolon before and after your entry, like this <some text>; C:\Program Files\adb;. All the PATH entires are separated with a semicolon.
      • If you accidentally delete the PATH value, cancel out, or you will break everything
    6. Close and Reopen any cmd.exe/PowerShell/Explorer windows to reload your PATH, and you should be able to type "adb" into a command prompt and get something that isn't an error.
    7. With your phone connected, open term and type adb devices. You should see something similar to:
    List of devices attached
    HTXXXXXXXXXX device
    You should now have a working install of ADB.
    If you can't get your device to show up, there may be a newer version of ADB available. Get the latest version of the Android SDK, and update that Wiki link if you are feeling generous. Also, you may need special USB or ADB drivers for your device.
    If you run adb devices and it isn't detecting your device, you may need special drivers.



    i'm trying to revert my phone back to stock so I can get it exchanged (speaker blew out) and I can't get adb working. I'm running windows 7. after i do all these steps I still get the message 'adb' is not recognized as an internal or external command, operable program or batch file.

    Advertisement
    :
  2. DizkoDan

    DizkoDan Well-Known Member

    I don't know what that file is you are downloading, but I would always get something like that directly from the source. The instructions have changed slightly, as there is no setup.exe anymore. I have this documented here
  3. DizkoDan

    DizkoDan Well-Known Member

    You don't actually have to do any of those steps for adding adb to your path. Just cd into the sdk/tools directory and execute the adb commands from there.
  4. welbinator

    welbinator Well-Known Member

    when I type cd sdk/tools it says cannot find the path specified.

    nevermind, i got my backslashes confused.
  5. welbinator

    welbinator Well-Known Member


    hey thanks! after I got into the sdk/tools directory all the steps on cyanogenmods wiki for downgrading my phone worked flawlessly! :D
  6. nexussowner

    nexussowner New Member

    when i type in adb devices it just says List of devices. And nothing under it but when i go to drivers and under android phone it says ANDROID Compsite ADB interface?! and then i tried to unlock by saying fastboot oem unlock and it just says waiting for devices? can some one please help me i really want to unlock my nexus s
  7. DizkoDan

    DizkoDan Well-Known Member

    You do realize this is a Droid Incredible thread/forum right? Not to mention it's 7 months old. You should check the nexus forums as each device is different.
Loading...

Share This Page