can't get google.com to come up in English..?Support


  1. Jas0n

    Jas0n Member

    Standard Samsung Moment. Haven't rooted or anything like that.

    For some reason, using the regular browser, I can't get google.com to open up in English. I think it's opening in French.

    Google appears to know that I'm located in Kansas. I believe I've tried about everything I can think of with regard to browser settings, google's settings... tried to clear all the history, cookies, cache... performed "reset to default"... every time I go to Google it comes up in French. There's a link, of course, to get it in English. But it's infuriating that it won't just come up in English.

    Anybody had something like this? Alternatively, anybody have thoughts on why it might be happening?

    I've not installed many apps. Skreebl, Handcent, a date widget and a battery widget are all I've got going right now. I'm thinking that a complete "Factory data reset" is in order, but I'd hate to lose the stuff on my SD card (mp3s, wallpapers). I have not researched - those things may not be affected by a Factory data reset.

    Any thoughts please guys? I appreciate it.

    Advertisement
  2. Jas0n

    Jas0n Member

    Reporting back.

    Evidently a factory reset fixed it.
  3. IOWA

    IOWA Mr. Logic Pants Moderator

    You could have just cleared your cache...
  4. pastafarian

    pastafarian Pâtes avec votre foie Moderator

    And avoided the pleasure of re installing apps and setting up email? Come on....:p
  5. IOWA

    IOWA Mr. Logic Pants Moderator

    Oh man your right. Thats straight out of fun bag 101. My mistake ;)
  6. Jas0n

    Jas0n Member

    Clearing my cache didn't work.

    (Incidentally, that's in the first post.)

    I'm not entirely sure that doing a factory reset even worked, actually. I did a factory reset, set my homepage as http://www.google.com and sure enough, it came up not in English. Again.

    So I downloaded and installed Dolphin, even though for some reason the gentleman at the Sprint store told me that he didn't like it and thought I should probably avoid it too. And when I set http://www.google.com as my homepage on Dolphin... it came up in a foreign language.

    However, I managed to capture the link behind the text on google's page which says "display Google in English" or whatever ... so I set that link as my homepage, and now it works fine.

    But that's a bandaid on a broken bone I'm afraid.
  7. IOWA

    IOWA Mr. Logic Pants Moderator


    Cell phone reps are ******s. Sometimes google displays the wrong language because of your ip.
  8. meangene

    meangene Well-Known Member

    Google typically uses reverse DNS to determine the location of the IP address and then serves the page in a language consistent to where that IP address is (supposedly) located. I don't think this is a Google issue so mach as a Sprint issue--someone's DNS server is screwed up. I get this problem too and it usually displays the page in Spanish--though I am in San Antonio so that's pretty close I suppose.

    You can use Google to serve the page in english

    or Google to serve the mobile version in english
    Jas0n likes this.
  9. Jas0n

    Jas0n Member

    I suppose that makes sense enough. I am in Kansas, which is fairly close to the geographical center of the United States so I don't know why I'd be coming up with French or Spanish (I have now had both) ... being squarely between Mexico and Canada maybe?

    In any case, reference bolded, I will surely use the link you've provided. Thank you kindly sir.
  10. dhubba

    dhubba Member

    I had something similar happen with 1.5 (CL14) a few weeks ago. I was visiting a friend and the Google homepage kept coming up in Chinese. I think I figured out what was happening -- I looked to see where Google had geolocated me and the SSID/info associated with my address was in Chinese (the adjacent addresses were in English). Turns out the address (which was a few doors down from my friend) belong to an Asian couple. I'm guessing that Google somehow picked this up as the geo and started displaying content in Chinese. Once I turned off geolocation, Google switched back to English.

    Weird.
  11. pastafarian

    pastafarian Pâtes avec votre foie Moderator


    Wait! You're browser language changed to Chinese because a neighbor was Asian?:eek:

    On one hand considering privacy issues, I hope not and highly doubt it. OTH, it's kind of funny if true.
  12. phone*guy

    phone*guy Well-Known Member

    I had the same issue under 1.5...Happened all the time (spanish) and drove me nuts. Ever since going to DD03 I havent had it happen once...Dont know if its a bug in 1.5 but it sure looks that way.
  13. meangene

    meangene Well-Known Member

    I am also on DD03 and it still happens to me. I'm sticking with reverse DNS being the root of the issue.
  14. phone*guy

    phone*guy Well-Known Member

    That sucks...
  15. meangene

    meangene Well-Known Member

    I don't think a "perfect" product exists so if I have to use a bookmark that is a few characters longer then it's not really a big deal.
  16. latinmaxima

    latinmaxima Well-Known Member


    Agreed. I resaved my homepage once I got the correct page to show up.
  17. Sphagnum

    Sphagnum Well-Known Member

    I had that happen all the time, just use "http://www.google.com/m?hl=en" instead of "http://www.google.com" and you'll never have that again.
  18. dublinbu

    dublinbu New Member

    Same problem... in Illinois it keeps loading in spanish. Alternative solution I found - disable the location feature of the browser. When google doesn't know where you are it doesn't try setting language. It's something messed up with google, btw, because it knows my location is in Illinois and it still loads the spanish version as soon as it loads location.

    Maybe google's db is messed up... or some coding in the browser.
  19. System6

    System6 Well-Known Member

    I'm in Wichita, Kansas on an EVO 4G with location disabled and have the same issue. BLAH!

Share This Page