Can't get MMS to workSupport


Last Updated:

  1. piannetta

    piannetta Well-Known Member This Topic's Starter

    Joined:
    May 25, 2010
    Messages:
    74
    Likes Received:
    2
    Hi, I'm in Australia on the Optus network (I'm not sure that matters, but I'll mention it anyway) and I just can't seem to get MMS to work.

    I've trawled the web, found heaps of posts for the settings, tried them all, any time I try to send or receive an MMS, I get a "general network failure". All other things work perfectly.

    Am I alone in this or has anyone else had the same problems, and more importantly, know how to fix them?

    Cheers,
    Pete
     

    Advertisement
  2. nx1977

    nx1977 Well-Known Member

    Joined:
    Feb 8, 2010
    Messages:
    2,418
    Likes Received:
    172
    Are your APN settings correct?
     
    piannetta likes this.
  3. paul5f

    paul5f Well-Known Member

    Joined:
    Jun 1, 2010
    Messages:
    48
    Likes Received:
    3
    I had exactly the same problem with my desire on vodafone in the uk. I searched the vodafone forums and found out vodafone had been selling unbranded desires with the wrong apn settings. I found a post on the vodafone website and now everythings working ok.
     
    piannetta likes this.
  4. mico4ever

    mico4ever Member

    Joined:
    May 9, 2010
    Messages:
    13
    Likes Received:
    3
    make sure you settings are correct

    1. go to settings>wireless & networks>mobile networks>access point names
    APN settings:
    APNs | Android Australia

    2.messages>settings>MMS settings:
    auto-retrieve
     
    Archphoto and piannetta like this.
  5. piannetta

    piannetta Well-Known Member This Topic's Starter

    Joined:
    May 25, 2010
    Messages:
    74
    Likes Received:
    2
    Thanks for the replies. Tried thee settings, still getting a generic network failure
     
  6. nx1977

    nx1977 Well-Known Member

    Joined:
    Feb 8, 2010
    Messages:
    2,418
    Likes Received:
    172
    Is your account mms enabled?
     
  7. Gash

    Gash Well-Known Member

    Joined:
    Jan 21, 2010
    Messages:
    61
    Likes Received:
    5
    If it's anything like T Mobile in England, when this problem occurred it was solved by changing the maximum message size to 300k in the settings.
     
  8. piannetta

    piannetta Well-Known Member This Topic's Starter

    Joined:
    May 25, 2010
    Messages:
    74
    Likes Received:
    2
    It is. Using same SIM card that I did on my previous WinMo device - MMS worked fine with that. As a double-check, my carrier has confirmed account is MMS-enabled.
     
  9. piannetta

    piannetta Well-Known Member This Topic's Starter

    Joined:
    May 25, 2010
    Messages:
    74
    Likes Received:
    2
    Thanks for the tip. Mine is already on 300k
     
  10. Tyrolis

    Tyrolis Member

    Joined:
    Apr 13, 2010
    Messages:
    6
    Likes Received:
    2
    Hey Pete,

    Not sure if you are still looking for the fix but most likely are as it took me a few days to find it. It was posted here and this worked for me. Simple enough without doing a factory reset. I had mucked with the APN with an attempt to put in a mobile on/off switch app for Sense which didn't work (not Quick Settings).

    Third post with the steps in it worked for me. I would look for APN for your Desire and Phone service. Good Luck.

    http://androidforums.com/support-tr...ck-settings-bug-mobile-data-switch-issue.html
     
    piannetta likes this.
  11. Loud

    Loud Well-Known Member

    Joined:
    Jul 13, 2010
    Messages:
    77
    Likes Received:
    7
    Hi,

    I think I have a similar problem but I'm on Orange in the UK and whenever someone sends me an MMS it says to download it but it tries and fails. When I try to send an MMS the same thing happens, tries but fails. I'm using Handcent and Launcher Pro Plus by the way.

    I am not techy and just looked at the APN stuff as listed above, in APN via settings I have "Orange Internet" (highlight green spotty thing mext to it), "Orange MMS" below it and then beow that another "Orange MMS". Within both Orange MMS the APN is set simply to "orangemms". I don't want to start tinkering with things if they're different as I wouldn't know how to get back.

    Any help would be much appeciated if it's different to the above. :confused:
     
  12. piannetta

    piannetta Well-Known Member This Topic's Starter

    Joined:
    May 25, 2010
    Messages:
    74
    Likes Received:
    2
    Hi Tyrolis,

    Thanks for your advice, I tried it and unfortunately no difference. But thanks for the tip on APN Backup, handy little program.

    Pete
     
  13. ac/dc

    ac/dc Active Member

    Joined:
    May 19, 2010
    Messages:
    28
    Likes Received:
    0
    My Desire is on Telstra in Oz, , and I ported from VODA, , that was the issue. I could only MMS telstra numbers, but not voda or optus.

    Did you port from someone else ? Or get a new simcard ?

    Craig
     
  14. maverick1200

    maverick1200 Active Member

    Joined:
    May 6, 2010
    Messages:
    28
    Likes Received:
    0
    I had the same problem, i went into the Orange MMS settings and changed the authentication type to none, i think it was set to chap. Anyway after i did that, it works perfectly.
     
  15. maverick1200

    maverick1200 Active Member

    Joined:
    May 6, 2010
    Messages:
    28
    Likes Received:
    0
    Here is the orange settings

    Name: Orange Internet
    Apn: orangeinternet
    Proxy: <not set>
    Port: <not set>
    Username: <not set>
    Password: <not set>
    Server: <not set>
    MMSC: <not set>
    MMS Proxy: <not set>
    MMS Port: <not set>
    MCC: 234
    MNC: 33
    Apn Type: <not set>


    Name: Orange MMS
    Apn: OrangeMMS
    Proxy: <not set>
    Port: <not set>
    Username: Orange
    Password: Multimedia
    Server: <not set>
    MMSC: http://mms.orange.co.uk/
    MMS Proxy: 192.168.224.10
    MMS Port:8080
    MCC:234
    MNC:33
    Apn Type: <not set>

    But i have my username and password as not set.
     
  16. Loud

    Loud Well-Known Member

    Joined:
    Jul 13, 2010
    Messages:
    77
    Likes Received:
    7
    Hi mate and thanks for getting back to me. I've just tried adjusting the settings according to what you have above but still it doesn't work :( I can't send or receive MMS at all. I've been on to Orange a few times and it is all set up as far as they're are concerned, but all they ever seem to do is to run a diagnostic and if they can't work out what the problem is they recall your handset and send you back to square one again. Hasn't got to that stage yet but I returned 3 Vivaz handsets before getting the Desire and I'm not happy in sending this one back as it is unlikely a handset issue.

    It's really starting to bug me now :mad: :(
     
  17. Jaanzter

    Jaanzter Member

    Joined:
    Aug 9, 2010
    Messages:
    5
    Likes Received:
    0
    Hi, I'm from Finland and I've exactly similar mms problems as who started this.
    My problems started after 2.2 update...
     
  18. maverick1200

    maverick1200 Active Member

    Joined:
    May 6, 2010
    Messages:
    28
    Likes Received:
    0
    I have no idea then, as i said before all i did was change the authentication type to none. Have you got the username and password set to none as well?
     
  19. liquidmonkey

    liquidmonkey Well-Known Member

    Joined:
    Jun 18, 2010
    Messages:
    218
    Likes Received:
    10
    have the same issue here in SWEDEN on GLOCALNET.
    if anyone has a solution, please post....
     
  20. piannetta

    piannetta Well-Known Member This Topic's Starter

    Joined:
    May 25, 2010
    Messages:
    74
    Likes Received:
    2
    Hi Craig,

    No, always been Optus, same SIM card & account as I had on my old WinMo device where MMS worked fine.

    Cheers,
    Pete
     
  21. piannetta

    piannetta Well-Known Member This Topic's Starter

    Joined:
    May 25, 2010
    Messages:
    74
    Likes Received:
    2
    Oh that's not good, I was kind of hoping that 2.2 might fix my problem...
     
  22. nx1977

    nx1977 Well-Known Member

    Joined:
    Feb 8, 2010
    Messages:
    2,418
    Likes Received:
    172
    I seem to recall a member saying you must remove the Proxy from the APN settings. Dont recall if this was the internet or MMS APN. Worth a go, as sounds APN related rather than phone or SIM.
     
  23. piannetta

    piannetta Well-Known Member This Topic's Starter

    Joined:
    May 25, 2010
    Messages:
    74
    Likes Received:
    2
    Mmm, thanks for the suggestion but it didn't work for me
     
  24. Jaanzter

    Jaanzter Member

    Joined:
    Aug 9, 2010
    Messages:
    5
    Likes Received:
    0
    I think I have to make a recheck... has my friend received any mms I send, because phone didn't give any errors when i used an old fw 2.1

    I just assumed he has got them. (yes he did, I just received a phonecall from him)

    I think it's not a settings issue... I would blame a froyo.
     
  25. piannetta

    piannetta Well-Known Member This Topic's Starter

    Joined:
    May 25, 2010
    Messages:
    74
    Likes Received:
    2
    I don't have Froyo yet, I'm hoping Froyo will fix it!
     

Share This Page

Loading...