can't get my rooted evo 4g wireless tether to work


  1. My name is Mat. I have just recently rooted my phone. I just rooted it to a normal ROM. I did this just for wireless tethering.

    Here is my problem:
    I installed the wireless tether app on my phone (evo 4g) and it seems to work fine. The devices I am trying to connect to it wont connect to it fully. for some reason, it sees the network and then just don't want to go all the way through the authentication or something. It has a full signal and it don't want to give me internet. I was able to connect my pc to it, it seemed connected, but when I went to the internet, it said something about the DNS was causing it problems and to go to adroidforums.net to find out what could be the problem. I went here of course though because I have seen alot of threads here that have helped me in the past, and I am hoping someone could help me. Any ideas? Any questions just please reply. Thanks to everyone who reads this.

    Mat

    Advertisement
    :
  2. ZeroOne

    ZeroOne Guest

    some wifi tether apks work better with others i suggest 2.0.8 or the wugfresh
    wifi tether apk to change data settings get both to change it back if you need to. good luck
    ocnbrze likes this.
  3. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!! Moderator

    welcome to the forums!!!!!!!!!!!!!!!!!!
    i moved you to the rooting section.

    have you tried any of these?
    Downloads - android-wifi-tether - Wireless Tether for Root Users - Google Project Hosting
    Tina Kiz likes this.
  4. itiscosmo

    itiscosmo Well-Known Member

    hi Mat hope u dont mind but just a little more info might help..what rom...normal? u mean stock.... and kernal r u using cause the more info paints a better picture so as to try to help u.
    ocnbrze likes this.
  5. Rxpert83

    Rxpert83 Dr. Feelgood Moderator

    This file will hack the sprint hotspot

    http://dl.dropbox.com/u/38066670/HotSpotHack_4.67.zip

    Should be able to run from recovery. Note, i grabbed it from the 4.67 update thread by tommy on Xda, so it may only work on the new update. It is worth a shot though.


    If that doesnt work I would suggest upgrading your ROM to MikG 3.1
  6. Android version: 2.3.5
    Baseband version: 2.15.00.12.19
    Kernel version: 2.6.35.10-g4b48446
    HTC-kernel@and18-2 #1
    Wed Dec 21 16:37:11 cst 2011
    Build number: 4.67.651.3 CO239674 release-keys
    Software number: 4.67.651.3
    Browser version: webkit/533.1
    Pri version: 2.33_003
    Prl version: 60683
    This is all the info that is on the about phone part. I remember my other version number, if this helps, it was 2.18.000.1, my security is on for some reason. I will try some of the ideas you guys gave me today as soon as I can. I appreciate you guys trying help me out. Hope this new info helps out.
  7. rxper83: I tried the wireless hotspot hack and it seemed like it worked, but when I tried to get internet, it didn't seem to want to give me anything. I was able to connect devices, but no internet. I was curious though, I am thinking of changing roms, but this goes out to anyone who is reading, do I need to somehow uninstall the rom I already have, or can I just go ahead and flash the zip onto my rom without worrying about uninstalling? The reason I ask is because I found a rom I like and it comes with wifi tethering and I am wanting to try a few but I don't want to mess anything up.
  8. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!! Moderator

    you can't uninstall a rom. you can replace a rom, but not uninstall it. have you tried the different versions of the wireless tethering apps i linked you earlier?
    TheBritton likes this.
  9. theTrashcanMan

    theTrashcanMan Well-Known Member

    I didn't read this whole thread, so this may have already been posted. The stock kernels don't seem to support wifi tether or barnacle. I've tried literally every single one of the releases, beta, experimental and stable and none work on the stock kernel. They all install fine, allow me to run the program, and even allow me to connect, but when I try to access the internet on the connected device it gives me connectivity issues and says there is no internet connection. I just flashed freedom kernel and I'm now able to use the wifi tether, so it seems that htc built in a block for it.
    My problem now is to find a kernel that doesn't give me massive battery drain, I'm using the aggressive kernel and my batt dies in a few hours of non usage...gonna flash the less version and see if that helps.
  10. NaterTots

    NaterTots Well-Known Member


    Matt, I take it you rooted your phone after taking the newest OTA update. Is it possible that since it's watermarked by HTC that the wireless tether won't work?

    I'm asking those here that are smarter than I in these sorts of things.
  11. I did take the new rom, but I was still able to root. Does it make a difference?
  12. I just installed froyo v4.4 and it is awesome. I got the wifi too. And it works. Thanks for the ideas guys. By the way, I recommend this ROM to anyone. It's awesome.
    NaterTots likes this.
  13. Toyz

    Toyz Member

    With the help from ocnbrze I rooted my Evo installed MikG v3.1the Sprint Hotspot works great for my iPad2 and Acer Tab. Netflix perfect so far. MikG great Rom for my tethering.
    ocnbrze and dustwun77 like this.
  14. wolf_walker

    wolf_walker Well-Known Member

    dustwun77 and ocnbrze like this.
  15. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!! Moderator

    i have not been on froyo in years. lol

    what rom is this again?
  16. SDouble09

    SDouble09 Active Member

    Hi I'm having sort of the same problem with my HTC evo 4g. I just rooted my phone by following instructions I got online and my phone says that is rooted. So I downloaded the adroid wifi tethering app cuz that is the reason why I rooted in the first place. when I use the app and try to tether it says the "tethering started with errors please check show log" when I check it, it says "unable to open log file because log file doesn't exist then it proceeds to say that unable to start tethering is your phone rooted?. when I checked my phone it says that it has been rooted. I'm really stumped and would really appreciate any help I can get. thank you so much.
  17. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!! Moderator

    ok we need some more info from from you. what is your hboot? go into the bootloader (power+vol down). also what rom are you?

    check your app drawer and see if you have the superuser app. if so open it up and see if you can find the tethering app listed there. if not then go into settings>apps>manage apps>and clear data, and cache and try it again.
  18. SDouble09

    SDouble09 Active Member

    My HBOOT is 6.16.1002

    I do have the super user app but there is nothing in it it says the folder is empty there was nothing for me to clear out
  19. boofer

    boofer Well-Known Member

    that might not be fully true. i am running MikG 3.1 with the stock HTC kernel, and wireless tether / hotspot works for me, both through apps and via the built-in hotspot function.

    if you're using the app WiFi Tether, there's a checkbox in settings that you have to tick to make it work (Routing Fix). otherwise, devices will connect, but won't fully connect.

    also, my battery life has been fantastic the past few days. just slightly over 3 hours of the display being on (using the stock internet browser for 99% of that) with a single charge is about 45 minutes longer than any non-rooted session i've ever had. also, with SetCPU dropping the processor to 245mhz with the screen off, i only lose 1 or 2% of battery overnight.
  20. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!! Moderator

    ok then try and clear out the data and cache for the tethering app and see if that helps.
    Rxpert83 likes this.
  21. SDouble09

    SDouble09 Active Member

    How do I do that I tried looking for it I can't seem to find anything that says how to clear it out
  22. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!! Moderator

    see in my above post to clear them out.

    if there is nothing then you can try and go to recovery and wipe dalvik cache and cache and see if that helps.
  23. SDouble09

    SDouble09 Active Member

    OK I did that but still no dice the app still says the same message I stated earlier
  24. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!! Moderator

    which app are you using?
    did you wipe dalvik cache and cache?

    also try uninstalling and installing the app again.
  25. SDouble09

    SDouble09 Active Member

Loading...

Share This Page