Support Can't get NFC and not sure if even working

Discussion in 'Android Devices' started by Trel, Jun 14, 2012.

  1. Trel

    Trel Well-Known Member
    38

    Nov 9, 2009
    252
    10
    38
    Verizon Galaxy Nexus, rooted with AOKP b38.

    I've tried every NFC app I could, but I Can't get it to detect anything. I've tried with my driver's license, and a keycard from work.

    I get no reaction what so ever.

    Is there any surefire way I can find out if NFC is even functioning?

    (Before anyone asks, it is defintiely turned on)
     

    Advertisement

  2. drbugsmn

    drbugsmn Well-Known Member
    313

    Aug 3, 2010
    554
    254
    313
    Twin Cities, MN
    I had the same issue (wanted to write an app to store my work badge), no joy. apparently not all rfid is compatible with nfc. Turns out I have a citi mastercard that has a smartchip in it (look for the words paypass, or a sorta wifi looking symbol). I use the app called "Taginfo", and just slide the card along the back of the phone and it sees it.

    another option is if you know someone else with a gnex (or one of the other nfc enabled phones) is to open something like a contact and touch it to the other phone. Cool animation of it dropping into the other phone.
     
  3. Trel

    Trel Well-Known Member
    38

    Nov 9, 2009
    252
    10
    38
    I tried with all manner of cards with no response.

    Now, I do know someone else with a gnex. About a week ago, we did get a reaction. But now, we don't.

    Additionally, neither of us can get a reaction from his chipped credit card.

    I'm not sure what this means though.

    Is it possible that both our NFC capabilities broke?

    I'm going to put the stock rom on in a while and see if that has any effect.
     
  4. drbugsmn

    drbugsmn Well-Known Member
    313

    Aug 3, 2010
    554
    254
    313
    Twin Cities, MN
    interesting, I wonder if it is an issue with the rom? Once you switch, please repost, cuirous to hear. Good luck!
     
  5. Trel

    Trel Well-Known Member
    38

    Nov 9, 2009
    252
    10
    38
    It still doesn't react to my cards. I ordered a few NFC tags, I'll see if I can get anything from those when they come.

    Is there anything I can do to verify that it's working on my phone as far as hardware goes, error logs, etc?
     
  6. OfTheDamned

    OfTheDamned The Friendly Undead
    VIP Member
    813

    Oct 29, 2009
    9,692
    8,365
    813
    Right Behind You
    Just checking, but are you using the stock battery?
     
    colchiro and drbugsmn like this.
  7. drbugsmn

    drbugsmn Well-Known Member
    313

    Aug 3, 2010
    554
    254
    313
    Twin Cities, MN
    Duh! Excellent question!
     
  8. Trel

    Trel Well-Known Member
    38

    Nov 9, 2009
    252
    10
    38

    I am. (I'm aware of the antenna placement)

    I should ask this. Is there any sort of test case that should definitely work I can use to test?
    (Over the weekend, I'm going to back up all my files and revert completely to stock, but I want to have a test that should work indefinitely as long as there's no hardware issues)
     
  9. OfTheDamned

    OfTheDamned The Friendly Undead
    VIP Member
    813

    Oct 29, 2009
    9,692
    8,365
    813
    Right Behind You
    Do you have Google Wallet installed? If you did then you could test at just about any Wallgreen's, 7-11, McDonalds or Arbys.

    EDIT: Actually I think Walgreen's just updated their system and Google Wallet isn't working yet.
     
  10. Trel

    Trel Well-Known Member
    38

    Nov 9, 2009
    252
    10
    38
    I have a Verizon gnex, so I haven't bothered to track down an apk for that. If you have a link to a legitimate one I'd be happy to try.
     
  11. umataro42

    umataro42 Well-Known Member
    53

    Aug 3, 2010
    310
    66
    53
    Male
    San Pedro, CA
    Unfortunately, that won't be a definite test because the PayPass terminal might not be working properly at whatever location you try it. I've had it not work a 2 different McDonald's locations, but then it worked at a 3rd McDonald's and a 7-11. This was using an apk.

    After using the browser market trick to get the official version, I was able to use it at a gift shop in an airport, so it still worked.

    More recently, it failed at a CVS, but this was after I had done a factory reset. I reset Google Wallet first so it wouldn't break, but I haven't had a chance to try using it at a place I know it works.

    If you're on 4.0.4, you should be able to use the browser trick to get the official market version.
     
  12. Trel

    Trel Well-Known Member
    38

    Nov 9, 2009
    252
    10
    38
    Everything I read said the market trick was fixed a while ago and now brings you to the page with no install button.
     
  13. umataro42

    umataro42 Well-Known Member
    53

    Aug 3, 2010
    310
    66
    53
    Male
    San Pedro, CA
    I had that happen too, when I was still on 4.0.2.
    But after the update to 4.0.4, I was able to download it off the browser on my phone. I forgot to mention, just do the whole download from the browser, instead of switching to Market at any point. That was how it worked for me anyway.
     
  14. Trel

    Trel Well-Known Member
    38

    Nov 9, 2009
    252
    10
    38
    On the browser, it just tells me none of my devices are compatible. How are you getting it from there?

    Additionally if this is the apk to sideload, it doesn't install: http://forum.xda-developers.com/showthread.php?t=1365360
     
  15. Trel

    Trel Well-Known Member
    38

    Nov 9, 2009
    252
    10
    38
    (Is there a different source for the apk so I can try sideloading it?)
     
  16. jaydotelloh

    jaydotelloh Well-Known Member
    88

    Feb 10, 2010
    362
    291
    88
    Mech. Engineer
    Buffalo, NY
    So I was playing around with my Gnex trying to get it to read my work I'd badge which uses RFID to open doors. I couldn't get it to read. So I looks for apps made to read credit cards and try my credit with pay pass. Still no dice.

    I have not used NFC or beam on it so I don't even know if my NFC works. So, is there any way to check it? Is it possible to have a defective NFC chip and I never even knew it (had it since day one). Any thoughts would be nice.
     
  17. joesixpack

    joesixpack Well-Known Member
    53

    Jan 25, 2012
    338
    82
    53
    Male
    Northeast OH
    Download Taginfo from NXP Semiconductors and open it. It will tell you if your NFC is working if the app continues to run. Then try scanning a card with a chip in it (a Chase card worked on mine). Should pick it up and display the relevant card info. This may not be foolproof but was enough to convince me that mine was working.
     
  18. AntimonyER

    AntimonyER AF Addict
    VIP Member
    1,343

    Jun 18, 2010
    13,646
    8,004
    1,343
    Statesboro, GA
    I merged this with another thread on the same subject, thanks for understanding. :)
     
  19. jaydotelloh

    jaydotelloh Well-Known Member
    88

    Feb 10, 2010
    362
    291
    88
    Mech. Engineer
    Buffalo, NY
    Thanks! Was at work on the phone app and didn't do a search or anything.
     
Tags:

Share This Page

Loading...