Can't Get Past LoginSupport

Last Updated:

  1. cleverlemming

    cleverlemming New Member This Topic's Starter

    Aug 28, 2010
    Likes Received:
    I bought an barely used T-mob G1 with Tmobile unlock code but I have never been able to get it to work. I'm using it in the USA. I can't get past the login but the factory part number is is 99HEW306.

    I bought the Tmobile G1 unlimited plan and installed the SIM card but could never get past the Google login. There's no problem with the IMEI. The antenna bar always showed no signal; the phone would churn and then report that it couldn't contact Google's servers. Under wireless settings -> network operator, it displays a message that my SIM card does not allow a connection to this network.

    I gave it to a local cell phone repair store and they kept it a week but couldn't fix it. They said there was nothing physically wrong with the phone. What I would really like to do is take a sim from a working G1 and try it in my phone but the three Tmobile stores I visited could not/would not help me with this. The previous owner demonstrated the phone to me with his SIM card in it before I bought it and I could see all of the applications.

    After two weeks, I cancelled my contract, although I still have a pay-as-you-go voice only sim for my Nokia, that I tried switching to Sidekick and using with the G1 (have since read here why that won't work). One of the repair people recommended that I do a factory reset and enter the unlock code, which I did after I gave up on my contract, so the phone is now unlocked, although I'd still like to use it on Tmobile. If I try to find a network on my unlocked phone with a Tmobile voice only SIM, and search for 2G networks, it displays AT&T only but will not allow me to connect.

    I'm reluctant to bring it to another repair shop as although they say they're authorized, no one I've talked to has the HTC diagnostic SIM and they don' t seem to know much about software, just replacing parts.

    Does anyone have an idea for me? I've read that this can happen if the account is not set up correctly at Tmobile but they seemed to know what they were doing.

    Thanks in advance for any advice.

  2. fratermus

    fratermus Well-Known Member

    Aug 7, 2010
    Likes Received:
    If you use an ATT sim to get the login done you'll have to plug in ATT APNs.

    Easiest thing would be to borrow a Tmo sim with data plan on it for about 5mins.

Share This Page