Can't get past T-mobile registration


Last Updated:

  1. aricmonde

    aricmonde Member This Topic's Starter

    Joined:
    Oct 16, 2010
    Messages:
    6
    Likes Received:
    0
    Hi!
    I just bought a HTC G1 from the internet like 1 day ago. The problem is that I can't seem to get it to sync with my google account. It says I don't have an internet connection. The problem is that I can't sync it witg my wifi, so what do I do to get around this problem and start enyoing Android?

    It's a US-spec phone with a swedish sim. Why shouldn't it work?

    Hope someone can help me!

    Best of wishes
    Micke "aricmonde"
     

    Advertisement
  2. barrybob

    barrybob Member

    Joined:
    Oct 16, 2010
    Messages:
    23
    Likes Received:
    3
    You need to set a new APN to allow data transfer specific to your mobile carrier. Menu, APN, New APN

    Sorry cant be more specific as not too conversant on the terminology.
     
  3. aricmonde

    aricmonde Member This Topic's Starter

    Joined:
    Oct 16, 2010
    Messages:
    6
    Likes Received:
    0
    When I get to "new APN" the list is blank:( what do i do?
     
  4. aricmonde

    aricmonde Member This Topic's Starter

    Joined:
    Oct 16, 2010
    Messages:
    6
    Likes Received:
    0
    It seems like a need a sim-unlock tool. Where can I find a scam-free one?
     
  5. Baggy

    Baggy Well-Known Member

    Joined:
    Aug 26, 2010
    Messages:
    167
    Likes Received:
    19
    can you tell what sim you have put in i.e. Telia or Sweden 3G

    as you may be able to find the APN for i.e I'm with '3' so mine was three.co.uk.

    as for your MCC MNC codes

    Mobile Network Code - Wikipedia, the free encyclopedia

    I had similar problems with mine where i got a t mobile g1 of ebay so i unlocked it for '3' but couldn't sync with google account. i fixed it by factory reset and passing set up, went to wifi and signed on there. then i set up my APN
     
  6. barrybob

    barrybob Member

    Joined:
    Oct 16, 2010
    Messages:
    23
    Likes Received:
    3
    You need to set up a new APN

    As there have been 2 ways described how to get past the registration screen, this is the way I did mine


    Search "<your mobile carrier> APN settings"

    Enter the carriers name, then 'under APN' the setting name, eg. TeliaSonera is - online.telia.se



    Thats all I had to do albeit with a different APN because I am in a another part of the world.
     
  7. aricmonde

    aricmonde Member This Topic's Starter

    Joined:
    Oct 16, 2010
    Messages:
    6
    Likes Received:
    0
    It is a Telia SIM.

    Should i downgrade to RC29, and then try? will it be any different?
     
  8. Baggy

    Baggy Well-Known Member

    Joined:
    Aug 26, 2010
    Messages:
    167
    Likes Received:
    19
    try [settings>wireless controls>mobile networks>access point names]

    Name: Telia Internet
    APN: online.telia.se

    MMSC: http://mms.telia.se
    MMS proxy: 193.209.134.132
    MMS port: 9201
    MCC: 240
    MNC: 01

    [if needed Authentication type: none]
    leave the rest as <not set>
    try the ones in RED 1st the black ones may help with MMS
    and save

    this should help at least with getting you on the internet and google account
    let me know if this has worked as you may not be alone!!

    ps i don't think you need to downgrade, its mostly for when your wanting to root your phone.
     
  9. aricmonde

    aricmonde Member This Topic's Starter

    Joined:
    Oct 16, 2010
    Messages:
    6
    Likes Received:
    0
    I entered only the APN and atuhentification as default. It sorted itself out:) so now it all works:D
     
  10. Baggy

    Baggy Well-Known Member

    Joined:
    Aug 26, 2010
    Messages:
    167
    Likes Received:
    19
    awesome
     

Share This Page

Loading...