Can't get push email to push using HTC Desire-always reverts to manualSupport


Last Updated:

  1. howard_page

    howard_page New Member This Topic's Starter

    Joined:
    May 26, 2010
    Messages:
    4
    Likes Received:
    0
    Hi,
    I have a strange problem with Push email on my HTC Desire. I can set this up no problem - email comes in but only manually. I cannot get the push to actually work. When I go into the send receive schedule I can set up the days/hours for peak off peak and push but regardless of what I set these to be, when I go back to the previous screen it always says the Schedule is Manual. I've tried setting up lots of variations from manual through timed to push but still the same. Net result is push never seems to happen - manual overrides my schedule. To pick up email I have to go into email and do a manual sync.:confused:

    Has anyone seen this before? Is there something else to set up or is it a bug?? Thanks in advance! Howard.
     

    Advertisement
  2. Yenzehn

    Yenzehn Well-Known Member

    Joined:
    Mar 1, 2010
    Messages:
    262
    Likes Received:
    58
    What email service are you using?

    If you are using gmail, have you enabeled the push settings on your gmail account?
     
    howard_page likes this.
  3. howard_page

    howard_page New Member This Topic's Starter

    Joined:
    May 26, 2010
    Messages:
    4
    Likes Received:
    0
    Hi,
    I am using exchange - the server settings and log in info are fine - it can pull down email no problem. The issue is with the send receive schedule - if I go to settings, send & receive, schedule - I then select peak days and times and choose push for both peak and off peak. When I then go back to the previous menu under the Schedule button it still says manual. This is also the case if I select any other regular pull for every nn minutes - when I go back to the previous menu it always says manual. And indeed for this email account it is always set to manual. For my other pop3 email accounts they pull email in at the chosen frequency and times fine with no issue.
    I had push email working with my previous Windows Mobile device so I assumed the server settings were good for the Desire.
    Thanks again,
    H
     
  4. Yenzehn

    Yenzehn Well-Known Member

    Joined:
    Mar 1, 2010
    Messages:
    262
    Likes Received:
    58
    Yeah it sounds like a problem with the app itself.

    I cannot find anyone who shares this issue, so I would suggest trying to contact HTC support - you may get lucky.

    Another thing that may be worth trying, but more extreme, is trying to reset the phone, or waiting for an OS update which will reinstall all factory apps.
     
  5. howard_page

    howard_page New Member This Topic's Starter

    Joined:
    May 26, 2010
    Messages:
    4
    Likes Received:
    0
    Hi Yenzehn, many thanks. It isn't really worth the hassle of a reset. I've tried rebooting and removing the battery and a few other things all to no avail. I'll watch out for updates and I'll try HTC support!
    Thanks again for your help mate,
    Howard
     
  6. bdndk

    bdndk Member

    Joined:
    May 16, 2010
    Messages:
    11
    Likes Received:
    1
    I have the exact same problem, also using Exchange. No solution yet though :-(
     
  7. Ash Kapow

    Ash Kapow New Member

    Joined:
    May 27, 2010
    Messages:
    1
    Likes Received:
    0
    Looks like that's now 3 of us having the same problem.

    I have it as well. I'm on T-Mobile and have an unlimited internet package, so I know it can't be a restriction on internet usage.
     
  8. Nappy

    Nappy New Member

    Joined:
    Jun 2, 2010
    Messages:
    1
    Likes Received:
    0
    I've got the same.

    HTC Desire exchange sync is manual. Have tried a few changes to the schedule as well.
     
  9. EnochRoot

    EnochRoot Active Member

    Joined:
    Mar 22, 2010
    Messages:
    38
    Likes Received:
    5
    Hi there. I just started using K9Mail (free app) last night and it gets mail from my work Exchange account over IMAP (and Gmail too) and I have found the "push" functionality to be excellent.

    I have had problems connecting to my Work account over Exchange ActiveSync, so I just use IMAP instead and it works pretty well with K9Mail so far! Plus IMHO, K(Mail is better app than the standard email app on the Desire.
     
  10. spen2

    spen2 New Member

    Joined:
    Jun 3, 2010
    Messages:
    2
    Likes Received:
    0
    I had this problem as well exchange active sync as well. I discoved that Auto-sync was turned off. Go into Settings / Accounts & Sync and tick Auto-sync to turn it back on. This will solve your problem
     
  11. Qashqai

    Qashqai Member

    Joined:
    Jul 25, 2010
    Messages:
    5
    Likes Received:
    0
    Even though I checked all settings, it still doesn't automatically push my mail. Also the alerting (vibrate) does not work... Hope all will be fixed in Froyo...
     
  12. ncjharris

    ncjharris Active Member

    Joined:
    Jun 24, 2010
    Messages:
    25
    Likes Received:
    1
    I have it too, with Hotmail, and exchange server and an Icewarp account.

    I can get the emails when I go into the inbox (it automatically starts to sync when I open it), but when on the home screen, or with the phone screen blank, nothing happens. The settings are set to sync every 15 mins and the auto-sync is on.

    Would be interested to hear if anyone has solved this without the need for a 3rd party app?
     
  13. ncjharris

    ncjharris Active Member

    Joined:
    Jun 24, 2010
    Messages:
    25
    Likes Received:
    1
    Ok, i've been having a play and i think i may have cracked it.
    I did have a task killer on there, but to be honest is more of a pain than a help as it kills things i want to run until i remember to add them to the ignore list.

    I thought it only killed non-system apps, but i've removed it, re-set up the sync settings and it appears to be working.

    Not too sure if you guys may have an app killer or similar?
     
  14. Qashqai

    Qashqai Member

    Joined:
    Jul 25, 2010
    Messages:
    5
    Likes Received:
    0
    @ncjharris: GREAT! Thanks!
    I had indeed also app manager running to kill some apps. I thought it only killed apps I selected to kill, but eventually it looks like it kills more than that!

    Uninstalled it and now it works the way it should work!

    Thanks again.
     
  15. irfan

    irfan New Member

    Joined:
    Apr 13, 2010
    Messages:
    3
    Likes Received:
    0
    Had same problem a few weeks back and cleared cache for the mail application (Settings>Applications>Running Apps>Mail)

    Worked fine for a few weeks but has reappeared again. Now it would not resolve even after cache clean
     
  16. SUroot

    SUroot Well-Known Member Developer

    Joined:
    May 25, 2010
    Messages:
    23,925
    Likes Received:
    5,304
    Another case for not having a task killer then.
     
  17. Sky King

    Sky King Member

    Joined:
    Dec 28, 2010
    Messages:
    5
    Likes Received:
    0
    I am running the HTC mail app on Froyo (2.2) on an EVO and I was having ther same problem as others--no matter what I set the schdule to, my Exchange Active Sync always said "manual".

    I just now saw spen2's post from a few months ago and he has it spot-on. Automatic syncing was turned off, so a few things like weather and exchange weren't updating for me. I did as he said and bingo, it all works. Automatic DOES burn a little more battery so a lot of folks leave it off, but getting mail to my device on a short polling schedule is important to me.

    Go to Settings--the main device settings menu, not the e-mail account's settings... one of the settings tabs is called "Accounts & sync" and you go in there and turn "Auto-sync" on. There's a list of accounts that are able to use auto-sync, make sure the ones you want are on and the wants you don't want aren't, and you can add accounts too.
     

Share This Page

Loading...