1. Introducing Channels - a new way to chat with other Android users!
    Dismiss Notice

Can't get Setting Profiles to work correctly


Last Updated:

  1. CharlesLewis

    CharlesLewis Well-Known Member This Topic's Starter

    Joined:
    Jun 29, 2010
    Messages:
    183
    Likes Received:
    7
    Don't know if I am setting something wrong or if the app isn't going to do what I want, so I'm hoping some users can help.

    I want to keep the phone from ringing during my meal times, so I have set a profile called "Meal." I have it set to Silent mode and have turned media volume to zero (I use an MP3 song for my ring, so I figured doing both would be safer). I have set the rule to activate "Meal" from 18:00 to 19:00.

    I set this up over the weekend, but I got a call tonight (and it rang) at about 6:50 (18:50).

    Am I missing something in my settings? I have the full version, not the trial.

    (I know some folks like Tasker, but I gave it a lookover and was totally lost in the complexity of it. I'd rather turn the sound off and on manually!)

    Thanks for any help you can provide.
     

    Advertisement
  2. Szadzik

    Szadzik Well-Known Member

    Joined:
    Feb 15, 2010
    Messages:
    5,413
    Likes Received:
    715
    You said you set it up for the weekend, but it was Monday when you wrote and you said 'Today'.

    Make sure all the days are set up correctly in the rule and both condition and action are set up correctly.The condition will be the time and action will be to activate the Meal profile in your case.

    Do you have any other profiles in there? Make sure none of them are conflicting with the Meal profile and if they are try using the Priority option to make sure Meal overrides other profiles.
     
    CharlesLewis likes this.
  3. CharlesLewis

    CharlesLewis Well-Known Member This Topic's Starter

    Joined:
    Jun 29, 2010
    Messages:
    183
    Likes Received:
    7
    My original post must not have been as clear as I thought. I have the rule set to activate meal "during 18:00 to 19:00 Mon, Tue, Wed, Thu, Fri, Sat."

    The only other rule I have is active 8:00 to 11:00 on Sundays.

    Hope this helps someone figure out what's going on.
     
  4. Szadzik

    Szadzik Well-Known Member

    Joined:
    Feb 15, 2010
    Messages:
    5,413
    Likes Received:
    715
    1. When the time comes for the rule to become active (say 18.10) go into Setting PRofiles and see if that rule is shown as active. If it is, it means that there is something else that is set up wrong in the rule and that is why it does not work. If it is not showing awss active, you have to find out why it is not activating properly.

    2. Do you use any type of Task Killer? If so, make sure that it does not auto-kill Setting Profiles.
     
    CharlesLewis likes this.
  5. CharlesLewis

    CharlesLewis Well-Known Member This Topic's Starter

    Joined:
    Jun 29, 2010
    Messages:
    183
    Likes Received:
    7
    I use Advanced Task Killer, but it's set to ignore "Setting Profiles."

    I'll set up a test this afternoon and see if the profile is active.

    Thanks!
     
  6. Szadzik

    Szadzik Well-Known Member

    Joined:
    Feb 15, 2010
    Messages:
    5,413
    Likes Received:
    715
    Let us know how it works.
     
    CharlesLewis likes this.
  7. meyerweb

    meyerweb Well-Known Member

    Joined:
    Jun 4, 2010
    Messages:
    435
    Likes Received:
    110
    Another possibility, if you have multiple profiles defined, and rules set to activate them.

    If you set "meal" manually, and another profile was set automatically, SP decides what profile to actually use based on priority of the rule. Priorities can be defined from, I think, Lowest through Highest, with about 7 different levels. Manually set profiles have a priority right in the middle.

    So if you have a profile that was set active with a rule set at "high" priority, and then manually set your meal profile, it will end up getting over ridden by the higher priority one. If both profiles are set to "normal" priority, it's possible for both profiles to be active at once, and I haven't yet tried to figure out how SP handles conflicts.

    Are you using the SP Widget? If you assign a different color to each profile, the widget will show you what profile is active (or which profiles, if more than one).

    Finally, there's a support forum for SP. Go to Home Setting Profiles.
     
  8. CharlesLewis

    CharlesLewis Well-Known Member This Topic's Starter

    Joined:
    Jun 29, 2010
    Messages:
    183
    Likes Received:
    7
    Just got back to this thread. I set up another rule with the same profile, and suddenly both became active. Don't know why, but apparently it "pushed" the old rule into waking up.

    Don't argue with success!
     

Share This Page

Loading...