Can't get WIFI to connect at homeSupport


Last Updated: 2013-01-21 18:07:54
  1. rdalcanto

    rdalcanto Well-Known Member

    Both my original Droid and Thunderbolt won't connect to my home WIFI. The desktop computers work fine. I tried using WEP at 128bit and 64bit, and it doesn't make a difference. It says optaining IP address for ever, and then fails. I can use the open network at work with no problems. IT is a Belking Router. Anyone else have this problem? Is it a setting on Android that I need to fix somewhere?

    Thanks!

    Advertisement
  2. rexdog1888

    rexdog1888 Well-Known Member

    Try using WPA
  3. CyberPitz

    CyberPitz Well-Known Member

    I have the same problem with WEP networks on my Archos 101 tab and my OG Droid. It will connect but never be able to pass much (if any) data. WPA networks work fine.

    Really annoying. GF has a WEP network, and can't remember her login info (And her router is crap, so factory resetting would probably ruin her network forever), so she's gotta connect to the neighbors network...
  4. Odinist

    Odinist Well-Known Member

    Why the heck are you using WEP anyway?
  5. gregg5150

    gregg5150 New Member

    The Thunderblunder.....was at verizon at 9am, got the Thunderbolt, activating it is diff now...don't use *228. Anyhow, finally got the phone to work....but here comes the good part. I just wanted to activate the phone then deactivate to use at a later date. Anyhow, they couldn't get my old phone activated again because I still had a "pending" when I activated the Thunder. Turns out that the SIM card never activated. So my guys at Verizon were on the phone again to tech and this was not good. It seems they need to call another number to activate SIM card, however, as it turned out, the SIM is future dated to April 5th and tech said there is nothing they can do till then. The phone will operate on 1x and that is all, no 3 or 4g and I think wifi will not work either. I was at the store for 4 hrs and finally cancelled the Thunderbolt. Never did get it to work right. The Verizon tech said they are swammped with calls but could do nothing till April 5th on about half the phones ?? I'm not a tech type and really don't know what this all means. At my store they stopped selling the TB. They also activated some TB's ahead of me sending them out the door not realizing the SIM card wasn't activated and are calling all those people back to explain the problem. At best the Thunderbolt was a cluster f**K this morning and after a wasted 4 hours no go on the phone. There is going to be a hugh amount of probs and pissed off people in the next few days................anyhow that was my experience.
  6. Odinist

    Odinist Well-Known Member


    What does this have to do with the OP's post about WiFi?
  7. rdalcanto

    rdalcanto Well-Known Member

    I tried that too. I just retried default settings on the router with no security, and can't get that to work either. Everything else will work (3 desktops, 2 Itouches, old Ipad). There is something about Android and my router.... My original Droid worked until a few months ago, when they upgraded Android. Any other ideas? :mad:
  8. Eleer

    Eleer Well-Known Member

    Don't tinker with any of the router/modem settings. When I experience problems pertaining to not being able to connect my laptop/phone to WiFi, I simply unplug the main power chords to BOTH the modem and the router. Leave it unplugged for a minute then plug it back up again. Doing this will refresh your WiFi connections. If this doesn't work, simply unplug your modem and then RESET your router. (There should be a button on the back of the router you press and hold). Hope this helps.
  9. welzie

    welzie Member

    I am having the same issue. thunderbolt will NOT connect to my wireless G router. It's an old microsoft branded router.

    I have tried these things to no avail. with a modem, router, and phone restart after each.
    1)wep key
    2)wpa/wpa2
    3)wpa/wpa2 + turning off "mobile network, connect to internet" option

    The result is the same for all of these. Phones sees network. Click connect. Enter password then phone keeps saying obtaining ip address and never does. Laptop and samsung captivate worked/continue to work with wep and wpa.

    Can't believe htc has an issue with wifi, i mean wifi. really?
  10. dbcad7

    dbcad7 Active Member

    You can also try renaming the router in case it is a matter something being corrupted in the password file.. for example, MAC's are infamous for this.. if the original key is wrong, often the only way to fix it, is to rename the router.. deleting the old connection, and creating a new one where it even asks for a new key doesn't work.. renaming does.. worth a try.
    JediSpice17 likes this.
  11. balefire

    balefire Active Member

    I also had problems connecting my DROID to my Linksys WRT54G wifi router.
    To fix it, I had to:
    -flash the latest firmware
    -reset the router
    -use WPA Personal, hidden SSID, stock channel, no IP restrictions

    Now I can use wifi with both my wife's DROID and my TB.
    good luck.
    JediSpice17 likes this.
  12. dbcad7

    dbcad7 Active Member

    @balefire
    Just curious, in switch to a hidden SSID.. did you rename it ?
  13. balefire

    balefire Active Member

    I did not rename it
    the first time my phones recognized the hidden SSID using the non-hidden SSID, probably a bug.
    the second time, the phones could not find it, even though the SSID name was stored.
    i then deleted the SSID on the phone,
    added the hidden SSID manually on the phone.
    now my wifi works on all my phones and tablets.

    in the end, i don't think keeping the SSID name the same matters as i had to manually add it anyway.
  14. dbcad7

    dbcad7 Active Member

    It's just a wag (wild a$$ed guess), as I don't know for sure.. but I think each connection you make, has it's own password file.. I think there is a problem in editing that file once it's created.. Maybe when you switched to hidden, and created the manual connection, it was forced to create a new file instead of editing the old one.. I could be wrong (happened once several years ago).., but it definitely needs looking into.
  15. aodmisery

    aodmisery Well-Known Member

    the first few days i had no problem with my wifi but now the tb doesnt want to seem to connect anymore
  16. jasoraso

    jasoraso Well-Known Member


    After an update on my droid incredible, my belkin router also had problems. I think something with htc and belkin doesn't jive.

    A solution I found was to MANUALLY set the ip address.

    If you can verify this works for you, you can download an app - wifi static which will automatically switch it for you.

    I ultimately switched to a different router (i moved top a bigger house and needed more coverage) and set the belkin to pass-through mode and font have any problems with thunderbolt or my droid.
  17. Prim8

    Prim8 Well-Known Member

    Any time I have ever had a device stuck at obtaining an IP address only to error out it's always been that I typed in the password wrong.
  18. rdalcanto

    rdalcanto Well-Known Member

    The TB will tell me if the password is wrong - I tried that on purpose. Seems like an Android vs Belkin router problem since my Moto Droid won't connect anymore either with the current version of Android.... :( Hoping 4G comes soon so I won't need Wifi.
  19. rdalcanto

    rdalcanto Well-Known Member

    You manually set the IP address in the router or the phone? :confused:
  20. dvst8

    dvst8 Active Member

    When mine would not connect to my router it was because the Wireless N Router was in "Mixed" mode. When I changed it to "B+G" only mode the Thunderbolt was able to connect right up. I had the same issues with my original MotoDroid when I first got it.
  21. rdalcanto

    rdalcanto Well-Known Member

    Tried only B+G mode. Still no dice.... :(
  22. MyTBoltisuno1

    MyTBoltisuno1 Member

    my wifi issue is i cant connect at home .. abt to venture out to see if i can connect at a public open wifi... we shall see....
  23. MyTBoltisuno1

    MyTBoltisuno1 Member

    still having mad issue with the wifi radio at home - doesnt connect at all it is in scanning mode despite the fact that i enter in correct password.. no issue with my bb torch but this is annoying and i am about to call amazon wireless to send it back... too much of a hassle to deal with a simple function.. i dont need the 4g lte at home all the time especially with a wifi network like mines (cable modem)
  24. gynormus

    gynormus Well-Known Member

    you know whats weird i cannot connect to my wi-fi at home ONLY when the SSID is not being broadcasted... wierd huh?? anyone know whats up?
  25. MyTBoltisuno1

    MyTBoltisuno1 Member

    i can not connect to my home wifi network it has a wep key - but when i go to a public open network - it connect without any problem.. what the heck is going on... any solutions to make my wifi hookup work at home please?

Share This Page