Can't Install Google EarthSupport


Last Updated:

  1. captainm27

    captainm27 Well-Known Member This Topic's Starter

    Joined:
    Jun 8, 2010
    Messages:
    174
    Likes Received:
    20
    For some reason, when I try to install Google Earth, it says Package File invalid. Anyone experience this too? I have 2.1, rooted.

    Thanks.
     

    Advertisement
  2. smtom

    smtom Member

    Joined:
    Sep 17, 2010
    Messages:
    11
    Likes Received:
    1
    It's a big file - do you have adequate room in the install location?
     
  3. captainm27

    captainm27 Well-Known Member This Topic's Starter

    Joined:
    Jun 8, 2010
    Messages:
    174
    Likes Received:
    20
    Oh yes, plenty of room. I have downloaded plenty of other programs, but this is the only one that i get that error on.
     

Share This Page

Loading...