Can't install Google G1 Driver

Discussion in 'Application Development' started by giantshroom, Apr 21, 2009.

  1. giantshroom

    giantshroom Member
    5

    Apr 21, 2009
    5
    0
    5
    Every time i plug in my G1, windows (vista 32 ultimate) automatically installs a microsoft driver. when i go to device manager, uninstall the ms driver, and then try to reinstall the google driver i get an error: "Windows encountered an problem installing the driver software for your device...THis device cannot start (code 10)."

    in the driver-selection process, after I point windows to the right .inf file, im asked to choose from HTC Dream, HTC Dream Composite ADB Interface, Android Sooner Single ADB Interface, Android Sooner Kernel Debug Interface, Android Sooner Composite ADB Interface, and Android Sooner ADB Testing Interface. I've tried most of them, but every time i get the same code 10 error. USB debugging IS enabled. i just don't know what i'm doing wrong.
     

    Advertisement
  2. RozzaC

    RozzaC Well-Known Member
    73

    Feb 25, 2009
    647
    10
    73
    Student
    London, UK
    What SDK are you running?
    I never saw all those options when I selected it.... o_O
     
  3. giantshroom

    giantshroom Member
    5

    Apr 21, 2009
    5
    0
    5
    1.1 but the USB driver that's included wasn't formatted correctly, and windows wouldnt read it. I ended up searching around and someone in a forum was able to provide a working one. But i guess i don't know for sure that it's working, because i can't get my phone to connect...maybe the driver i got from the forum isn't right. i'll re-download the sdk and try again
     
  4. giantshroom

    giantshroom Member
    5

    Apr 21, 2009
    5
    0
    5
    Ok, I downloaded the SDK again from the android site, got the x86 drivers
    I went to device manager, found "Android Phone," right-clicked, and selected update driver. next i pointed the wizard to the x86 drivers i just downloaded and i got this message:

    The folder you specified doesn't contain a compatible software driver for your device. If the folder contains a driver, make sure it is designed to work with Windows for 32-bit systems."

    ???
     
  5. RozzaC

    RozzaC Well-Known Member
    73

    Feb 25, 2009
    647
    10
    73
    Student
    London, UK
    The USB driver that I got with my 1.1 SDK download worked perfectly fine for me...

    o_O

    Uninstall the driver's you've attempted to install and re-install them again...
    Don't just try and update the driver...
     
  6. giantshroom

    giantshroom Member
    5

    Apr 21, 2009
    5
    0
    5
    If i uninstall the driver in device manager, the phone disappears from the list, and the only way to get it to come back is to hit the 'search for new hardware' button or to unplug the phone and plug it back in. and every time i do that, the microsoft drivers get installed automatically, theres no popup, no dialog, nothing.
     
  7. justjimjpc

    justjimjpc Premium Member
    VIP Member
    653

    Nov 3, 2008
    10,543
    210
    653
    Washington DC, USA
    This might be a stupid question, and I might not understand or follow what is going on here !! But, Are you able to do a normal USD hookup to a pc and view the files and folders on the SDCard...

    This should be done with "USB Debugging" NOT selected ...
    (under Applications|App Debugging)

    then when the USB appears in the nofication bar ... you do the pull down and select Mount Drive ..

    You might get the Found New Hardware Wizard... Just Cancel out the Wizard .. (this will indicate that you have Debugging Enable) --DISABLE IT!!

    On the phone's notification -- click on the "USB connected"
    And then select "Mount"

    Now you should find the SDCard drive available for viewing ...

    This will confirm the USB interface and the usb cable are functioning properly ...
     
  8. giantshroom

    giantshroom Member
    5

    Apr 21, 2009
    5
    0
    5
    I am able to mount the SD card with or without USB debugging enabled. It seems to make no difference. And no "Add new hardware" wizard comes up in either case.
     
  9. justjimjpc

    justjimjpc Premium Member
    VIP Member
    653

    Nov 3, 2008
    10,543
    210
    653
    Washington DC, USA
    Well, that is good to know .... mine pulls up the wizard if I have debugging on ... but I also dont have anything SDK, Eclipse installed on my work Computer ... so that is probably why the wizard popped for me ..
     
  10. Crashthatvh

    Crashthatvh New Member
    5

    May 12, 2009
    2
    0
    5
    I'm having the same problem. Vista automatically installs the USB-external-drive drivers for reading the SD card, then right clicking and choosing "update drivers" and pointing it at the inf file gives the same error as above:
    "The folder you specified doesn't contain a compatible software driver..."

    I've tried setting nointegritychecks to "yes", but to no avail.

    Running Vista 32bit SP1 and trying to connect to HTC magic running Android 1.5.
     
  11. Crashthatvh

    Crashthatvh New Member
    5

    May 12, 2009
    2
    0
    5
    This worked for me. The instructions are at:
    [android-beginners] Re: HTC Magic - Can't install driver on development

    I'll repost them here too:
    (I first disabled automatic installation of drivers- not sure if this was neccessary). To do this on Vista, Right click my computer -> Properties -> Advanced System Settings -> Hardware Tab -> Windows Update Driver Settings -> Choose "ask every time".
    There's also another solution suggested here which may work for some (I had trouble deleting the registry key in regedit though):
    [android-beginners] Re: HTC Magic - Can't install driver on development

    Hope this helps someone!

    Tom.
     

Share This Page

Loading...