Can't mount phone to Win7 PCSupport


Last Updated: 2012-04-19 18:05:09
  1. cyraxote

    cyraxote New Member

    It recognizes that a phone has been attached and gives it a drive letter, but then when I click on the drive, it says "please insert a disk into removable disk".

    USB debugging is unchecked.

    Any ideas?

    THanks.

    Advertisement
  2. Barky

    Barky Active Member

    Change the phone's USB connection mode to mass storage.
  3. cyraxote

    cyraxote New Member

    Yes, I've done that already. No change. I do get the message on the phone "Your SD card cannot be used for mass storage." Or something along those lines. I've tried 2 different cards, same message.
  4. AndyOpie150

    AndyOpie150 <strong> <a href="http://androidforums.com/optimus Contributor

    Go back to the USB debugging mode. As fast as you can (start with it checked) uncheck and check the box. Then go back to your home screen.
    When you plug your phone into your PC you should see a USB icon in the task bar. Pull the dropdown and select to transfer files. Select to enable USB mass storage device. Wait no more than 2 min.
    If this doesn't work you will have to install the LG drivers for you phone. Unplug the phone. Google it. Once you have the drivers installed reboot the PC. Plug your phone back into PC and wait for the Drivers to finish installing. then try again.

Share This Page