Can't mount SD card on my Mac (even with USB debug!)Support


Last Updated:

  1. danray

    danray New Member This Topic's Starter

    Joined:
    Oct 14, 2010
    Messages:
    3
    Likes Received:
    0
    Hello,

    I'm trying to mount my SD card on my MacBook Pro with the stock USB cable. I had a Moto Droid before my Fascinate, and I knew what to do there
     

    Advertisement
  2. GoBruins

    GoBruins Well-Known Member

    Joined:
    Sep 28, 2010
    Messages:
    246
    Likes Received:
    44
    Do you need to install samsung drivers, by any chance?
     
  3. danray

    danray New Member This Topic's Starter

    Joined:
    Oct 14, 2010
    Messages:
    3
    Likes Received:
    0
    For my computer? I wouldn't think so
     
  4. jdella681

    jdella681 Active Member

    Joined:
    Oct 31, 2009
    Messages:
    25
    Likes Received:
    1
    Actually I had a similar issue.. Are you using the cable that came in the box? I was using an lg micro usb and it would only charge the phone. With the samsung cable it worked fine for me. Are you using the stock cable?

    Edit: nevermind just reread the post.. Have you tried other cables?
     
  5. danray

    danray New Member This Topic's Starter

    Joined:
    Oct 14, 2010
    Messages:
    3
    Likes Received:
    0
    Yeah, I tried another USB cable yesterday at an AT&T (not Verizon) store. With that cable, the phone would charge, but the USB mount button wouldn't even appear on the phone. I don't know what the difference in the cable was
     
  6. glroze

    glroze Well-Known Member

    Joined:
    Jun 5, 2010
    Messages:
    51
    Likes Received:
    3
     
  7. sho95

    sho95 Well-Known Member

    Joined:
    Nov 11, 2009
    Messages:
    266
    Likes Received:
    8
    Try to see if it will mount on another computer and if it don't than it could be the actual usb plug loose. When connecting the phone wiggle it to one side then the other and see or hear if it mounts. I seen issues were the usb cable will charge the phone but not send or maintain connection with the computer because of a loose usb plug.
     
  8. JimmieW

    JimmieW New Member

    Joined:
    Oct 22, 2010
    Messages:
    1
    Likes Received:
    0
    Hi Danray, I've got the same problem with a Taiwan Mobile T2 and MacBook. It worked ok the first 2 times now whatever variation I try the SD card doesn't show up ...

    Let me know if you get a fix.

    Best Wishes,
    Jimmie
     
  9. jbirdsf

    jbirdsf Well-Known Member

    Joined:
    Oct 9, 2010
    Messages:
    216
    Likes Received:
    16
    I have a macbook pro and I downloaded salling software which you can find online and download it from the website. It works great. Once I plug in my phone I just pull down the status bar and press the usb connect and it asks me if I want to mount the device. I have had zero problems with compatibility. :)
     
  10. willisan

    willisan New Member

    Joined:
    Jan 29, 2011
    Messages:
    1
    Likes Received:
    0
    Are you using a Fascinate? I dl'd the Salling Media sync app for mac and it still isn't recognizing my phone. The site shows compatabilty for the SGH-i7500 but not for the Fasc. I'm hoping I didn't pick the one and only phone that doesn't sync :/ Other than that however things have been great!
     

    Attached Files:

  11. jbirdsf

    jbirdsf Well-Known Member

    Joined:
    Oct 9, 2010
    Messages:
    216
    Likes Received:
    16
    I do have a fascinate. My original post was pre-DL09 update. Everything worked great before. Since...my macbook pro will not recognize my device! Verizon offered me a new phone, I declined. They gave me a $25 credit, I bought an external sd card reader for $7.99 and take the card out of the phone to down/upload and organize. It is a bit clumsy but it works. They (VZW) promised a fix in the next update. I'm not holding my breath. :mad:
     
  12. jr1463

    jr1463 Guest

    This will work until the fix is in from Verizon or Samsung. It takes a few steps but works!

    First open Terminal (applications - utilities - terminal), then type in "gpt show /dev/disk1" without the quotes. Make sure USB Debugging is turned on. Plug in the phone, it will be detected in Finder as a Verizon CD, after a minute that will disappear, you can eject it to get there faster. Then mount the USB device, wait for the disk error message and select "Ignore" then unmount the card then remount it. Then in the Terminal hit Enter to run the "gpt show /dev/disk1 command". You may have to run the command more than once. It should recognize your card at that point. Then you can access the card as usual.
     
    prachiti likes this.
  13. prachiti

    prachiti New Member

    Joined:
    Mar 2, 2011
    Messages:
    1
    Likes Received:
    0
    Thanks! this works. Till yesterday, when I had the old version (i think DH..) It used to work fine on my Mac Pro. Today, when Verizon shipped me a new phone with current version, the SD card was not recognized.
    With your method it works, its takes several takes, but it works.
    Thanks again, I was gonna return this phone too.


     
  14. garybrower

    garybrower Member

    Joined:
    Mar 5, 2011
    Messages:
    5
    Likes Received:
    0
    I thought this would help (as another reader found it to work), but I must be missing something.

    What should the settings be for "SD card & phone storage" on the "External SD card"?

    What should the settings be for "USB settings"?

    I've tried the suggestion below, but never get the option to "mount the USB device" (and is this on the computer, or on the phone)?

    Oh, and in the Terminal command, is there supposed to be a space between "show" and the "/" before "dev" (or does it make a difference)?

    Thanks!

    Gary

     
  15. Gnomad

    Gnomad Well-Known Member

    Joined:
    Nov 26, 2010
    Messages:
    129
    Likes Received:
    21
    Don't change anything on the "SD Card & Phone Storage" settings. Go to "Settings" then "Applications" then "Development" and turn on "USB debugging".

    Yes, gpt show /dev/disk1 needs to be typed exactly as shown here. There is space between gpt and show, and space between show and /dev/disk1. You can just copy from this post if you need to. Also, depending on your computer setup you may need to use a number other than 1.
     
  16. garybrower

    garybrower Member

    Joined:
    Mar 5, 2011
    Messages:
    5
    Likes Received:
    0
    Gnomad,

    Thanks. What about the setting for "Mass Storage, Media Player, Ask on Connection"? I tried what you've suggested, and I still don't get the option to mount the phone.

    So running the Terminal command hasn't even yet become an option.


     
  17. Gnomad

    Gnomad Well-Known Member

    Joined:
    Nov 26, 2010
    Messages:
    129
    Likes Received:
    21
    I have it set to mass storage mode. What happens when you plug in the phone? Does your phone recognize that it is plugged in to USB?
     
  18. garybrower

    garybrower Member

    Joined:
    Mar 5, 2011
    Messages:
    5
    Likes Received:
    0
    Gnomad,

    Thanks for your help here. The current settings are:
    • USB Debugging On
    • USB Mass Storage on

    When I plug in the phone the following happens/appears on the phone's status line at the top
    • USB Connected
    • USB Debugging Connected
    • Turn off USB Storage

    Then the icons at the top are the standard USB icon, and a red triangle that is linked to the message of how to turn off USB storage.

    On the Mac side, I get two alert boxes. The first tells me that a "new network interface has been detected" and asks if I want to configure it (or set it up -- whatever). The second tells me that the disk is not recognized. If I check (as suggested above) the "Ignore" in that message box, there is no indication at all in the Finder that the phone is plugged in.

     
  19. Gnomad

    Gnomad Well-Known Member

    Joined:
    Nov 26, 2010
    Messages:
    129
    Likes Received:
    21
    After you plug in the phone and these messages come across the status bar, swipe down on the screen and select "USB Connected" "Select to copy files to/from your computer" Then select "Mount" when the blue USB connected message pops up. Wait a few minutes until you get the "Disk you inserted was not readable" error, select "Ignore". At this point, just to be sure, open "Disk Utility" on your Mac, you should see an entry for "Samsung SCH -I500. Select it and then hit "Info". Look at the Disk Identifier, it should say disk1 or some other number. If it is disk1 just copy "gpt show /dev/disk1" without quotes and paste it in Terminal. If it is disk2 or another number just change the 1 to whatever number yours happens to be. When you have that copied in Terminal, look back at your phone and "Turn off USB Storage" select "Turn off" on the blue message that pops up, wait a few seconds and the "USB connected" "select to copy files" message comes back on your phone "select it and mount again. Then bring up your Terminal and hit enter to run the command. You should get something like this,
    start size index contents
    0 1 MBR
    1 128
    129 30904191 1 MBR part 12

    if you do then you should see an entry in Finder for your card, if not try running the command again. I know it sounds like a lot, but once you get the sequence down it really doesn't take to much to get it to work.
     
    garybrower likes this.
  20. garybrower

    garybrower Member

    Joined:
    Mar 5, 2011
    Messages:
    5
    Likes Received:
    0
    Gnomad,

    Thanks! This finally worked! What made it work was that I had to swipe FAST before all of the other messages came through.

    Now, will I have to do this every time? or will the Mac and the phone learn to like each other automatically?

     
  21. Gnomad

    Gnomad Well-Known Member

    Joined:
    Nov 26, 2010
    Messages:
    129
    Likes Received:
    21
    Until Verizon has an update that fixes this you will have to do it every time you connect. To help make it a little easier you can follow the steps in this thread, post #25 will help create a small Mac app that you can save to your desktop and when you get past the Disk read error you can just double click on the app and it will automatically run the terminal commands for you.
     
    garybrower likes this.

Share This Page

Loading...