Can't mount to PCGeneral


Last Updated:

  1. kinzelane

    kinzelane New Member This Topic's Starter

    Joined:
    Dec 9, 2009
    Messages:
    2
    Likes Received:
    0
    I have a Vista 64 bit laptop. Got a droid eris 2 weeks ago or so.

    First time I ever wanted to connect my computer and phone I tried a bunch of things but each time, phone kept saying it was mounting but then would never do it. BUT under settings/SD it knew it was mounted b/c of card size, etc showing up and "Unmount" was selectable. Did lots of things, kept trying, eventually when I tried out the sync feature found out I didn't have HTC sync on my computer, which it said it needed, so I installed that and then tried to mount again and then it worked! I viewed my files, moved some pics around, etc.

    Now I go to mount again and the same thing is wrong... won't connect at all. Tried mounting, unmounting, power cycling, using device manager on my laptop, even took out the card and put it back in, safely removing hardware, back and forth and on and on. Computer knows it's plugged in because it shows up as drive F but when you click on it once it is "mounted" (though I don't think it actually is mounted) - the computer says "please insert disk into drive f". I have USB 2.0 and I got it to work once, I don't understand what is wrong this time!

    Suggestions?
     

    Advertisement
  2. Sterlingmaxx

    Sterlingmaxx Member

    Joined:
    Dec 5, 2009
    Messages:
    13
    Likes Received:
    0
    Unfortunately, instead of a solution, I have to add my voice to yours here...
    I searched for a solution and found your thread...
    Mine is the exact same problem...When I try to open the card in Vista it says to insert a disk in f: (the assigned storage drive)
    I have noticed that it did download the right device driver, because when I go to "Safely Removed Hardware" it does call it "HTC Android Phone USB device"
    I d/l Sync as well, hoping that it would help it recognize, but no luck...
    The ONLY difference between us is that I'm running the 32-bit Vista..
    Anyone have any ideas?
     
  3. Peaser

    Peaser Well-Known Member

    Joined:
    Dec 5, 2009
    Messages:
    103
    Likes Received:
    8
    Hi guys, it works. I have a Vista 64 as well. I forget exactly how you get it to see it, I will try to do it later when I'm near that computer and send directions if you haven't gotten it by then. It does initially say, "insert disk" however.
     
  4. Melissa31

    Melissa31 Well-Known Member

    Joined:
    Dec 9, 2009
    Messages:
    118
    Likes Received:
    2
    If you are using Windows Vista 32bit System then try the following, I had the same issue as you and this worked for me :

    The USB debugging check box in Home > Menu > Settings > Applications > Development needs to be selected for the phone to be able to synchronize with the PC using HTC Sync. On your computer, run HTC Sync. Connect the phone to the computer using the provided USB cable. The first time you synchronize the phone, the Synchronization Settings Wizard starts automatically to help you set up HTC Sync. Select the PC application you want to synchronize with and then select the categories you want to synchronize. Select when to synchronize data and then check the settings that you have chosen. OR You can always go to this page listed below here for support on different ?'s :
    http://www.htc.com/us/support/droid-eris-verizon/help/synchronization
    [​IMG]
     
  5. rigamrts

    rigamrts Well-Known Member

    Joined:
    Nov 19, 2009
    Messages:
    213
    Likes Received:
    1
    as i've said before droids not coonecting to windows is always a windows problem. to fix this and i don't recommend it cause if you lose data it's not my fault.

    refomat that windows box to like new. then before you install all the other stuff you want to your pc connect that droid right up and watch it connect right up.

    this really has nothing to do with any android device at all cause i've seen this comment in all the forums. and the brave who do the system wipe of windows always comback and say wow that fixed it.

    windows is like the 10 dollar slut on the corner everybody's had a peice and most have paid a price. then you have android who comes in and finds windows smoking crack and shooting heroin and say no way am i touching that.
     
  6. Sterlingmaxx

    Sterlingmaxx Member

    Joined:
    Dec 5, 2009
    Messages:
    13
    Likes Received:
    0
    @ Melissa31 - Thanks! That did get HTC Sync to work! So that's awesome, but didn't help in being able to load stuff onto the card itself..still get the same error message "Insert a disk"

    @ Rigamrts - Wow...yeah, I don't think I'm willing to try that...It would take me like 2 days to be able to restore all the things I have going on this computer, and if I lost data...not good.. But your description of Windows..spot on! *laughz*

    There's gotta be another way...maybe just wait till the ver2 update which (I think) will have bluetooth file transfer...
     
  7. Sterlingmaxx

    Sterlingmaxx Member

    Joined:
    Dec 5, 2009
    Messages:
    13
    Likes Received:
    0
    Whhoa! Just figured it out...
    After HTC Sync installed on my computer and it d/l whatever drivers it needed to have, my phone was still plugged in by USB (charging)
    So, I went to my phone and under notifications, the first option (Ongoing) was Turn On USB Storage, then it asked if I wanted to mount the card to transfer files, which of course is what I have been trying to do, and then my autoplay on the computer loaded up the f:
    *sigh*

    So, D/L HTC Sync, Install, On phone go to Notifications, Select Turn On USB
    Storage, Select Mount, drag and drop your files onto your card

    Cheers to all who replied!
    Miguel...
     
  8. Peaser

    Peaser Well-Known Member

    Joined:
    Dec 5, 2009
    Messages:
    103
    Likes Received:
    8
    Yes, here's info from the manual:

    Using the Phone
     
  9. mike johnson

    mike johnson New Member

    Joined:
    Dec 10, 2009
    Messages:
    1
    Likes Received:
    0
    I have almost the same problem but I am using Win7 64 bit. I follow all the instructions including mounting the drive. My Droid shows up in the "Devices" folder but is not listed as a "drive" in Windows Explorer. (And they said Win7 was going to work better....):cool:
     
  10. Sketchee

    Sketchee Well-Known Member

    Joined:
    Dec 5, 2009
    Messages:
    135
    Likes Received:
    3
    This probably won't help you, but I have a Windows 7 64 bit machine as well and have no problems. After I select the USB connected notification, it appears in Windows Explorer :eek:
     
  11. ztsfofo

    ztsfofo New Member

    Joined:
    Dec 18, 2009
    Messages:
    1
    Likes Received:
    0
    took me some time to mount to my vista 64bit too. and when trying to unmount, can't find that notification. it said to unmount before turning off usb storage. weird
     
  12. Sterlingmaxx

    Sterlingmaxx Member

    Joined:
    Dec 5, 2009
    Messages:
    13
    Likes Received:
    0
    I think in this case, the unmounting is from the computer as in "Safely Remove Hardware"....I just use the computer unmount, THEN turn off the usb on the phone...
    I don't think it's a phone notification...
    Loving my Eris by the way...Going to Christmas comparison shop with ShopSavvy this upcoming week...
     
  13. jjr1968

    jjr1968 Well-Known Member

    Joined:
    Dec 15, 2009
    Messages:
    48
    Likes Received:
    6
    when attach phone to PC/laptop, down drag phone screen 1st and pick "mount". Don't go thru puter first.
     
  14. kinzelane

    kinzelane New Member This Topic's Starter

    Joined:
    Dec 9, 2009
    Messages:
    2
    Likes Received:
    0
    Yeah, I don't know if what I was looking for is clear enough. It shows up in windows explorer, but when you click on it, it says "Please insert a disk into drive //whatever I have it plugged in as, usually f or g//" even though it is clearly showing up right there, it can't find it. But HTC Sync can find it and sync. And my phone shows the space available, so I know it is connected on the phone end. I don't know how to get it to work though. It's really annoying. Think I'll have to eventually *gasp* take it into a Verizon store and see if they know whats going on.
     
  15. erisuser1

    erisuser1 Well-Known Member

    Joined:
    Nov 11, 2009
    Messages:
    1,644
    Likes Received:
    759
    I think there might be a mix of different issues here, but it appears that in a few cases reported here, the problems arise not from a problem with the PC, but from a misunderstanding about the way it works - probably because it is more complicated than using a USB thumb drive or an external USB hard drive with a PC.

    The key point is that that the SD card is not made available to the PC automatically as soon as the USB cable is plugged in, even though the correct drivers are in place on the PC - you have to take some further actions on the Eris before that happens. (That's the way it would work with a USB thumb drive or hard drive... but not with the Eris.)

    The reason for this is that the Eris software will not allow the SD card to be used by both the Eris OS at the same time the PC has access to it - and vice versa; and it doesn't just automatically disconnect from one and reconnect the other when the cable is plugged in, because there are usage scenarios where the user does NOT want to mount the SD card on the PC, even though the phone is plugged in to the USB cable (such as using the developers' debugger, running HTC Sync, or simply charging the phone from a PC).

    Also, the way that the words "mount" and "unmount" are used in the Eris menus, it is not completely clear whether they are talking about the relationship of the SD card to the PC, or the SD card to the Eris - so it is a little confusing until you've gone through it and used it couple of times.

    Here is the process end to end:

    1) Plug USB cable in to the PC and the (running) Eris.
    2) Wait for the "USB connected" message to show up in notification area
    3) Open the notification bar and tap on the "USB connected" message
    4) Press the "Mount" button.

    At this point, you should be able to manipulate the files on the SD card from the PC (add, delete, rename, create folders, etc) - it should be at drive E:, F:, or similar, depending on your PC.

    (Note that the Eris will not be able to see the SD card at this point - for instance, playing music or looking at camera shots - the PC has exclusive control of the SD card)

    When finished doing what you want on the PC - just like any other thumbdrive or external USB hard drive, you:

    5) Click on the "Safely Remove Hardware" icon in your System Tray, and select the drive mount point where you saw the files (E:, F:, etc. - wherever the SD card got mounted).
    6) Pull open the notification area on the Eris, and tap "Turn off USB Storage"
    7) Click on the "Turn Off" button.
    8) Unplug the USB cable**

    That's it! Doing this last step (6 and 7) lets the Eris know that the PC no longer is using the SD card, and it will get "re-mounted" by the Eris OS so that all the files on the SD card are available again to the Eris.


    **One last comment, too: on my computer (Windows Xp), I can not repeat this process without unplugging the USB cable and re-plugging it. I don't know if other Windows releases also behave that way or not.

    I hope this explanation is helpful - it's pathetically long.

    eu1
     
  16. rokkstar96

    rokkstar96 New Member

    Joined:
    Jan 20, 2010
    Messages:
    3
    Likes Received:
    0
    try this Menu > Settings > Applications > Development > USB Debugging....un plug then try mounting again
     
  17. astonjay32

    astonjay32 New Member

    Joined:
    Aug 10, 2010
    Messages:
    1
    Likes Received:
    0
    Somewhat related issue that I just found a solution for.

    For those with a Droid Incredible who have had issues with mounting both the SD card and internal storage to a PC (i.e. SD is explorable, but the internal store drive shows up but returns the 'Please insert disk into drive ...' when clicked), here's how I got it working:

    - Setting USB connection type to 'Disk Drive'
    - Turn on USB debugging
    - Connect phone to PC. At this point (at least for me), both drives show up, but only one (the SD card in my case) could be opened and explored.
    - While still connected (this was the key!), on the phone change the USB connection type from 'Disk Drive' to 'Charge Only'. This should make both drives go away in Windows.
    - While still connected, change the option back to 'Disk Drive'. Both drives should now show up in Windows and be explorable.

    Hope this helps someone. Drove me crazy before figuring this out.
     

Share This Page

Loading...