1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

Cant Read NV Items Help!Support


  1. CooLoser

    CooLoser Well-Known Member

    Hey,

    Im trying to flash my Nexus S 4G to boostmobile and im on the final stage of it. I have everything working except for data.

    So, for my donor im using my SAMSUNG PREVAIL but in CDMA workshop when I send spc code and unlock the pohone then try to read both NV items 466 and 1192 it shows as access denied. But 465 and 1194 work. Im trying to get the AAA and the HA shared keys

    ** Do you guys know of any other way to get a hold of my HA and AAA shared keys? **

    Advertisement
    :
  2. bbacc020

    bbacc020 Member

    Find the file stl5 under /dev/block
    copy it (but DO NOT modify it in any way!!!)
    Paste to your computer
    Rename it to cdma.rfs
    Open that file with MagicISO
    and Voila, you will see all of the NV items listed under NVM.
    wilfredojr978 and kolosus like this.
  3. kolosus

    kolosus Well-Known Member

    Thank you bbacc020 for pointing that out. The procedure you outlined worked perfectly. It didn't help me directly because I was trying to do something else but it gave me a nudge in the right direction to see the solution that I required.
  4. jwh42000

    jwh42000 Well-Known Member

    Ya thank you as well. I can use it elsewhere as well
  5. CooLoser

    CooLoser Well-Known Member

    What is MagicISO
  6. kolosus

    kolosus Well-Known Member

    Google is your friend.

    MagicISO is a powerful CD/DVD image file creating/editing/extracting tool. It can open / create / edit /extract CD/DVD image files, and it can convert bin to iso and ...
  7. CooLoser

    CooLoser Well-Known Member

    I dont see the stl5 under the /dev/block
    i see folders "platform" and "vold" and it isnt under either
  8. kolosus

    kolosus Well-Known Member

    Use a different file manager to look into the folder. I used ES File Explorer. I cant seem to read the contents of /dev/block in Ghost Explorer.
  9. CooLoser

    CooLoser Well-Known Member

    I used root explorer and can't find it WTF and btw is the stl5 in sdcard cause es file explorer only sees SD card
  10. kolosus

    kolosus Well-Known Member

    By default ES File Explorer is only supposed to look into your /mount/sd. You can touch the star in the upper left hand corner (Favorites) and then select to see your / (root) folder. Navigate from there.

    You might have to go into settings and allow root explorer and might have to mount file system r/w.

    Just be careful of what you do after you allow root. Might want to read up on Odin before you mangle your phone.
  11. CooLoser

    CooLoser Well-Known Member

    When I try to copy it says stl5 copy failed and i cant move it anywhere. Can i read internal memory from my pc?
  12. CooLoser

    CooLoser Well-Known Member

    edit: this all works but i cant get the nv items. they are locked preventing me from reading ha and aaa shared keys

    thanks anyways :/ now i gotta buy an incognito to finish this
  13. verec08

    verec08 Member

    So is it impossible to get the HA and AAA shared keys from Galaxy Prevail? I'm on desperate need on getting mine!!!
    Help Please
    wilfredojr978 likes this.
  14. trialnerror

    trialnerror Well-Known Member

    no, It is not impossible. A Broken Screen forced me to use my Prevail as a donor.

    the 4 NV files needed are in /dev/block/stl5,(465,466,1192,1194). once you copy the folder to your sdcard, transfer it to your computer,you change the folder name (stl5) to cdma.rfs, extract with MagicIso,or ISOmaster. use a Hex Editor to view them. I had to make those 4 text files the hard way to use in cdma workshop for the S2.
    Google for better instructions, there is also a video out there.
    wilfredojr978 likes this.
  15. wilfredojr978

    wilfredojr978 Well-Known Member

    Ive flash a htc evo 4g to boost using my prevail.So it can be doen i notice their are differences in the update that get released.so also the version of android you are on could effectt hat as well.
  16. bwbu

    bwbu New Member

    When I copy the stl5 file to the sd card and rename it to cdma.rfs the file has 0 bytes. Did the file program not copy the whole file I am using Astro File Manager? I also tried leaving the file name as stl5 just change it to stl5.rfs. I am trying to use a Prevail as my donor. Have a Sanyo Innuendo but can't it to be read by CDMA or CDMA NV Items reading. Tried connecting it to QPST first and still no luck.
  17. bwbu

    bwbu New Member

    I have the same phones, I'm stuck been trying to do this phone for over a month. Please help...HELP! Lol
  18. kolosus

    kolosus Well-Known Member

    Using the Innuendo as donor is almost impossible. Getting the aaa keys off that device IS impossible. The stl5 method outlined here is the way to use the Prevail as donor... be warned though, if you mess up the stl5 on the device that the phone will go into boot loop.

    If you're unable to copy the stl5 from the phone to the sd card then the file manager that you're using doesn't have root access. Try with something else. I've used ES File Manager with success. You can also use Root Explorer or Root Commander. Root access is a must! Cant be copied without root access. The resulting file should be about 8mb in size. Ranaming the file is not strictly necessary. You can open it as is. I usually do rename mine to meid.rfs just so it is easier to locate the file when I'm looking for info from a particular donor.

    On HTC devices the MEID and aaa needs to match. On Samsung the MEID, the aaa AND the MSL need to match.

    Good luck.
  19. alexcass4

    alexcass4 New Member

    is there a way to do this for the galaxy rush? sph-m830 the nv items are locked when i try to find them using cdma workshop and dfs
    acevell likes this.
  20. cwhatever

    cwhatever Life Goes On Guide

Loading...

Share This Page