Can't recovery, error formatting /system


Last Updated:

  1. koral

    koral Member

    Hello guyz..

    Didn't want to trouble you but i just seem to be stuck with my HTC Desire S. Got it s-off and rooted a while ago, everything was fine, did a couple of backups every now and then after deleting some stock apps, overall it worked perfect. Untill today, it just froze and I had to pull the battery, after that it wouldn't go any further than boot animation. So I went to the Revolutionary recovery and tried to restore the latest backup, got an error about wrong md5 sum. Mounted the sdcard and rebuilt the md5 sum manually. Now the error is Error formatting /system, no matter what I do I get some sort of error.

    I just don't have a clue where to go from here, should I look for stock rom, or somehow use my recovery image? I'm fairly new to android. So any help would be greatly appreciated!

    Every recovery launch prints:

    Revolutionary CWM v4.0.1.4
    E:Can't mount /cahce/recovery/command
    E:Can't mount /cahce/recovery log
    E:Can't open /cache/recovery/log
    E:Can't mount /cahce/recovery/last_log
    E:Can't open /cache/recovery/last_log

    Advertisement
  2. FoX777

    FoX777 Well-Known Member

    It isn't good, I'll tell you that much.

    Look into emmc problems with the desire s.

    Possible fix (if its just corrupted cache partitions) is to flash, say 4ext recovery, then format the cahce partition to ext3/4, I also read that you can then clear all partitions also dalvIk cache then re install your ROM and hope your emmc isn't fried
    koral and El Presidente like this.
  3. koral

    koral Member

    Thanks for your reply!

    So i can do that using a partition manager in the recovery menu yeah? If not, what tools should i use?
  4. FoX777

    FoX777 Well-Known Member

    yeah. don't need any special tools. but I suggest you do some serious reading into the topic, lots of threads around, most on xda forums.
  5. El Presidente

    El Presidente Beware The Milky Pirate! Moderator

    koral likes this.
  6. koral

    koral Member

    Is there a way to enable usb debugging from recovery? I want to use adb to check the chip.
  7. FoX777

    FoX777 Well-Known Member

    Sadly I don't think there is a way, that's why I leave mine on regardless.

    You can go ahead with the other fix and hope its just a corrupted cache.
  8. koral

    koral Member

  9. koral

    koral Member

    Okay, so according to the output of
    Code (Text):
    1. adb shell
    2. dmesg | grep mmc0
    which is
    Code (Text):
    1. <3>[    7.737213] mmc0: No card detect facilities available
    2. <6>[    7.737823] mmc0: Qualcomm MSM SDCC at 0x00000000a0500000 irq 98,0 dma 7
    3. <6>[    7.737976] mmc0: Platform slot type: MMC
    4. <6>[    7.738189] mmc0: 4 bit data mode disabled
    5. <6>[    7.738311] mmc0: 8 bit data mode enabled
    6. <6>[    7.738555] mmc0: MMC clock 144000 -> 50000000 Hz, PCLK 96000000 Hz
    7. <6>[    7.738677] mmc0: Slot eject status = 0
    8. <6>[    7.738800] mmc0: Power save feature enable = 1
    9. <6>[    7.739044] mmc0: DM non-cached buffer at ffa0f000, dma_addr 0x0ba03000
    10. <6>[    7.739166] mmc0: DM cmd busaddr 0x0ba03000, cmdptr busaddr 0x0ba03300
    11. <6>[    7.892547] mmc0: new high speed MMC card at address 0001
    12. <6>[    7.894256] mmcblk0: mmc0:0001 M4G2DE 2.10 GiB
    the eMMC is okay and still breathing.

    I'll try and push 4ext recovery image and see if formatting to ext4 will make any differece...
  10. El Presidente

    El Presidente Beware The Milky Pirate! Moderator

    Any joy?
  11. koral

    koral Member

    Not so far no, i just can't make 4ext replace the revolutionary recovery.

    Installing from zip:
    Code (Text):
    1.  
    2. installing...
    3. assert failres: write_raw_image("/tmp/recovery.img", "recovery")
    4. E:Error in /sdcard/PG88IMG.zip
    5. (Status 7)
    6. Installation aborted
    7.  
    Using adb to do the same:
    Code (Text):
    1.  
    2. /sbin/sh: su not found
    3.  
    After manual install of superuser zip it says everything went fine and install was completed, but it writes binaries to /system, which is of course, inaccessable.

    And I can't make fastboot work, it just says <waiting for devices>, although adb devices can see the phone.

    Thought of returning to stock Hboot, but the current hboot version is 6.98.2002 so i can't downgrade. Might try to install the 2.0.2002 hboot, the latest htc upgrade version 2.3.5 i think it was, but not sure if i should.

    I'm just running out of ideas.
  12. FoX777

    FoX777 Well-Known Member

    You haven't put your phone into fastboot yet.

    Boot into hboot and press the power button once after it scans your memory card.

    Don't try change your hboot. you'll lose s off. and it won't help your problem.
  13. koral

    koral Member

    Well it goest to fastboot, and it says fastboot usb, but from the terminal i still get <waiting for devices>.

    Okay, now, after tons of dmesg text, reading and googling various output, i finally bumped into:
    Code (Text):
    1.  
    2. mmc0: reinit card
    3. mmc0: Starting deferred resume
    4. mmc0: Deferred resume failed
    5.  
    Whenever i try to wipe to factory from revol recovery i get that message first and then tons of:
    Code (Text):
    1.  
    2. <3>[  248.048217] end_request: I/O error, dev mmcblk0, sector 2919244
    3. <3>[  248.048309] end_request: I/O error, dev mmcblk0, sector 2919245
    4. <3>[  248.048492] end_request: I/O error, dev mmcblk0, sector 2919246
    5. <3>[  248.048614] end_request: I/O error, dev mmcblk0, sector 2919247
    6.  
    As Ghul stated on XDA
    And mine is exactly that one. So I guess this is it then, gonna try and return it on warranty, do you think they won't be too happyt about me getting it s-off and stuff?
    FoX777 likes this.
  14. FoX777

    FoX777 Well-Known Member

    If you don't return it to stock say bye bye warranty. let's hope you still can return to stock.

    check the how to root your desire s thread section 2.
  15. koral

    koral Member

    The phone was already S-OFF when I got it. So shouldn't matter that much. But i might still try to return it to stock in case the provider changed it's policy or some other things.
  16. 1st_Paladin

    1st_Paladin Well-Known Member

    I've encountered this error. It was due to corrupt partition. Here's how I solved the problem.

    1. Backup your SD card onto your PC
    2. Using Gparted, delete your EXT partition
    3. Recreated the EXT partition and format it to EXT3 or 4 or whatever you need
    Now try mounting the EXT partition in recovery. If it works, then your partition is ok and you can try restarting.

    If it does not mount, then you may have to format your entired SD card and redo the partition.

    1. Format the SD card using Windows
    2. Using Gparted partition your SD card into 2 primary partition the first FAT32 and second EXT (whatever you need)
    3. Mount EXT to test whether it works. If you get no error message that's good.
    4. Copy back your SD card contents
    5. Try recovering your backup
  17. koral

    koral Member

    Yeah some people say that solves their problem. Although if you take the memory card out and try to start the phone, you get the same message. In my case it hasn't got anything to do with the mc. I got my phone returned to me today from HTC, everything replaced and new (UK/BT)

    And the chip is exactly the same as i had before
    Code (Text):
    1.  
    2. $ cat /sys/devices/platform/msm_sdcc.2/mmc_host/mmc0/mmc0:0001/name
    3. M4G2DE
    4.  
  18. tangerine00720

    tangerine00720 New Member

    I had exactly the same problems as you did a few weeks ago. Corrupted partition, couldn't instll 4ext. Couldn't dowgrade the boot manager, couldn't do anything etc etc.

    I've come to the conclusion the 'desire S' is an unstable phone once s-off'd and rooted. Probably why on the HTCDEV site they haven't listed it as a phone which can have the bootloader unlocked when all the other models are listed.

    Did the same as you, sent to HTC, just waiting now for it to come back. I don't think they are even charging me as I would have had an email by now.

Share This Page