Cant root my desire hd help please

Last Updated:

  1. defendos

    defendos Member

    Hello im new here and im really stuck i searched days long for a way to root my desire hd the follow things i have tried already:

    adb shell root / temp root
    superoneclick root
    advanced ace hack kit

    i also tried with goldcard but no success, i made already a goldcard for sure (a working goldcard)

    and some others i cant remember now

    i also looked and followed many guides and tutorials but with no success, so i though i go and post a thread here

    My device is the following:

    htc desire hd (ace) a9191 (Vodafone Branded but simlock free)
    S-OFF with a tool from htc official site.
    android version 2.3.5
    htc sense: 3.0
    build-version: CL208029
    Kernel version:

    i cant temproot and if i try to root it with for example with adb commands i get a $ and i need a # (temproot) and if i try the advanced ace hack kit i can get through every step but it wont root it with the file

    also when i want to downgrade i somehow get stuck with the build version or im stuck because its branded i dont know exactly, i think there is a step for step way like first unbrand then downgrade, i dont know it anymore.

    i hope i informed you guys enough, im kind of stuck so can anybody please help me through or get me some tutorials of how to do it please.

  2. CDPlant

    CDPlant Well-Known Member

    The advanced ace hack kit is the only one I know about. What happened when you tried to run it?
  3. El Presidente

    El Presidente Beware The Milky Pirate! Moderator

    Which version of the hack kit are you running? Earlier versions couldn't root
    defendos likes this.
  4. defendos

    defendos Member

    @ el presidente:
    im running this hack kit version:

    aahk-13012012 (that is the filename) more i dont know about it, if i got the wrong advanced ace hack kit could you give me a link with another please.

    @ cdplant:
    it says that everything is done good in the cmd window, and it will check the image file in my phone at the bootloader, and yes it is checking the file but it doesnt flash twice (2) as described in the last step from the cmd at the advanced ace hack kit, sorry little confused english he he, if you dont understand i can try to explain it better or show you some images.
  5. CDPlant

    CDPlant Well-Known Member

    You mention the cmd, so I assume you are using Windows. The hack kit can work with Windows, but more often that not you will run into some problems. Do you have any access to either mac osx or linux? The hack kit should run fine using one of those. It is a bit inconvenient but it will go more smoothly. If not, I will have a look and try and find a solution to the problem you have using it with Windows.
    defendos likes this.
  6. defendos

    defendos Member

    Can i use also a ubuntu live cd for example or a virtual machine with linux?
  7. El Presidente

    El Presidente Beware The Milky Pirate! Moderator

    I think the instructions state virtual machines are likely to cause errors, the live CD is the recommended method.
    defendos likes this.
  8. defendos

    defendos Member

    is there a guide for it, i only readed it once at a different forum that some people used ubuntu live cd but i didnt read further becase i was using windows, can you please help me to get a tutorial with ubuntu, and thank you already for your great help
  9. nigsy

    nigsy Well-Known Member

    Download Ubuntu live cd frome here:

    Download | Ubuntu

    burn the iso to a cd. Change your boot options in BIOS to boot from your CD/DVD drive save changes and exit. It should then boot to the live CD.

    This will run Ubuntu from the cd and not install anything on your PC, so it will run a little slow.

    To open a terminal (CMD screen in windows) right click on the desktop and select 'Open Terminal' and your away....
    defendos, CDPlant and El Presidente like this.
  10. defendos

    defendos Member

    what do i need to typ in the terminal the same things as described in guilds for windows? like "adb push" commands?
  11. El Presidente

    El Presidente Beware The Milky Pirate! Moderator

    You can run the hack kit from within Linux, run the .sh file from the terminal as opposed to adb. It should tell you what's needed in the manual.

    I don't have access to the most recent one or I'd check for you, sorry. I'm pretty sure it's in there though.
    defendos likes this.
  12. CDPlant

    CDPlant Well-Known Member

    The manual is in the zip file of the hack kit which will show you the commands to run the script. Once you run it follow the on screen instructions and its good to go :)
    defendos likes this.
  13. defendos

    defendos Member

    ok i have finally made ubuntu started and i am in ubuntu live cd desktop right now i made it to run the aahk but i asks for a PASS KEY, i know it is in the file cajun.txt but when i try to open it in ubuntu i get the text that says: nice try come back later.

    what does this mean did i something from im not very simular with ubuntu can somebody pleas help me? to open the file so i get a pass key to run the aahk in the terminal, thanks in advance
  14. tobyjuggler

    tobyjuggler Well-Known Member

    If I remember correctly, it is designed to make you read all the way to the end of the help file and near the end is a link that will take you to the pass key.
    defendos likes this.
  15. defendos

    defendos Member

    never mind the question i found it out, i was in the archive manger i guess and i had 2 aahk downloaded im really lost in ubuntu haha but the aahk program is now running in the terminal now hoping it works i keep you guys updated
  16. defendos

    defendos Member

    hmm after the pushing rom to sdcard and after temproot i get an error with unable to chmod /data/local/tmp/goldcard.img: operation not permitted, but it still is ongoing is that good? i still get to follow the steps, but i was wondering if that error is good or not
  17. defendos

    defendos Member

    hmm strange the same issue as if i try it in windows, i get to the final step that says it will check the file that has been sended to the phone and yes it does check the file after checking it says ino image or wrong image and in the steps the phone must prompt me to press volume up to continue but i dont get that i get in the boot menu with the options like reboot phone and hboot etc.

    what does this mean?
  18. gosub3000

    gosub3000 New Member

    I've the same issue here. I've tried with both 64bit Ubuntu, and 32bit Linux Mint, using aahk-13012012. Everything seems to go well, but I get the same chmod error. The phone then seems to reject the new image, and I can't progress the rooting procedure.

    I would also appreciate any tips or help here.

  19. gosub3000

    gosub3000 New Member


    I had unlocked my DHD using the tools from aahk can't deal with that, so you have to relock. Once I relocked, aahk worked like a charm!

    defendos, CDPlant and El Presidente like this.
  20. defendos

    defendos Member

    how to relock my desire hd i dont know how to do that can you please tell me how?
  21. defendos

    defendos Member

    i dont know how to relock it, if i try the tool from again it says i have a higher version ( than the allowed unlock rom ( what now is there a program to relock it?
  22. defendos

    defendos Member

    how to relock it?
  23. defendos

    defendos Member

    i found it out, just start your phone normal, plug the usb cable at the phone & pc and select charge only and make sure it is in developer mode, then go to start -> cmd and typ in fastboot oem lock, that its all you dont need to go to a specific map or program to typ that only make sure windows got your bootloader drivers installed works like a charms i now gonna use aahk i keep you guys informed if it worked
  24. El Presidente

    El Presidente Beware The Milky Pirate! Moderator

    How did you get on after you relocked the bootloader?
  25. defendos

    defendos Member

    i got everything worked im looking now for a good rom, one with automatic processor settings and improved wifi strength and if possible with looks from ice cream sandwich does some1 know a good rom?

Share This Page