Can't see SD Card after root NOOB


Last Updated:

  1. kcsoccer1

    kcsoccer1 New Member

    Hey guys

    I am a complete Noob when it comes to rooting phones so I followed Scotty's instructions and flashed a temporary recovery. I made a nandroid backup, and installed titanium backup. For whatever reason it seemed that TiBu would not see my SD card. I got busy and figured I would get back to it when I had a chance. In the mean time I found out that other items such as the camera would not see the SD card. I opened up the back and pulled the SD card and put it in a reader. The pictures from the camera are on the card I just can't see them from my pc and the phone can't seem to acknowledge that the SD card exists. Right now when I plug in the phone it only shows me charge only mode and does not give me the option to see the card.

    I am sure that I am missing something simple, but I have tried all that I know.

    Help please.

    Advertisement
  2. scotty85

    scotty85 Guides Guide

    there is an option in settings to mount your sd card,id check there first. i cant remember exactly in gingerbread,sd and storage,or something to that affect...

    also double check the obvious and make sure its in securely after you had it out to look at it in the PC.

    titanium will default to the internal sd,so youll need to change it in preferences to see sdcard 2(externel),but that does not explain not seeing it when you plug the phone in. :confused:

    if you cant remount it with settings,id try a simple reboot first.

    if no luck there,you might try a factory data reset.

    this is defiantely not a typical prollem had from unlocking and/or rooting :eek:
  3. kcsoccer1

    kcsoccer1 New Member

    When I try to mount the sd card it tells me preparing sd storage and then sd card safe to remove. So no joy there.

    When I remove the card and reseat it, it tells me sd card safe to remove.

    Simple reboot yields same message.

    Factory data reset here we go....................Success.:D

    Loaded Tibu and it actually looks like it supposed to look.:)

    Many thanks for the info and for the noob guide to rooting.
    scotty85 likes this.
  4. scotty85

    scotty85 Guides Guide

    cool :D glad that worked for you. also glad the guide was useful :cool:
  5. rcrott1

    rcrott1 Well-Known Member

    ive done a factory reset a few times now, tried to mount it, still nothing. GRRRR.
  6. scotty85

    scotty85 Guides Guide

    need more info on when/how it disapeared? have you unlocked and flashed a rom?
    chknhwk likes this.
  7. rcrott1

    rcrott1 Well-Known Member

    unlocked, TRIED flashing bamf ics v1.2, and it went in to a really long boot loop, then i did a factory wipe, it finally loaded and then if ANYTHING came in..phone call, text, email, anything...phone reboots. i try to make a call, phone reboots. SD card disappeared then...and i honestly have NO idea what to do now. im just really pissed because im EXHAUSTED and i have surgery in the AM. and NEED my phone. blah.
  8. scotty85

    scotty85 Guides Guide

    looking now,but do you have a link for the rom you tried to install? also,how did you install the kernel? was it an "automatic" reboot to flash as a PH98IMG,or did you use fastboot?

    again,the more details you give me,the faster we will fix your phone :)

    edit:
    also need to know what hboot you currently have.
    chknhwk likes this.
  9. kool kat2

    kool kat2 Well-Known Member

    Ive had this problem (not having my sd card seen) with ResROM 3.2 and 3.3 and Kanged senseless.

    Res 3.2 - wipe, flash, reboot for kernel, reboot for the patch

    Res 3.3 - was on leak, wiped, reboot for kernel (also power cycled here)

    Kanged - wiped, booted up, rebooted for kernel

    none of these saw my sd card but its functioning correctly. I cant manually mount it in settings because its like i dont have one. titanium backup and file exploresrs dont see it either. they're all 4.0.3 roms. i haven't had a problem with business ics 1.3, which is what i keep getting back to.

    how do i know what hboot i have?
  10. Bob Cat

    Bob Cat Careful, They're sharp!! Moderator

    Volume down and power get's you into hboot. Look at the top, it's there.
    kool kat2 and scotty85 like this.
  11. scotty85

    scotty85 Guides Guide

    first,a general statement,as the thread is getting a lil confusing: kool kat2 and rcrott1,neither of you are having the same issue as the OP of this thread(sd card wouldnt mount on stock rom after unlock). you are both having trouble with yuor sd card missing when flashing certain roms.

    the troubles you are having make me think that you are both simply installing roms that are not compatible with the firmware that you are running.

    i flashed the system,boot,and recovery images from the leak with the firmware from 2.01.605.11 on my s-on rezound and the phone was not useable-constant reboots. i flashed the eng hboot(wich works with gingerbread) onto my s-off rezound running the leak,and my sd card disapeared :eek: flashed the leak hboot back,and voila! sd card was back :D

    when we first got the leaks we only had the system and boot images,and devs had to make several "fixes" to make their roms work with our current firmware.

    now that we have an entire leak RUU,the devs have figured out that the "fixes" they were doing were actually not neccessary if one had flashed the ruu and was on the appropriate firmware.

    what this means is that you have to flash the new,leaked RUU in order to run certain roms.

    rezrom is one that requires the new firmware. it has a patch for old firmware,but it appears that its not really working for you for whatever reason(kool kat2). business 1.3 is based on even older firmware,so the fact that it works fine indicates that you prolly on old firmware.

    in a nutshell:
    you guys need to check your hboot as BC instructed.
    *if you find hboot 2.10.0000 or 2.11.0000 then you are on shipping(2.10) or current(2.11) firmware,and as such will need to stick to gingerbread,and some older ICS based roms

    *if you are on hboot 2.21.0000,you are on the leak firmware,and are "stuck" with ICS roms based on the 3.11.605.22 leak.

    one last bit of advice that i have,to make sure youre not installing roms without overwriting the old kernel:

    *get into the habit of launching your recovery from fastboot(follow directions for temp recovery in the root guide).
    this allows you access to the boot partition from recovery,like a traditional recovery :) after launching recovery,you can be 100% sure that there are no bits of your old rom or kernel left over by wiping:
    -data/factory reset
    -cache
    -dalvik cache
    -boot
    -system
    note that wiping boot from a permanent recovery will not work.

    if you do the above wipes,your rom will not boot if youve not successfully flashed the kernel,and wiping system will ensure that youre not mixing a bucnh of code together if the rom isnt wiping or formatting /system automatically

    hope that helps :)
    chknhwk, thornev and kool kat2 like this.
  12. rcrott1

    rcrott1 Well-Known Member

    didn't get a chance to post, but i got mine squared away yesterday
  13. scotty85

    scotty85 Guides Guide

    for others that find this in a search,what was the solution? :)
    chknhwk likes this.
  14. rcrott1

    rcrott1 Well-Known Member

    in all honesty, charliesthaman from team BAMF remote networked in to my laptop, with my permission using a secure program, and he and i worked on it for 4 hrs, wiping data.system.cache and dalvik cache a few times.....installing the ICS RUU (leaked), installing the PH98IMG.ZIP from their site, adding amon ra recovery, and upgrading to their version 1.2 upgrade.

    only issues ive had is that the phone still overheats and the battery still drains like normal. other than that...amazing ROM and an even better developer team
  15. sam21191

    sam21191 New Member

    hi. i need some help. i have dell xcd 35. i temporarily rooted my phone. and i was trying to apply metamorph themes. but it suddenly rebooted itself. after dat i cant find messages or settings in my phone. can anyone help me out.

Share This Page