Can't seem to boot into recovery mode


  1. howetechnical

    howetechnical Well-Known Member

    I followed the instructions on the how-to root sticky, but when I power down the device and then hold vol down+up simultaneously and power it back up to get to recovery mode (to root), it boots normally. I've done this 7 times now, with two fingers holding down the volume buttons (one each) and then pressing the power button until the device shows signs of life.

    Any ideas?

    Advertisement
    :
  2. howetechnical

    howetechnical Well-Known Member

    Update: Watched a video that showed you have to wait until the "Vibrant" logo flashes once, then release all buttons. Did that...4 tries later, still boots normally. Is it possible that T-Mobile had the volume buttons disabled during boot on newer shipments?
  3. howetechnical

    howetechnical Well-Known Member

    Decided to install the SDK package and use adb instead. Got it done and the lag fix, which as usual, made the Vibrant perform at Mach1 speeds.

    Never was able to get the volume keys to boot into recovery mode through boot.
  4. Casperr

    Casperr New Member

    How can they disable this? I would assume that it is through software then is there any this disabling can be fixed?
  5. simonsez

    simonsez New Member

    I tend to believe that they have disabled the ability to button into recovery on newer devices. I just got my Vibrant 3 days ago, and just today decided to root, but I can't get it to boot into recovery. I've read all over XDA, and tried every possible combination repeatedly, and it just reboots.

    I've successfully booted into download mode, with buttons but no go for recovery.
  6. FSY2K

    FSY2K New Member


    How did you manage to get into download mode using buttons? Can you provide us with instructions on how to do so? Thank you, greatly appreciate it!
  7. halr9000

    halr9000 New Member

    FYI, got my Vibrant a few weeks ago, and I also can't boot to recovery. Tried a dozen times. Thanks for the adb recommendation, didn't think of that.
  8. BartTech

    BartTech New Member

    I was having the same problem so I removed that battery for a bit and tried again. Worked!
  9. BossDj

    BossDj Well-Known Member

    to get to dl mode, this works every time on my device:

    1. turn off phone, pull battery
    2. plug phone in to usb that is connected to pc, seems connecting just a charger will not work
    3. put battery back in, and wait until you see the green battery icon
    4. hold down the vol up and vol down buttons, then press power
    5. as soon as the green battery icon disappears, let go of the power button only, should go into dl mode

    keep in mind, download mode and recovery mode are two different things, recovery mode i have not yet been successful getting into with buttons
  10. markmanjd

    markmanjd New Member

    I found that nothing works unless USB debugging is turned on.

    Then it works.

    Good luck!
  11. w_bovine

    w_bovine Well-Known Member

    booting into Recovery is another thing ROM Manager is good for. Might be worth your time to check it out.

    ROM Manager - Android app on AppBrain

    oh yes...it's for rooted phones only...
  12. cooley_l

    cooley_l Member

    I got my phone this week and this works for me every time.
    To get into recovery mode, with phone not connected to USB, hold vol keys and power button down , wait till first screen (says Vibrant) and then release power button only ,wait till yellow text appears and then release vol keys.

    To get into download mode no battery pull before hand is needed, just put phone into debugging mode then power off phone , hold vol keys down and then connect to USB and phone will go into download mode , you don't have to touch the power button. Anyhow these methods work every time for me FWIW.
  13. TuesdayClub

    TuesdayClub Well-Known Member

    I've tried the above methods and I still cannot boot into recovery...it's killing me.
  14. cooley_l

    cooley_l Member

    Your phone was powered off when you tried this right? Other than that , maybe a factory reset might help. I have a Vibrant (TMobile) and a Captivate(ATT) and those methods work without fail for me every time. Sorry I couldn't be more helpful.
  15. cooley_l

    cooley_l Member

    "he just stated man that he cant even get into recovery, my guess is he's locked out using the volume up/down keys like many new phones are (which btw is a known defect, spend 10min on the phone with tmobile doing thier trouble shooting to show them it doesnt work and they send you a replacement..) sooooo I gave him a way to get into recovery without the buttons and not having to wait till he gets to a black screen where possibly its frozen and he cant use adb commands."

    I just saw this posted on a xda vibrant forum. Time for a replacement?
  16. shaahinjjj

    shaahinjjj Well-Known Member

    try holding the power button + vol up + home button. worked for me!
  17. TuesdayClub

    TuesdayClub Well-Known Member

    I am locked out of the physical recovery method...had to do it through one-touch root/adb on the computer. My mfg date says 8/10.
  18. heleyj

    heleyj New Member



    How did you use the SDK? and what is the lag fix?
  19. TuesdayClub

    TuesdayClub Well-Known Member

    SDK is the computer side of the development package--it allows you to operate the phone through the computer...personally, I hate it (using a 10.4 Mac sucks) but it can get you into things easy.

    Lagfix (there are many) speed up the phone...search XDA for them...some only work on specific roms.
Loading...

Share This Page