1. Hot New Devices! HTC One M9 | Samsung Galaxy S6 | LG G4

Can't seem to get hello world app to run right, help?


  1. skelooth

    skelooth Member

    Hi. I never thought of myself as an idiot but I seem to be at a crossroads of competency in trying to get "Hello World" to display.

    I've followed the tutorial for hello world in eclipse using the plugin. It all seems to work fine, but when I press run as android application an emulator pops up (it looks like a big cheesy phone) and just says "Android _" .... nothing more. I tried some trouble shooting tips that involved killing the emulator process


    1. Quit the emulator if it is running
    2. Check that any emulator processes are killed (sometimes they can hang, use ps on unix or mac, or task manager in the process view on windows).
    3. Quit Eclipse
    4. From the command line, type: adb kill-server
    5. Start Eclipse and try again

    but it's done nothing to help me. I'm pretty frustrated because apparenly my google skills are slipping and can't seem to find any one who had a similar problem.

    The source for my hello world app is:
    package com.android.test;

    import android.app.Activity;
    import android.os.Bundle;
    import android.widget.TextView;

    public class myTest extends Activity {
    /** Called when the activity is first created. */
    @Override
    public void onCreate(Bundle savedInstanceState) {
    super.onCreate(savedInstanceState);
    TextView tv = new TextView(this);
    tv.setText("Hello, Android");
    setContentView(tv);
    }
    }

    Advertisement
  2. Graham

    Graham Well-Known Member

    Does the emulator boot if you go to the command prompt and type: emulator
  3. skelooth

    skelooth Member

    Yes, it does, and it does the same exact thing (just sits there saying android _)

    emulator -avd my_avd

    Attached Files:

  4. RozzaC

    RozzaC Well-Known Member

    Exactly how long are you waiting....

    Because from my experience..it takes a good few minutes for it to actually start up and show the home screen...
  5. skelooth

    skelooth Member

    I waited for a good 5-10 minutes (at least long enough for a bathroom trip and to get a drink). I also have a moderately fast/modern computer. I finally found another post similar to mine and they said they had to run it in xp compatability mode, I'm going to try that when I get home, but I'm still open to any other suggestions :)
  6. RozzaC

    RozzaC Well-Known Member

    You running Vista or XP ?
  7. skelooth

    skelooth Member

    Vista Ultimate 64 on a core2 quadcore and plenty of ram. If I continue with misfortune I might just switch back to ubuntu or something. Unfortunately the computer came with a software raid, and gparted and the ubuntu installer don't want to play nice for me.
  8. RozzaC

    RozzaC Well-Known Member

    Ah...64-bit Vista...

    You may have to use compatibility mode...

    I've never tried 64-bit so I can't tell you anyhing about it...

Share This Page