Can't send MMS from my Centura phoneSupport


  1. tjdoren

    tjdoren Member

    My wife and I both have a StraightTalk Galaxy Centura phone, and we are both unable to send text messages with images attached (I assume that is MMS). Receiving seems to be a problem, as well. I've tried it using both the stock Messaging app, as well as GoSMS. Anyone else have this issue, and is there a fix? I've seen some forums that talk about changing APN settings, but I don't know what those should be for this phone.

    Advertisement
  2. SteveCampsOut

    SteveCampsOut Well-Known Member

    I've only ever tried sending one picture and it never arrived. Plain texts go thru just fine though.
  3. mac55

    mac55 Member

    I sent pictures all the time with just the stock centura and it works fine.
  4. JooseyJay

    JooseyJay Well-Known Member

    From what I can tell they only send over 3g and not wifi
  5. SteveCampsOut

    SteveCampsOut Well-Known Member

    I was successful in sending 3 pictures to my cousin last night so I must have been trying to send over WiFi the first time....
  6. TotesMyGoats

    TotesMyGoats Member

    You have to send and receive pics over 3G
  7. Corpsecrank

    Corpsecrank Member

    I don't think it is limited to 3g only. That would make no sense at all because it would force you to use the more limited of the 2 choices.

    I just sent a picture to the other phone over wifi while typing this it works without a doubt.

    When creating a new message use the paperclip in the upper right hand corner to attach a photo. It will convert the message to mms and ask you to choose the image. If the image is to large it compresses it and then attaches it.
  8. TotesMyGoats

    TotesMyGoats Member

    No, it makes perfect sense to me. You can't send SMS over WiFi, so why would you be able to send MMS over it?
    Anyways, you HAVE to have your mobile data on to send MMS. We have 3 centuras in my house and we have WiFi. We have all tested MMS is every possible way. Mobile data off, fails. WiFi on, fails. Mobile data on, works. Both WiFi and mobile data, works.
    If you're on WiFi, it won't show you the 3G symbol, but if your signal bars are blue and not grey, then you're good to go.
  9. Corpsecrank

    Corpsecrank Member

    Wait why can't you send it over wifi exactly? I am confused I didn't think there was anything preventing it from being done.
  10. TotesMyGoats

    TotesMyGoats Member

    The same reason you can't send a text message over WiFi (with the obvious exceptions of free texting apps and such), because its not using a cell tower. It would be awesome if you could send MMS over WiFi, but I doubt carriers like Verizon will start doing it.
  11. Corpsecrank

    Corpsecrank Member


    I guess what I am getting at is that there is no actual limitation. The technology does not have a limitation preventing sms mms or anything else from being sent over it. Think about this for a moment. Without using anything special I can hold a text conversation with people on phones from my pc or laptop. Neither of those are on a cell tower and yet the phone can communicate with them. Your phone can hit your home router which means it can easily communicate with another device over the wifi on that router. So why can't it send over wifi again?

    Either because your specific model or carrier does not allow it for whatever reason. That would be the only limit. The technology contains no limit of it's own by default.

    Not that I am trying to argue or anything like that but I just don't see the reason it would be impossible to do unless there is a carrier lock or other limit put in place beyond the available tech. Something put in place afterwards to prevent it specifically.

    If that is true then it also means it can be defeated and wifi can be used for text and other stuff kind of why I want to find out what the exact reason for this is.

    From everything I am reading though it should just work. If it doesn't then there is a problem or the carrier/manufacturer has prevented it beforehand.

    Either way you should be able to find a way to do this either by fixing the problem or removing the locks.

    UPDATE: From another forum where we are talking specifically about samsung:

    Has anyone had issues sending/receiving MMS over wi-fi on the S III? I regularly use Handcent and contacted them about the issue, but there hasn't been a solution. I've tried both the stock messaging system and Go SMS with the same results. I noticed that this was also being discussed over on XDA Developers, so I thought I would contact Samsung via LiveChat today. I was basically told that Samsung designed the phone not to send MMS over wi-fi and only over the carrier's network. Does this seem correct? This is the first Samsung phone I've owned, so I don't know if this is something they've done in the past or if this is a new thing for them.

    Here's part of my transcript...

    "I have run a check on the database for you and I am sorry to inform you that, the phone is designed in such a way that there is no option to send MMS messages using WiFi network as it can be done only through AT&T network."

    "The Samsung phone is only designed in such a way that there is no option to send MMS messages using WiFi network as it can be done only through carrier network."


    Are other users not experiencing this, or is everyone else sending their MMS over their network?

    Sure this is an S3 we are talking about but it is samsung and the S3 is way better than the centura if they left it out of the S3 then the phone we have sure as hell didn't get it either.

    Like I was saying the technology by default contains no limitation against sending it the hardware manufacturer in this case samsung has simply decided to leave that out of it's hardware apparently because the carrier someone other than AT&T (I'm guessing verizon) did not support it either. It sounds like AT&T supports this and there should be no issues on that network or the phones if you wanted to send over wifi instead of 3g or 4g
  12. mac55

    mac55 Member

    Cheat... I have an old samsung feature phone that has no minutes, but does have wi-fi. I log into my g-mail account and use it to text...There is always a way. ;) :rolleyes:
  13. Corpsecrank

    Corpsecrank Member

    Oh right and in our case that is about the only option but it shouldn't be I guess is the point lol.
  14. SteveCampsOut

    SteveCampsOut Well-Known Member

    I use my Samsung Infuse with Google Voice, Talkatone and my NetZero 4G Hotspot as a spare phone. Works like a charm and it's free! :p
  15. tjdoren

    tjdoren Member

    I think this is correct, from my experience. At least with the Centura phone (maybe other phones might work differently). I also have noticed that the stock messaging program can send/receive MMS just fine, but the GoSMS app seems to have trouble with it. Has anyone figured out the settings in GoSMS to make it work?
  16. kb777

    kb777 New Member

    When sending pics always make sure u text a message with it- worked for me
  17. Ashtonian

    Ashtonian New Member

    Sometimes when in messaging, using the paperclip doesn't work to send a picture. it just says 'Sending...' and nothing happens. Our work around is to start from the picture gallery tap the picture and then select the messaging. This way always works for us.
  18. Petroglyph

    Petroglyph New Member

    My Centura successfully sent MMS and then, for no apparent reason, it refused to comply. Like Astonian described above, my phone just said 'Sending' but nothing happened. One pic was labeled 'sending' for two days.

    Found this cure in Straight Talk / Facebook >
    In Messaging Settings turn OFF Auto Download for MMS.
    Power the phone off.
    Power phone back on.
    Dial *22890 and hit Send.

    When that process finished, an MMS that had been sitting in "Download" mode since Wednesday suddenly arrived. Currently MMS can be sent and received. Hope this works for others.
  19. Ashtonian

    Ashtonian New Member


    As of April 1, 2014, sending SMS messages to phone contacts through Google Chat in Gmail was discontinued for all supported mobile operators.
  20. cbm2940

    cbm2940 New Member

    Did you turn the Auto Retrieve back on when you were done?

    Thanks!


    Found this cure in Straight Talk / Facebook >
    In Messaging Settings turn OFF Auto Download for MMS.
    Power the phone off.
    Power phone back on.
    Dial *22890 and hit Send.

    When that process finished, an MMS that had been sitting in "Download" mode since Wednesday suddenly arrived. Currently MMS can be sent and received. Hope this works for others.[/QUOTE]
  21. Petroglyph

    Petroglyph New Member

    Nope did not turn it back on.

    Must say that since that last posting I've had to do the routine twice (reboot then update roaming) to get/send MMS. Then it works again. What knocks it out is a mystery.
    Getting really irritated with wasting time on something that should be easy.
Loading...

Share This Page