Can't send MMS - help!

Last Updated:

  1. MikeR380

    MikeR380 Member

    This is driving me mad. I'm a bit new to smartphones so please bear with me if I seem a little slow.

    I can't seem to send a photo via MMS. I just get the little timer thing going round and round and eventually it times out. Every time.

    I of course googled this and it seems to be problem with some Samsung phones (this is a Galaxy Ace Plus). They say to try enabling "use packet data" (whatever this is). I did this and still no joy. I installed the Hand Cent app, but I just get the same result. It won't send. It must be some setting somewhere.

    PLEASE can someone help me????

  2. Digital Controller

    Digital Controller The Real Bass Creator Guide

    Okay so I had this problem a lot when using the stock messaging via Verizon's service, since then i switched to google voice and it sends/receives mms via email, using either mobile network or wifi, which is nice, since before it would take years to send!

    Usually what i had to do to get a MMS through, would be to either turn off wifi and turn on mobile network, or reboot the phone entirely then turn on mobile network, for some reason i couldn't get an MMS to send for the life of me over Wifi :(

    Hopefully this helps :)
  3. MikeR380

    MikeR380 Member

    I've tried three other apps for this, GO SMS Pro, Hand Cent SMS, and something else I can't remember. I've had no joy, it's the same thing, just gets stuck on sending. I've tried changing any settings I can find, using wifi, not using wifi, booting, rebooting, re-rebooting. I just can't get it to work. At all.

    As a totally unsophisticated user I just can't understand why this doesn't work, I'd have thought MMS messaging is pretty standard functionality that should just work out of the box. The phone is great otherwise and works better and more intuitively than I could ever have hoped for. Think I'll just give up on this one and be happy with the stuff that does work.
  4. mrsbelpit

    mrsbelpit Well-Known Member

    Do you have an unlocked phone? It may be as simple as looking for the proper APN settings for your carrier.
  5. MikeR380

    MikeR380 Member

    Thanks for the reply. I don't know if I have an unlocked phone! I can change the APN settings though so I think the answer is yes (?).

    I found a website with the correct settings for virgin mobile and they were slightly different to the settings in my phone. I changed them, but still the same result. Not sending.
  6. mrsbelpit

    mrsbelpit Well-Known Member

    What country are you in? Did you buy the phone from the carrier or sim free? I'll see if I can direct you to something more helpful.
  7. MikeR380

    MikeR380 Member

    I'm in the UK. I got the phone via an upgrade from Virgin mobile. Does that help?
  8. mrsbelpit

    mrsbelpit Well-Known Member

  9. MikeR380

    MikeR380 Member

    Hey thanks for the help. The settings looked right to me but I deleted them anyway, started from scratch and it works! Well, only just. I've only managed to send very small pics so far. But it's better than nothing!
  10. mikedt

    mikedt 你好 Guide

    That sounds about right for MMS, very small pictures, probably a maximum of 20-40k in size. MMS is a bit of a legacy thing from the days when cellphones only had small screens and not much storage.

Share This Page