Can't send MMS. SMS works, but not MMS.Support


  1. Bob Blaylock

    Bob Blaylock Well-Known Member

    Motorola Triumph, running the MTDEV-CM7 build 20120926. Virgin Mobile.

    If I try to send a text message with an attachment, or I try to send a text message to an email address, it gets as far as

    Attached Files:


    Advertisement
    :
  2. Sounds like a setting in your telco's system. So I would contact them.
  3. mikeca

    mikeca Well-Known Member

    It looks to me as though you are on wifo. You need to have 3g/4g to send mms. Not sure why but been there myself. It showd zero bars. Hope that helps!
  4. gtbarry

    gtbarry Well-Known Member

    When I have the exact same problem you describe above (Galaxy Nexus on t-mobile USA) it is because mobile data is turned off.

    In Jelly Bean it is:
    Settings > Data Usage > mobile data

    Note that I have to have mobile data turned on PRIOR to sending an MMS OR receiving one. If I receive an MMS with mobile data turned off, I will get the notification of a new message and I will receive the message with a download button. But if I do not have mobile data on prior, the incoming MMS attachment will not be received. Even if I turn it on after the message was received.
  5. Makes sense because SMS and MMS are phone protocols, not WiFi protocols.

    OTOH, I have sent image files per SMS/MMS when I was on WiFi using the free MySMS app... So I recommend the O.P. try that.
    Get it from the Play Store.
  6. Digital Controller

    Digital Controller The Real Bass Creator Guide

    This ^

    And This ^

    For some reason when your phone provider enables you with the ability to send and receive MMS you must have the Mobile Data enabled, even if you are using Wifi, if the Mobile Data is enabled you will be able to receive and send MMS, even if Wifi is showing as your internet on your device.

    It is a real pain, as if you do not have it on, the message can hang a lot, even when turning on Mobile Data, and might require a reboot of the device.

    Hope this helps.
  7. whohasaquestio

    whohasaquestio Active Member


    Will 2G (Edge) work for MMS?

    the VM 3G is so slow, it's almost 2G speed anyway.
  8. Bob Blaylock

    Bob Blaylock Well-Known Member

    This doesn't appear to be relevant.

    I do have JuiceDefender on my phone, set to turn various things off when they are not in use. I tried disabling it, and I find that even without JuiceDefender, my 3G goes off when I have a WiFi connection.

    Turning off WiFi, and making sure I have a 3G connection up, doesn't seem to make a difference. MMS still doesn't work even then.
  9. OverByter

    OverByter Resident Slide Rule Guru

    Edge is a GSM protocol, CDMA's counterpart is 1x rtt, and yes mms will work over it. Just for sh*ts and giggles try sending an mms message to yourself and see what happens.
  10. gras123

    gras123 New Member

    Hi

    I would like to add the solution that worked for me. I was browsing many forums for ages, before I got on the right track. Maybe it will work for you also.

    My provider has two sets of APN details: One for internet and one for mms. The tricky part for me, was setting the APN-type correctly.

    For the internet APN the type should be set to:
    Code (Text):
    1. default,supl
    For the mms APN, the type should be set to:
    Code (Text):
    1. mms
    Furthermore, I deleted all other APN's that those two.

    Here are the complete details (for the Danish provider "Bibob"):
    internet
    Code (Text):
    1.  
    2. name: Bibob internet DK
    3. APN: internet.bibob.dk
    4. Proxy: Not set
    5. Port: 8080
    6. Username: Not set
    7. Password: Not set
    8. Server: Not set
    9. MMSC: Not set
    10. Mms-proxy: Not set
    11. Mms-port: Not set
    12. MCC: 238
    13. MNC: 02
    14. Authentication Type: Not set
    15. APN-type: default,supl
    16. APN-protocol: IPv4
    17. Carrier: Not set
    18. MVNO-type: None
    19. MVNO-value: Not set
    mms:
    Code (Text):
    1. name: Bibob MMS DK
    2. APN: mms.bibob.dk
    3. Proxy: Not set
    4. Port: 8080
    5. Username: Not set
    6. Password: Not set
    7. Server: Not set
    8. MMSC: http://mms.telenor.dk
    9. Mms-proxy: 212.88.64.8
    10. Mms-port: 8080
    11. MCC: 238
    12. MNC: 02
    13. Authentication Type: CHAP
    14. APN-type: mms
    15. APN-protocol: IPv4
    16. Carrier: Not set
    17. MVNO-type: None
    18. MVNO-value: Not set
Loading...

Share This Page