can't turn on the wifi on my S4Support

Last Updated:

  1. naeemz78

    naeemz78 New Member


    i have a Samsung Galaxy S4 (gt-i9595), with the latest update (4.4.2)

    Im not able to turn on the wifi, i have had the issue for som time, i used to have the issue on he previous os aswell, and updating didnt help.

    everything else works, bt, gps etc. Its just the Wifi, if i pull down the screen and hit the wifi button, it turns faded green for a few seconds, before if turns grey. If i touch and keep the wifi button touched i go into the wifi setup, here i try to move the wifi bar to the right, but it snaps right back to the off position.
    i tried wiping the cache partition in recovery mode, and i tried a hard reset. but no wifi

    What can i do?

  2. Rukbat

    Rukbat Well-Known Member

    It's not true in every single case, but that usually indicates a hardware problem with the wifi radio. In most phones that requires a new motherboard.
  3. sreum

    sreum Well-Known Member

    I had the same issue on my phone when I first got it. Tried everything even battery pull. Then finally just held the power button down and selected shut down..... waited 5 mins turned it back on and worked fine after that.
  4. bobolinko

    bobolinko Well-Known Member

    Were it me, I would flash it all the way back to the rom I had "out-of-the-box".
    PURE STOCK. Wpe the cash and Dalvic and try to see if it will get to working again.

    It sounds like you're rooted, so before you do this, do a Nandroid backup, and if you want to, use My backup Pro, and backup your SMS, MMS, and Phone Log. My gut feeling is that it will "Miraculously", start to work like it should.

    You can then, slowly, and going step by step over a few days, bring it back to where you were before this problem came to what it is now.

    Aloha and Good Luck!
  5. Big Daddy

    Big Daddy Well-Known Member

    Ive noticed a similar problem on my gs3. And found it lies with somthing in the kernal. If youve done any flashing this will cause the issue. Try doing a complete restore in recovery. Or try using odin to flash back to stock

Share This Page