Can't upgrade to GBSupport


Last Updated: 2012-02-14 17:07:18
  1. Girevik

    Girevik Well-Known Member

    I cannot get my phone upgraded to Gingerbread via Kies Mini. I keep getting the message "SGH-I897 cannot be updated".

    I've tried it rooted and unrooted, and even did a factory reset, all to no avail. Does anyone have any other suggestions I might try?

    Advertisement
  2. geeve420

    geeve420 Well-Known Member

    May not want to go this far but you could go back to 2.1, then kies up to 2.2 and finally up to 2.3.5.

    or if you can get to download mode you could use Odin 1-click to get you there.

    Click me!!!

    1st post has 2.1 official for AT&T

    3rd post has Leaked (which has been confirmed official AT&T) 2.3.5 GB you will want the one with bootloders if you haven't been on GB before. I use it quite a bit now to return to stock after playing with ROMs.

    Post #4 has the Rogers links

    Geeve
  3. Girevik

    Girevik Well-Known Member

    I used Keis to get from 2.1 to 2.2, so my concern with doing what you suggest is that I would have the same problem upgrading I'm having now except I would be stuck at 2.1 rather than 2.2.

    I appreciate the suggestion, but I'm thinking if I can't get my phone upgraded as-is, I'll have to decide between sticking with it (I AM eligible for an upgrade in a few months), or flashing a custom rom.
  4. geeve420

    geeve420 Well-Known Member


    Right on. Might want to reread my post.

    I did give you another option that is quite painless. like I said the other option I listed is to flash official GB using Odin 1click, then you can bypass keiss altogether and have GB bootloaders ready for roming. Check the link, post #3, you will want the one with bootloaders. It's easy and fast.

    Geeve
  5. Girevik

    Girevik Well-Known Member

    Yeah, got that. Just saying that I'm hesitant to try the first option since I might end up stuck back on an older OS.
  6. geeve420

    geeve420 Well-Known Member


    Cool, I can see that! That would suck LOL!

    Just wanted to make sure you didn't miss it :)

    Geeve
  7. Girevik

    Girevik Well-Known Member

    HA! Finally got it. After all the tweaks on the phone it finally occured to me that the one variable I hadn't changed was the computer I ran the upgrade on . I installed Kies on my laptop and the dumb thing finally worked.
  8. geeve420

    geeve420 Well-Known Member


    That is awesome!! It's always the simple stuff no one thinks about. Glad you glad it!
  9. kcau

    kcau Active Member

    Kind of reminds me that most of the problems i have had with this phone are related to the pig of a piece of software 'Kies' .... not the phone itself. Keep in mind Kies (the older versions anyway) wouldn't uninstall properly, leaving old drivers etc. I would need to use the windows>prog unstall as well to get rid of it all ..... prog and usb drivers. The latest Kies installs the prog and phones drivers which the earlier version wouldn't (for me in vista).

    Since then pc connectivity has become very reliable.

    KC
  10. timbuk2

    timbuk2 Well-Known Member

    I tried it on two different computers, three different cords plus all the other 10 or 15 solutions I've heard. None work. The odd thing is I did it successfully to one Captivate and the computers do not recognize the other one. I guess I have to conclude that the phone is defective.
  11. timbuk2

    timbuk2 Well-Known Member

    Of course I just realized this post was for a different OS upgrade, but should matter....
  12. Girevik

    Girevik Well-Known Member

    What errror are you getting, exactly? I had a problem before where the USB port on my phone whent bad, but that was entirely different that the what I was seeing when I tried to upgrade and Kies was the issue.
  13. timbuk2

    timbuk2 Well-Known Member

    Don't recall exactly, but I've seen it posted (even a pic) all over the web while looking for help. :) Something like there is a device connected to the computer and windows does not recognize it. My PC does not make a sound or recognize the phone as a device for any purpose except to charge it. I've tried every suggested resolution I've run across. I suppose it might be a bad USB port on the phone.
  14. Android26

    Android26 Well-Known Member

    Yeah same here. No matter what options I tweak, my laptop never recognizes my phone anymore (except to charge). I've given up and just decided to wait until I have access to another computer before I try the GB upgrade again.

    Very frustrating.
  15. Girevik

    Girevik Well-Known Member

    In my case it was a bad USB port....it wouldn't work on any computer. I eventually had to get a replacement. I hope that's not the case for you!
  16. Trod27

    Trod27 Member

    so I had tons of issues all stemming from not being able to connect to my pc's. I tried 4 different pc's. This was going on for three weeks.
    I finally sent it to Josh at mobiletechvideos.
    He replaced the USB port and upgraded my phone to GB.
    I am posting this because I found no help here or XDA. He sent the bad usb port back which I can see the burnt connection points.
    I thought it was a software issue after trying all sorts of factory restores, backups, etc...
    Now my phone is updated to GB, rooted, and connects to my pc.
    I hope future samsung galaxys have easier ways to sync and upgrade and not rely on usb connections,IMHO!!!!

    Good luck with all your issues but you might want to look into hardware issues. I also found one of my usb cable had the identical issue. making me believe I plugged it into my phone which created short in usb. now I am very carefull to observe my usb cable to make sure it is clean.
  17. normkol

    normkol Member

    My Captivate will not be recognized by my home computer, an XP model. But no problem with my pc at work or my daughter's laptop, both Win7 computers. I used my daughter's laptop to upgrade to GB this weekend, piece of cake.

    When I upgraded my Asus Transformer Prime from 3.1 to ICS, I couldn't believe how easy it was. It downloaded over wi-fi and upgraded in about 10 minutes. That's how it should be.
  18. Android26

    Android26 Well-Known Member

    Thanks man! I haven't tried any other computers yet, but I'm inclined to think no computer will work. I broke my micro usb cord a while back, and have to literally hold it in position (or put a book on top) just to get it to charge haha.

    Honestly, if it doesn't work, I'll probably just stay on 2.2 for the remainder of my contract, instead of backing up everything and calling to ask for a replacement, etc.

    Oh gosh, that's a lot of work. Sorry to hear you had to go through all that. But yeah, if its my USB port that's the reason its not working, then I'll just keep my phone and stay on Froyo.

    Oh well, we'll see!

Share This Page