Captivate Root


  1. I did the entire root process straight from my phone! I originally tried to download the update.zip file with the default browser. It said "this content type is not supported"! WTF? Who makes a browser that can't download zip files?

    I used Skyfire to download the zip file, then renamed it and put it in the root with file manager. Performed the steps and worked like a champ! I'm running Titanium backup now to get a good backup before I get rid of these AT&Greed apps! :D
  2. sonicanatidae

    sonicanatidae Well-Known Member


    Check your APPs list.. You should see a new app called SUPERUSER.
    The Icon is a lil ninja guy.

    If you have that icon, you have root.
    MYFASTANG likes this.
  3. acandia007

    acandia007 Member

    Should i root this phone or not?
    When att or samsung releases 2.2 on this, would we be allowed to update the phone?
    I'm just worried that if i rooted my warranty would be voided and not be able to update it(not sure on that yet).
  4. acandia007

    acandia007 Member

    because i found apps via torrents and when i emailed them to my phone, the app was blocked and cannot be installed because its not from the market. im guessing i have to root my phone =/
  5. jhnstn00

    jhnstn00 Well-Known Member

    Always great to have browser options like op mini, skyfire, dolphin. Will try this at work on Friday when I get my phone. Will look at Titanium as well. Assuming it is a android app that backs up to storage card.
  6. jhnstn00

    jhnstn00 Well-Known Member

    Downloaded the zip file to storage card and renamed it on my WinMo phone. Will get new phone and move file to internal memory Friday. Woot.
  7. sdelliott31

    sdelliott31 Active Member

    I am at my wits end with my phone. I keep plugging along because of its potential. I downloaded this, mounted my sd card, renamed, copied, did the reboot and it said it could not open the file - bad. WTF, simple enough instructions. I have done worse to my iPhone, I don't understand why I'm struggling so bad.
  8. acandia007

    acandia007 Member

    when you rename the "update.zip" just put "update" dont put the .zip
    i had the same issue,but it worked with when i renamed it "update" without the .zip
  9. sonicanatidae

    sonicanatidae Well-Known Member

    From my previous post:

    5. Make sure you are putting the UPDATE.ZIP file in the right folder. When I copied mine over to my SD card, it put it in /sdcard/sd It needs to be in /sdcard. I used the file manager in the phone to move the file to the right folder. After that, it found the file and ran fine.

    Assuming its a Windows system, open a folder, then click TOOLS, FOLDER OPTIONS, VIEW, then uncheck HIDE EXTENSIONS FOR KNOWN FILE TYPES.
    This will allow you to see the extension and make sure you dont have
    a file named UPDATE.ZIP.ZIP
  10. ShaneS429

    ShaneS429 New Member

    Wow this worked great. I was thinking rooting was going to take a while, took me 30 seconds. Currently running Titanium Backup to backup my App + System Settings before I begin removing all the crapware.

    Is the paid version of Titanium Backup worth it?
  11. blazeplacid

    blazeplacid Well-Known Member


    iphone cant do any of that...thus I got an android :p
  12. sdelliott31

    sdelliott31 Active Member

    OMG.....I must be overthinking this stuff. I am sure I did the rename wrong. I will find out in a second. Hold on.......I think I did it right as I have an icon that says Super user permission. Now what? My ultimate goal is to I guess its end load apps on here. 18 steps backward, but finally one step forward!!!!! Thank you all.
  13. speedfreak32

    speedfreak32 Well-Known Member

    I have read this from top to bottom but when I connect all I can see is the larger of the two internal drives, I have the drivers installed and usb debugging checked and ask on connection checked. I never get an option to mount drives. what am i missing?
  14. rajendra82

    rajendra82 Well-Known Member

    Done deal. No issues except the built in browser not letting me download the zip file. Went ahead and downloaded it to the computer first and then put it on the sdcard. Now I can live more safely due to titanium backup.
  15. tman42

    tman42 Member

    and

    Anyone? Just wondering myself before I do this.
  16. maibee

    maibee New Member

    this worked like a charm, thanks :)
  17. rajendra82

    rajendra82 Well-Known Member

    I suspect that when the update comes OTA, it would also be available as a separately downloadable file. Since the update.zip we are currently using is simply the stock Captivate boot rom with the superuser privileges tacked on, and is otherwise unmodified, the OTA update could probably still be applied, but we would lose the root, break the apps that require root, and probably revert back to non side loading behavior until the 2.2 update boot rom gets the patches applied. It would probably be a matter of a day or two for that to happen unless Samsung locks the new boot rom down far more than this version has been.
    tman42 likes this.
  18. Foofiebeast

    Foofiebeast New Member

    I did this, and when the phone rebooted, everything seems a lot laggier, and when i launch the superuser permissions, it just launches to a black screen...

    i followed the directions exactly, what's happening?


    EDIT:
    Am I undesrtanding correctly that the superuser app, when launched doesn't actually show anything and is just a black screen? or is something wrong with my phone now?

    The lag seems to come and go, but it wasn't lagging at all before this, I'm a little worried, but mainly just confused.

    EDIT2(hah): so I understand the black screen thing now, however the lag part is still worrying me a bit. I think the lag may have been mainly just for the first 2-5 minutes or so after start up, it seems to be running better now, i'll have to keep watching it. Any thoughts?
  19. ewur36

    ewur36 Member

    this is a dumb question but how do i copy the updat.zip to my internal memory..im a former iphone user, the captivate is my first android powered phone..and im also not the greatest on a computer.. when i plug my phone into my comp my phone shows a picture of a usb and the top says mtp application.. can you please help me??
  20. circazero

    circazero Well-Known Member



    I just did this all from within the phone. its easy, I came from an iPhone too so ill try to help you out.

    1. Download Opera Mini to save the update.zip file to your phone.
    - The file is on the first post. So use opera mini to hit the download file.
    - Opera mini will ask you where to save the file to. The default should be /sdcard so save it to there.

    2. Open a program called "My Files" it should be included by default with your phone.

    3. Look for the file that was downloaded to /sdcard and rename it by holding down on it. A list will appear and click rename. and name it to "update" there is no need to add the ".zip" because it already knows what kind of file it is. ***

    4. Once it has been renamed. Turn off your phone.

    5. Hold down both the volume keys and power key as stated in the first post. "(note: let go of the power button after seeing initial boot screen, otherwise it'll continue to power cycle)"

    _______________________

    " - Select Reinstall Packages from the recovery menu using Volume Up and Down to navigate, and Power to select

    - Phone will automatically reboot, and you will have root privileges, and the Superuser program installed."



    hope this helps man. it took me less than 30 secs and it was all done within my captivate ;)
    climo, RockSolid, La Luna and 5 others like this.
  21. bw1969

    bw1969 New Member

    trying to root... When I go into system recovery, I get an error saying can't open /sdcard/update.zip (no such file or directory) Installation aborted.

    Any help is appreciated!! I thank you in advance!!
  22. djfotizo

    djfotizo Member

    Hahaa!! Yes, I sold my tilt and have both the 8125 and Fuze. When the keyboard on the Fuze went wonky, i was back to the 8125. 2G He// for sure! Gotta love the battery life on that thing though. I actually still use it with my son. Morphgear + Roms :)

    Ok, sorry for the momentary hijack down memory lane... Now back to the Captivate rooting! OMG i love this phone!
  23. belyle

    belyle Member

    Just rooted, as others stated, took all of about 30sec. Installed busybox and titanium backup, now waiting for full backup to complete before I start tweaking.

    For when I inevitably bork something, is restoring the phone as easy as keeping a backup ROM on the SD card, then booting to recovery and selecting "reinstall packages"?
  24. djfotizo

    djfotizo Member

    OMG that was tooo easy... Props to you chaoscentral.... i dont see how you could have made it any easier! :D
  25. djfotizo

    djfotizo Member

    And sideloading apps with the Sideload Wonder Machine is pretty friggin easy too... wow... Sorry winmo. This may be a lasting change!
Loading...

Share This Page