Captivate USB Drivers Links Here


  1. jazzman09

    jazzman09 Well-Known Member


    I had to change to mass storage mode and it recongnized it, then had to mount phone from pull down menu on the android tool bar and then could see it as E:

    I used the x64 drivers posted in first post. It automatically wants to connect as MTP device, have to change it to mass storage. Not sure if the July 16th Samsung drivers are for x64 windows 7, had an error when installing.
    idrankwhat and richierich like this.
  2. smeltn

    smeltn Well-Known Member

    Well I got my captivate last night. I have Windows 7 Ultimate 64 bit, and still can not get it to read it. I keep getting the USB error. I have tried installing the drivers from this site in the sticky and from the Samsung site, but no dice.
  3. jazzman09

    jazzman09 Well-Known Member


    did you try going to application in settings, usb settings and change to mass storage mode, then try connecting the phone, then it should recognize it, then on phone slide down tray and hit mount.
    DeniseJ and Crosseyed_N_Paniless like this.
  4. sundaybiker

    sundaybiker Member

    Had the same problem on Win 7 64 and 32, didn't do the mount tho, I'll try it tonight, thanks.
  5. jazzman09

    jazzman09 Well-Known Member

    Should work
  6. Jreitnauer7

    Jreitnauer7 Well-Known Member

    I'm on Windows 7 64bit and I can't get Kies to work. When trying to use the Contacts or Calendar or Firmware option, I get the message "SGH-I897 The Device does not support this service".
  7. simulator

    simulator Well-Known Member

    I couldn't get it to work for my life with Windows 7 32 bit, but it worked fine with my xp computer. I hate samsung & microsoft.
  8. GalaxyS609

    GalaxyS609 Well-Known Member

    this is the direct link from Samsungs site http://downloadcenter.samsung.com/c...3/SGH-i897_Captivate_USB_Drivers_5_02_0_2.zip
  9. rajendra82

    rajendra82 Well-Known Member


    That's odd, because my wife's Acer laptop with Windows 7 64 bit recognized the Captivate mass storage without installing any drivers. My Windows XP 32 desktop however could not until I tried moving to different ports/powered USB hub, and installed the drivers twice.
  10. simulator

    simulator Well-Known Member

    Connected fine on my xp box. Still haven't been able to on my 7 32 bit one.
  11. sundaybiker

    sundaybiker Member

    It did work after clicking Mount on the phone, thanks!
  12. simulator

    simulator Well-Known Member

    Make sure you use a usb cable that makes contacts with the pins inside the phone. One cable worked, one didn't.
    dan828 likes this.
  13. Belaflek

    Belaflek Member

    Drivers are acting squirrly. At first, when I treid to uninstall and reinstall...the software said I couldn't because the drivers were alreay installed. Nothing on the add remove or on teh device manager while showing hidden devices so I deleted some registry entries..installed, uninstalled ok adn rebooted and reinstalled then rebooted to make sure and then it froze up on attempting to install the digital Still camera driver..also the phone showed up on my drives but as two drives that were unable to be written to. Very stange as I work through this. First time on the Android OS and playing with...
  14. Belaflek

    Belaflek Member

    pointless update It took about 5 min to install ssadmdfl.sys and said it installed then froze the Digital Still Camera and nothing shows up except the device installer on the taskbar. Im trying to figure if its a driver, pc or ID10T error
  15. Belaflek

    Belaflek Member

    ya..Samsung mode no drives..mass storage shoes two new drives with nothing in them and unwritable..no SD card mind you but that cant be it..whats the point of 16gb internal storage then
  16. GalaxyS609

    GalaxyS609 Well-Known Member

    sounds like you need to select Mount from the pulldown on the top of the phone.
  17. Belaflek

    Belaflek Member

    I tried but never got it to work..I went up to windows 7 32 bit and it works fine.
    I get the feeling I flubbed the driver install at the start and had some leftover file that I just couldn't find. Ill be I could have reformatted and gone to XP again and that would have solved it too.
  18. dan828

    dan828 Member


    I've been messing with this all day-- I got it to work fine at home, but can't get it going at work. I just read this and think that's probably the problem, I'm using a generic micro-usb cable here at work, where at home I used the included one. Hopefully that's the problem, because all I've been getting so far today is that "the usb device is malfunctioning"
  19. chilli707

    chilli707 New Member

    Hi,
    I was able to connect the USB through mass storage option under applications/USB. But, after connecting to computer i cannot view the directory/folder of the phone. I see new drives on my computer (F: & G) but on clicking on them it says "please insert a disk into removable disk F:"

    Someone please advice, how do i view content of phone on my computer.
    I have windows vista.

    Thanks
  20. dan828

    dan828 Member

    so no, not the cable. It just appears that the MTB program on the phone isn't able to fully initialize, it gets to the initializing screen.... thinks for a sec, then it appears to restart. Not sure what's going on, but I've unrooted and factory reset and it still won't connect. Thing is, it was working fine before, so I'm going to assume it was something in the rooting procedure, or a screwup on my part doing so, that is causing this. Is there anyway to reflash a fresh rom back onto it?
  21. dan828

    dan828 Member

    Well, as a further on this, it's working now after I unmounted and formated both the internal and external SD cards.
  22. c0ld29

    c0ld29 Member

    Question... I've tried uninstalling and reinstalling the drivers literally 10 times, restarting the computer each time, I've tried doing it with the Kies program and kies selected, tried mass storage and mounted it, media player, and pc internet, and when I connect my phone to any usb hub (I'm on windows XP) it does the same thing,

    it pops up saying "Found new hardware - Samsung_android" and then the found new hardware wizard pops up. If I do the "Install software automatically" it says that nothing could be found and my phone doesn't connect.
    If I do "Install from a specific location" and select where the drivers were installed, it does the same thing and says it cant find the necessary hardware also.

    Is there something I'm missing? Once I install the drivers from the file shouldn't the computer automatically know how to use them? Is there a step I am missing?

    Edit: I also unmounted and formatted the internal SD card, not sure if that makes a difference
  23. ric3bowl

    ric3bowl Active Member

    So I tried to install the drivers on my winxp pc, but I got a popup message that installing this may destabilize my pc. Does anyone else get this message?
  24. c0ld29

    c0ld29 Member

    mine says something like that about windows xp hasn't tested it for compatibility and or something.
  25. dave6

    dave6 New Member

    I think I might have figured it out but have to try it. Samsung's sync software is called Samsung Kies, the phone is defaulted to try to use it to connect. I wondered what that was till I read the manual lol Its page 133 manual here Support for Samsung Captivate? (SGH-i897) SAMSUNG
    According to their site it is not available in US. You can change setting to use Windows Media Player or use phone as mass storage device.

    If you want Kies, you could click on Canada at Samsung Apps. to get a copy, I will try WMP.
Loading...
Similar Threads
  1. IamAl
    Replies:
    8
    Views:
    1,047
  2. supersales5
    Replies:
    0
    Views:
    538
  3. mi_canuck
    Replies:
    8
    Views:
    1,449
  4. bigch0ps
    Replies:
    7
    Views:
    4,002

Share This Page