Captivate wifi problem


  1. fourseventwofour

    fourseventwofour New Member

    I have a rooted samsung captivate with sideloading enabled. After experimenting with different wifi tethering apps from the unofficial market, I began experiencing difficulties with my wifi connection. Even after uninstalling every app that I thought was changing the wifi state, the problem still persists. I can turn on the wifi and it will act normally for about 30 seconds before turning off without user intervention. In dmesg, the error is as follows: 'mmc1: Got command interrupt 0x00060001 even though no command operation was in progress.' Is this caused by an app or is this a more complicated problem? Does anyone have any ideas on how to fix this? Any help or ideas would be appreciated.

    Advertisement
    :
  2. fourseventwofour

    fourseventwofour New Member

    Bump. Does anyone know what's happening?
  3. Brandon0810

    Brandon0810 New Member

    I have just started having similar problems today. My captivate is rooted and has been for weeks. Just today for some reason the wifi has stopped working correctly. I turn it on and after 30 seconds or so it shuts its self off. Just after turning on wifi I tried to search for networks and it says cannot search for networks amd shuts of the wifi. HELP PLEASE.
  4. mui

    mui Member

    I've experienced something similar as well and I think this is what helped me: Turn off WiFi in the notification tray, remove the file /data/wifi/bcm_supp.conf (I used Root Explorer, but "rm <file>" in shell after "su" should be ok), then turn on WiFi. This will re-generate the file and ask you again for the SSID, password, etc.
  5. Brandon0810

    Brandon0810 New Member

    Effing brilliant man, works perfectly, a million thank yous.
  6. czpaladin

    czpaladin New Member

    My wifi.conf file is corrupt. Could anyone upload me a copy or txt of wifi.conf's guts?
  7. fourseventwofour

    fourseventwofour New Member

    I managed to fix my problem by changing the owner of the modified settings.db file to system.

    Code (Text):
    1.  
    2. su
    3. chown system /dbdata/databases/com.android.providers.settings/settings.db
    4.  
    This would probably only work if you edited your settings.db file to enable sideloading.
  8. fourseventwofour

    fourseventwofour New Member

    Here you go dudehammer.

    Attached Files:

    • wifi.zip
      File size:
      551 bytes
      Views:
      292
  9. mudwoman

    mudwoman Member

    My Captivate WAS connecting to our home wifi network when I bought the thing three days ago, and now it is NOT connecting. Wifi is ON, the network is showing, the password is correct (changed NOTHING since it worked earlier), and the word "Scanning" pops up from time to time, but the Wifi status keeps showing "Disconnected." I have no idea what rooting or settings.db are, or where to find them, and therefore have changed none of these that I know of on this brand-new phone. I have not done any unlocking or sideloading or anything else. But the wifi was connecting, and now it is not.

    When I select our home network from the list (there are two listed, but the other one is elsewhere, not in range), a dialoge box pops up, signal shows as "Good." I hit "Connect," but nothing happens. Wifi status still reads "Disconnected," even after several minutes.

    There is a "WPS button connection" option, so I thought I'd try that. If I hit it, I get a meter that shows progress of something, and the message says "Press WPS on your Wifi access point within 2 minutes." WHAAAA??? I do not have (that I know of) a WPS to "press." My Netgear router has no such button. And I didn't have to TOUCH the router previously, when the phone wifi WAS connecting. Why is it not connecting automatically now, like it was a couple of day ago?

    If this were a laptop, I'd delete my home network, and then re-enter it, but there appears to be no way to do that, either. I
  10. Dennis_Bham

    Dennis_Bham Well-Known Member

    Maybe ... in menu/ WiFi settings/Wi-Fi networks, long press your home network and select forget network ... then re-enter it ...
  11. mudwoman

    mudwoman Member

    Tried that. Only thing is does is forget the password. Tried it again just now to be sure, but again, just forgets that password. Reentered it, and still sits there "Disconnected."

    OK, just saw "long press" in your response. So tried that, selected "forget network," and it does not delete the network. Again, just seems to forget the password.
  12. acertainman

    acertainman Active Member

    This may be a dumb question, but have you power-cycled your router? You might try that.
  13. mudwoman

    mudwoman Member

    Not a dumb question. Yes, I did power-cycle the router, twice. Once before trying to connect, and once while the WPS button connection option was counting down the 2 minutes.

    I see a lot in these threads about wifi.config and db files, and I hope I don't need to get into any of that, or I'm taking the phone back. I haven't messed with any of the factory settings that I know of.
  14. mudwoman

    mudwoman Member

    I did not realize this until I poked around in my Netgear router settings, but I had to enter my Captivate and its MAC address on the Wireless Card Access List under my Advanced Wireless Settings. Not every router is set up to require this, of course. But now it's working consistently. :D (This also probably explains why my brother can never get on the internet when he's here.)
    tyson4lyfe likes this.
  15. Jirv311

    Jirv311 Active Member

    This sounds like you have MAC Filtering turned on in your router. This should not be required at all.

    My issue is somewhat of the same nature. I can connect to my home network just fine. If I go to work, I have an access point there that my Captivate has already connected to but it doesn't automatically connect. I am using the WiFi Manager widget on my home screen. If I tap that, I can see my "Favorite" network and if I tap it, I can hit connect and it will connect right away. If however, I don't hit Connect but actually go into the phone settings, under Wireless Networks, I see my network there but it usually says something to the effect of Disconnected. Again, I can tap it and it will connect right up. Strange that it connects, yet not automatically. I believe I tested this without the WiFi Manager widget installed and same thing.

    Currently running Cognition 2.2 Beta 7 but this was happening on 2.1 as well.
  16. wraphd

    wraphd New Member

    I have this problem with wifi (connects, works for a minute of two, then loses connection) and tried all fixes suggested here and elsewhere. The only solution that works for me is to:
    go to wifi settings on phone and "forget" connection, turn off wifi on phone, access router settings through computer and change wireless security type to something other than what it usually is (i.e, from WPA to WEP), save those settings, turn on wifi on phone and let it find 'new' network, put in password and have it connect. These settings can then be changed back (to WPA, for example) and wifi remains solid. For me this holds until I am forced for whatever reason to re-boot phone, at which point fix needs to be repeated. Hope this helps.
  17. ampower14

    ampower14 New Member



    how Do I find this files? cause I'm using droid explorer and I cant find those files
  18. kmcclendon

    kmcclendon New Member

    Did you ever figure this out? I have the same problem my captivate worked perfectly fine until I did the 2.2 update and now it does the same thing, it will not automatically connect to the wifi I have to manually scan several times before it connect. I even got a replacment phone cause att or samsung could not figure it out and the replacement does the same thing. If you found a solution please let me know!
  19. PainDr

    PainDr New Member

    for all having problems try this:
    go to /system/etc/wifi/wifi.conf

    cut out the wifi.conf and past it some where you can remember. Reboot the phone and re-past the file in its original place. Reboot again. This fixed my problem. No modification had to be done.
  20. t3chn0s1s

    t3chn0s1s Member



    Thank you! I was having the SAME problem on my rooted Captivate running Serendipity VII and this method worked like a charm! OMG, thank you. I was beginning to think I had to find a new modem!
  21. Chynakatt

    Chynakatt New Member

    Samsung Captivate rooted with sideloading enabled.
    I'm having a similar problem. Phone wifi works great at home, out and about, no problems. For some reason, it will not work on the open wifi at work. It shows 'obtaining IP address" then doesn't connect.
    I can't screw around with the modem at work. I've forgotten network, turned off wifi, turned off phone...still won't work. I got FXR WiFi Fix and Rescue, which totally nukes all of your wifi passwords, but it does fix the problem for a few weeks. Then I walk into work and it just won't work again. Several other folks are using the work wifi and haven't had these issues.
    I'm considering a factory reset but I don't want to hassle with setting everything up again. Not incredibly savvy computer user so go easy on the mumbo jumbo talk, please. Thanks.
  22. tyson4lyfe

    tyson4lyfe New Member

    Had the same issue with wifi. My home network wouldn't stay logged. My wife's Iphone stays connected so I knew the router wasn't acting up. So I did what mudwoman suggested. I added the Mac address to the LAN IP section of the advance tab using one of the IP addresses it lists ranging from 10-19. I used 15 and low and behold, works perfect for now. It connected right away. So we will monitor this for a few and see what happens
  23. pharm2k

    pharm2k New Member

    I did this but in the process I lost the wifi.conf file and now I get the "wi-fi error" message. Can someone please upload the wifi.conf file for me? I restored system data with titanium data to no avail. Thanks.
  24. KCoop

    KCoop New Member

    i just downloaded the root explorer found this file deleted it and still nothing happened with my wifi...also i do keep getting a force close due to a tethering manager...which i dont have enabled because of my data plan...im just confused now..somebody plz help

    i upgraded my phone to gingerbread and rooted it using odin..started messing around with metamorph and discovered the problem
  25. Johnnyis138

    Johnnyis138 New Member

    I am also having this issue after upgrading to Gingerbread.

    I've tried deleting the file /data/wifi/bcm_supp.conf. I've also tried moving the wifi.conf file and moving it back.

    Any other ideas?
Loading...

Share This Page